MSRA Mode
Contents
  • Welcome to the MSRA Operating Mode
  • Typical Applications
  • Measurements and Result Displays
  • Applications and Operating Modes
  • MSRA Basics
  • Configuration
  • Analysis
  • How to Perform Measurements in MSRA Mode
  • Measurement Example: Analyzing MSR Signals
  • Remote Commands to Perform Measurements in MSRA Mode
  • List of Commands
Top


Welcome to the MSRA Operating Mode

MSRA Mode > Welcome to the MSRA Operating Mode
Welcome to the MSRA Operating Mode

The MSRA operating mode is part of the standard R&S FSW firmware and adds functionality to perform multi-standard radio analysis.

The R&S FSW MSRA operating mode features:

  • analysis of the same I/Q data in more than one application
  • analysis of correlated effects due to multiple standards
  • configuration of data acquisition settings only required once for all applications
  • overview of all results in one screen in addition to large display of individual results
  • common analysis line (time marker) across all applications
  • performing measurements in the frequency and time domain (such as channel power measurements) on I/Q data

This user manual contains a description of the functionality specific to the MSRA operating mode, including remote control operation.

All functions not discussed in this manual are the same as in Signal and Spectrum Analyzer mode and are described in the R&S FSW User Manual. The latest version is available for download at the product homepage

http://www2.rohde-schwarz.com/product/FSW.html.

For information on how to configure an MSRA measurement see "Configuration".

For background information on MSRA measurements and the MSRA concept see "MSRA Basics".

Contents
  • Starting the MSRA operating mode
  • Understanding the Display Information


Starting the MSRA operating mode

MSRA Mode > Welcome to the MSRA Operating Mode > Starting the MSRA operating mode
Starting the MSRA operating mode

MSRA is a new operating mode on the R&S FSW.

To activate the MSRA operating mode

  1. Press the MODE key on the front panel of the R&S FSW.

    A dialog box opens that contains all operating modes and applications currently available on your R&S FSW.

  2. Select the "Multi Standard Radio Analyzer" tab.

  3. Confirm the message informing you that you are changing operating modes.

    The R&S FSW closes all active measurement channels in the current operating mode, then opens a new measurement channel for the MSRA operating mode.

    In addition to the "MSRA View", an "MSRA Master" tab is displayed.

    For details see "Applications and Operating Modes".

    The Sequencer is automatically activated in continuous mode (see "Using the Sequencer in MSRA Mode"), starting an I/Q Analyzer data acquisition with the default settings (but with a "Spectrum" result display). It can be configured in the MSRA "Overview" dialog box, which is displayed when you select the "Overview" softkey from any menu (see "Configuration").

Remote command:

INST:MODE MSR, see INSTrument:​MODE


Understanding the Display Information

MSRA Mode > Welcome to the MSRA Operating Mode > Understanding the Display Information
Understanding the Display Information

The following figure shows a screen display during MSRA operation. All different information areas are labeled. They are explained in more detail in the following sections.

  • The orange background of the screen behind the measurement channel tabs indicates that you are in MSRA operating mode.
  • The [image] icon on the tab label indicates that the displayed trace (e.g. in an MSRA application) no longer matches the currently captured data. This may be the case, for example, if a data acquisition was performed in another application. As soon as the result display is refreshed, the icon disappears.
  • The [image] icon indicates that an error or warning is available for that measurement channel. This is particularly useful if the MSRA View tab is displayed.

An orange "IQ" indicates that the results displayed in the MSRA application(s) no longer match the data captured by the MSRA Master. The "IQ" disappears after the results in the application(s) are refreshed.

1 = MSRA View (overview of all active channels in MSRA mode)
2 = MSRA Master (data acquisition channel with global configuration settings)
3 = Measurement channel tab for individual MSRA application
4 = Channel bar for firmware and measurement settings of current application
5+6 = Window title bar with diagram-specific (trace) information and analysis interval (applications)
7 = Diagram area
8 = Diagram footer with diagram-specific information, depending on evaluation
9 = Instrument status bar with error messages, progress bar and date/time display

The diagram area varies depending on the type of measurement channel, as described in detail in the following topics.

Window title bar information

For each diagram, the header provides the following information:

Window title bar information in MSRA mode
1 = Window number
2 = Window type
3 = Trace color
4 = Trace number
5 = Detector
6 = Trace mode
7 = Analysis interval
8 = Analysis line indication
Diagram footer information

The information in the diagram footer (beneath the diagram) depends on the evaluation:

  • Center frequency
  • Number of sweep points
  • Range per division (x-axis)
  • Span (Spectrum)
Status bar information

Global instrument settings, the instrument status and any irregularities are indicated in the status bar beneath the diagram. Furthermore, the progress of the current operation is displayed in the status bar.

If an error or warning is available for a measurement channel, the [image] icon is displayed next to the tab label in the channel bar.

Contents
  • MSRA View
  • MSRA Master
  • MSRA Applications


MSRA View

MSRA Mode > Welcome to the MSRA Operating Mode > Understanding the Display Information > MSRA View
MSRA View

The MSRA View is an overview of all active channels in MSRA mode, similar to the MultiView tab in Signal and Spectrum Analyzer mode. At the top of the screen the MSRA Master is displayed, i.e. the application that captures data. Beneath the MSRA Master, all active applications are displayed in individual windows. Each application has its own channel bar with the current settings as well as a button in order to switch to that application tab directly.

The MSRA View displays the following basic elements:

1 = Channel information bar for the MSRA Master
2 = Application data coverage for each active application
3 = Result display for MSRA Master (for entire capture buffer)
4 = Channel information bar for application with button to switch to application tab
5 = Result display for application (for analysis interval)


MSRA Master

MSRA Mode > Welcome to the MSRA Operating Mode > Understanding the Display Information > MSRA Master
MSRA Master

The MSRA Master is the only channel that captures data. It also controls global configuration settings for all applications. The MSRA Master channel itself is implemented as an I/Q Analyzer application. The MSRA Master measurement channel cannot be deleted or replaced.

The following figure shows the screen elements specific to the MSRA Master.

1 = Channel information bar for the MSRA Master
2 = Data coverage for each active application
3 = Analysis line
4 = Result display for MSRA Master (for entire capture buffer)
Channel bar information

The channel bar shows the firmware and measurement information for data acquisition and global configuration.

Information displayed in the channel bar for the MSRA Master
Ref Level | Reference level
(m.+el.)Att | (Mechanical and electronic) RF attenuation
Ref Offset | Reference level offset
Freq | Center frequency
AQT | Defined measurement time, i.e. the duration of data acquisition to the capture buffer
Rec Length | Defined record length (number of samples to capture)
SRate | Defined sample rate for data acquisition
RBW | (Spectrum evaluation only) Resolution bandwidth calculated from the sample rate and record length

In addition, the channel bar also displays information on instrument settings that affect the measurement results even though this is not immediately apparent from the display of the measured values (e.g. transducer or trigger settings). This information is displayed only when applicable for the current measurement. For details see the R&S FSW Getting Started manual.

Data coverage for each active application

Each application obtains an extract of the data captured by the MSRA Master (see also "Multi-Standard Analysis"). Generally, if a signal contains data channels for multiple standards, the individual applications are used to analyze the channel for the corresponding standard. Thus, it is of interest to know which application is analyzing which part of the captured data, or more precisely, which data channel. The MSRA Master display indicates the data covered by each application, restricted to the channel bandwidth used by the corresponding standard, by vertical blue lines labeled with the application name. For applications that support several standards (e.g. VSA, LTE) an estimated or user-defined bandwidth is indicated.


MSRA Applications

MSRA Mode > Welcome to the MSRA Operating Mode > Understanding the Display Information > MSRA Applications
MSRA Applications

The data captured by the MSRA Master measurement (or only parts of it) can be evaluated by various applications. The measurement channel for each application contains the settings and results for the application data extract from the capture buffer.

The following figure shows the screen elements specific to the MSRA application tabs.

1 = Channel information bar for application
2 = Analysis interval for current evaluation
3 = Result display for analysis interval
4 = Analysis line

The display for the individual MSRA applications is identical to the display in Signal and Spectrum Analyzer mode except for the following differences:

  • The analysis interval indicates which part of the capture buffer is being evaluated and displayed in each window.
  • The acquisition time indicated in the channel bar (Meas Time) indicates the analyzed measurement time, not the captured time.
  • Any bandwidth or sample rate values refer to the application data, not to the actual data acquisition from the input signal.
  • The analysis line for time-based displays is only available in MSRA mode. It represents a common time marker in all applications whose analysis interval includes that time (see "Analysis line").

For details on the individual application displays see the "Measurements and Results" topic for those applications.


Typical Applications

MSRA Mode > Typical Applications
Typical Applications

The technological advances made in the field of mobile radio have given rise to a wide variety of standards over the past several decades. These standards, which include those produced by the global cooperative for standardization – the 3rd Generation Partnership Project (3GPP) – are based on various transmission technologies. Network operators can deploy GSM/EDGE, WCDMA, TD-SCDMA and LTE or combinations of these four standards.

To handle these complex scenarios, the Multistandard Radio Base Station (MSR-BS) was developed. These can transmit and receive multiple standards simultaneously on various carriers. An MSR-BS combines at least two different radio access technologies (RAT).

Specifications and Tests

3GPP has published the specifications TS 37.141 and TS 37.104 for multistandard base stations. The latter describes the minimum requirements for multistandard base stations in terms of RF requirements for the downlink and uplink. TS 37.141 defines the tests and test requirements for the MSR-BS based on these RF requirements.

To allow for efficient MSR-BS testing, TS 37.141 includes test configurations. The goal of these test configurations is to significantly reduce the complexity of the many possible test scenarios. They are limited to the worst-case scenarios with the strictest criteria. Thus, for example, a test configuration is provided for receiver tests in which two signals – a GSM carrier and an LTE carrier with a BWChannel = 5 MHz – are positioned at the lower and upper edge of BWRF while maintaining Foffset-RAT. This allows receiver tests to be performed with a configuration that fully utilizes the maximum bandwidth BWRF of the MSR-BS.

MSR-BS Testing using R&S FSW Multi-Standard Radio Analysis

The newly introduced R&S FSW MSRA mode allows you to capture signals from a multistandard base station and analyze the same data in various standard applications.


Measurements and Result Displays

MSRA Mode > Measurements and Result Displays
Measurements and Result Displays
MSRA measurement

The only true measurement in MSRA mode in which I/Q data from the input signal is captured and stored is performed by the MSRA Master. This data acquisition is performed as in the I/Q Analyzer application, i.e. a specified frequency span of the input signal is swept for a specified measurement time. The captured I/Q data can then be analyzed in various different applications.

Result displays

The data that was captured by the MSRA Master can be evaluated in various different applications. All evaluation modes available for the MSRA applications are displayed in the selection bar in SmartGrid mode.

For details on working with the SmartGrid see "Laying out the Result Display with the SmartGrid" .

The result displays available in MSRA mode are those described for the individual applications. The MSRA Master is implemented as an I/Q Analyzer application and has the same result displays.

See "Measurement and Result Displays" for a description of the result displays available for the I/Q Analyzer and thus the MSRA Master.

Measurements in the time and frequency domain

The I/Q Analyzer application (not Master) in MSRA mode can also perform measurements on the captured I/Q data in the time and frequency domain (see also "Measurements in the Time and Frequency Domain").

This allows you to perform standard-specific and general power measurements (such as ACLR or SEM) or statistical evaluations, as well as analyzing the EVM or modulation accuracy, on the same captured I/Q data.

Time and frequency-based measurements are configured using the same settings and provide similar results as in the Spectrum application. In addition, the analysis interval used for the measurement is indicated as in all MSRA applications.

The time and frequency domain measurements and the available results are described in detail in "Measurements" .


Applications and Operating Modes

MSRA Mode > Applications and Operating Modes
Applications and Operating Modes

The R&S FSW provides several applications for different analysis tasks and different types of signals, e.g. W-CDMA, I/Q analysis or basic spectrum analysis. When you activate an application, a new measurement channel is created which determines the measurement settings for that application. The same application can be activated with different measurement settings by creating several channels for the same application. Each channel is displayed in a separate tab on the screen.

The maximum number may be limited further by the available memory on the instrument.

independent vs correlating measurements

With the conventional R&S FSW Signal and Spectrum Analyzer you can perform several different measurements almost simultaneously. However, the individual measurements are independent of each other - each application captures and evaluates its own set of data, regardless of what the other applications do.

In some cases it may be useful to analyze the exact same input data using different applications. For example, imagine capturing data from a base station and analyzing the RF spectrum in the Analog Demodulation application. If a spur or an unexpected peak occurs, you may want to analyze the same data in the I/Q Analyzer to see the real and imaginary components of the signal and thus detect the reason for the irregular signal. Normally when you switch to a different application, evaluation is performed on the data that was captured by that application, and not the previous one. In our example that would mean the irregular signal would be lost. Therefore, a second operating mode is available in the R&S FSW: Multi-Standard Radio Analyzer (MSRA) mode.

Multi-Standard Radio Analyzer mode

In Multi-Standard Radio Analyzer (MSRA) mode, data acquisition is performed once as an I/Q measurement, and the captured data is then evaluated by any number of applications for different radio standards. Data acquisition and global configuration settings are controlled globally, while the evaluation and display settings can be configured individually for each application. Using the Multi-Standard Radio Analyzer, unwanted correlations between different signal components using different transmission standards can be detected. Thus, for example, an irregularity in a GSM burst can be examined closer in the R&S FSW 3G FDD BTS (W-CDMA) application to reveal dependencies like a change in the EVM value.

Multi-Standard Realtime mode

In order to combine the advantages of the MSRA mode with its correlated measurements and the gapless results provided by realtime measurements, a third operating mode has been introduced: the Multi-Standard Realtime (MSRT) mode. This operating mode is only available if one of the realtime options (R&S FSW-K85R/-U85R/-K160R/-U160R) is installed.

In this operating mode, data acquisition is performed once as a realtime measurement, and the captured data is then evaluated by any number of applications. Thus, a realtime measurement triggered with a frequency mask can be performed, and the results can be evaluated in the VSA application, for example, to detect the cause of a frequency exception.

Distinct operating modes

Although the applications themselves are identical in all operating modes, the handling of the data between applications is not. Thus, the operating mode determines which applications are available and active. Whenever you change the operating mode, the currently active measurement channels are closed. The default operating mode is Signal and Spectrum Analyzer mode; however, the presetting can be changed.

Remote command:

INST:MODE MSR, see INSTrument:​MODE

Switching between applications
When you switch to a new application, a set of parameters is passed on from the current application to the new one:
  • center frequency and frequency offset
  • reference level and reference level offset
  • attenuation

After initial setup, the parameters for the measurement channel are stored upon exiting and restored upon re-entering the channel. Thus, you can switch between applications quickly and easily.

Contents
  • Available Applications
  • Selecting the Operating Mode and Application
  • Using the Sequencer in MSRA Mode


Available Applications

MSRA Mode > Applications and Operating Modes > Available Applications
Available Applications

The R&S FSW provides some applications in the base unit while others are available only if the corresponding firmware options are installed.

Currently, only applications for base-station tests and those that process I/Q data are supported in MSRA mode, in particular:
  • I/Q Analyzer
  • Analog Demodulation
  • Pulse measurements
  • GSM
  • Transient Analysis
  • 3G FDD BTS
  • cdma2000 BTS
  • 1xEV-DO BTS
  • Vector Signal Analysis (VSA)
  • LTE (Downlink)
└ I/Q Analyzer
└ Analog Demodulation
└ Pulse Measurements
└ GSM
└ Transient Analysis
└ Vector Signal Analysis (VSA)
└ 3G FDD BTS
└ TD-SCDMA BTS
└ cdma2000 BTS
└ 1xEV-DO BTS
└ LTE DL


I/Q Analyzer

MSRA Mode > Applications and Operating Modes > Available Applications > I/Q Analyzer
I/Q Analyzer

The I/Q Analyzer application provides measurement and display functions for digital I/Q signals. Evaluation of the captured I/Q data in the frequency and time domain is also possible.

For details refer to "Welcome to the I/Q Analyzer Application" .

Remote command:

INST:SEL IQ, see INSTrument[:​SELect]


Analog Demodulation

MSRA Mode > Applications and Operating Modes > Available Applications > Analog Demodulation
Analog Demodulation

The Analog Demodulation application requires an instrument equipped with the corresponding optional software. This application provides measurement functions for demodulating AM, FM, or PM signals.

For details refer to "Welcome to the Analog Demodulation Application" .

Remote command:

INST:SEL ADEM, see INSTrument[:​SELect]


Pulse Measurements

MSRA Mode > Applications and Operating Modes > Available Applications > Pulse Measurements
Pulse Measurements

The Pulse application requires an instrument equipped with the Pulse Measurements option, R&S FSW-K6. This application provides measurement functions for pulsed signals.

For details refer to "Welcome to the Pulse Measurements Application" .

Remote command:

INST:SEL PULSE, see INSTrument[:​SELect]


GSM

MSRA Mode > Applications and Operating Modes > Available Applications > GSM
GSM

The GSM application requires an instrument equipped with the corresponding optional software. This application provides measurement functions for measuring GSM signals.

For details refer to "Welcome to the GSM Application" .

Remote command:

INST:SEL GSM, see INSTrument[:​SELect]


Transient Analysis

MSRA Mode > Applications and Operating Modes > Available Applications > Transient Analysis
Transient Analysis

The Transient Analysis application requires an instrument equipped with the Transient Analysis option, R&S FSW-K60. This application provides measurements and evaluations for Transient Analysis.

For details refer to "Welcome to the Transient Analysis Application" .

Remote command:

INST:SEL TA, see INSTrument[:​SELect]


Vector Signal Analysis (VSA)

MSRA Mode > Applications and Operating Modes > Available Applications > Vector Signal Analysis (VSA)
Vector Signal Analysis (VSA)

The VSA application requires an instrument equipped with the Vector Signal Analysis option, R&S FSW-K70. This application provides measurements and evaluations for Vector Signal Analysis.

For details refer to "Welcome to the Vector Signal Analysis Application" .

Remote command:

INST:SEL DDEM, see INSTrument[:​SELect]


3G FDD BTS

MSRA Mode > Applications and Operating Modes > Available Applications > 3G FDD BTS
3G FDD BTS

The 3G FDD BTS application requires an instrument equipped with the 3GPP Base Station Measurements option, R&S FSW-K72. This application provides test measurements for WCDMA downlink signals (base station signals) according to the test specification.

RF measurements are not supported in MSRA mode.

For details refer to "Welcome to the 3GPP FDD Applications" .

Remote command:

INST:SEL BWCD, see INSTrument[:​SELect]


TD-SCDMA BTS

MSRA Mode > Applications and Operating Modes > Available Applications > TD-SCDMA BTS
TD-SCDMA BTS

The TD-SCDMA BTS application requires an instrument equipped with the TD-SCDMA BTS Measurements option, R&S FSW-K82. This application provides test measurements for TD-SCDMA BTS downlink signals (base station signals) according to the test specification.

RF measurements are not supported in MSRA mode.

For details refer to "Welcome to the TD-SCDMA Applications" .

Remote command:

INST:SEL BTDS, see INSTrument[:​SELect]


cdma2000 BTS

MSRA Mode > Applications and Operating Modes > Available Applications > cdma2000 BTS
cdma2000 BTS

The cdma2000 BTS application requires an instrument equipped with the cdma2000 BTS Measurements option, R&S FSW-K82. This application provides test measurements for cdma2000 BTS downlink signals (base station signals) according to the test specification.

RF measurements are not supported in MSRA mode.

For details refer to "Welcome to the Applications" .

Remote command:

INST:SEL BC2K, see INSTrument[:​SELect]


1xEV-DO BTS

MSRA Mode > Applications and Operating Modes > Available Applications > 1xEV-DO BTS
1xEV-DO BTS

The 1xEV-DO BTS application requires an instrument equipped with the 1xEV-DO BTS Measurements option, R&S FSW-K84. This application provides test measurements for 1xEV-DO BTS downlink signals (base station signals) according to the test specification.

RF measurements are not supported in MSRA mode.

For details refer to "Welcome to the Applications" .

Remote command:

INST:SEL BDO, see INSTrument[:​SELect]


LTE DL

MSRA Mode > Applications and Operating Modes > Available Applications > LTE DL
LTE DL

The LTE Downlink application requires an instrument equipped with the LTE Downlink option, R&S FSW-K100 or R&S FSW-K104. This application provides test measurements for LTE downlink signals (base station signals) according to the test specification.

Frequency sweep measurements are not supported in MSRA mode.

For details refer to "Welcome to the LTE Measurement Application" .

Remote command:

INST:SEL LTE, see INSTrument[:​SELect]


Selecting the Operating Mode and Application

MSRA Mode > Applications and Operating Modes > Selecting the Operating Mode and Application
Selecting the Operating Mode and Application

The default operating mode is Signal and Spectrum Analyzer mode, however, the presetting can be changed.

(See "General Configuration Settings" ).

Both the operating mode and the application can be selected in the "Mode" dialog box which is displayed when you press the MODE key.

To switch the operating mode, select the corresponding tab (see "Starting the MSRA operating mode").

To select an application, select the corresponding button.

The available applications are described in "Available Applications" .

To deactivate a channel, simply close the corresponding tab.

The remote commands required to perform these tasks are described in "Activating MSRA Measurements".

└ New Channel
└ Replace Current Channel


New Channel

MSRA Mode > Applications and Operating Modes > Selecting the Operating Mode and Application > New Channel
New Channel

The applications selected on this tab are started in a new channel, i.e. a new tab in the display.

For a list of available applications see "Available Applications"

Remote command:

INSTrument:​CREate[:​NEW]

INSTrument[:​SELect]


Replace Current Channel

MSRA Mode > Applications and Operating Modes > Selecting the Operating Mode and Application > Replace Current Channel
Replace Current Channel

The applications selected on this tab are started in the currently displayed channel, replacing the current application.

For a list of available applications see "Available Applications"

Remote command:

INSTrument:​CREate:​REPLace


Using the Sequencer in MSRA Mode

MSRA Mode > Applications and Operating Modes > Using the Sequencer in MSRA Mode
Using the Sequencer in MSRA Mode

When you switch to MSRA mode, the Sequencer is automatically activated in continuous mode. Unless it is stopped or you select a different Sequencer mode, the R&S FSW will continuously perform a data acquisition (MSRA Master), then evaluate the data in the active applications one after the other, then repeat the data acquisition and evaluate the new data etc. The tabs are updated after each measurement or evaluation. This behaviour is identical to Signal and Spectrum Analyzer mode (also for Single Sequence or Channel-Defined Sequence modes).

However, if you switch the Sequencer off, the behaviour of the sweep functions is slightly different to Signal and Spectrum Analyzer mode (see also "Performing sweeps"):

  • If continuous sweep is active (default) and you switch to a different application, continuous sweep is aborted. This is necessary in order to evaluate the same data in different applications without overwriting the data in the capture buffer. Continuous sweep can be started again as usual.
  • Only the application that is currently displayed when a measurement is performed is updated automatically. A new "Refresh" function is available to update the display in one or all other applications.

For details on the Sequencer function see "Running a Sequence of Measurements" .

The "Sequencer" menu is available from the toolbar.

└ Sequencer State
└ Sequencer Mode
└ Refresh All


Sequencer State

MSRA Mode > Applications and Operating Modes > Using the Sequencer in MSRA Mode > Sequencer State
Sequencer State

Activates or deactivates the Sequencer. If activated, sequential operation according to the selected Sequencer mode is started immediately.

For details on sequential operation see "The Sequencer Concept" .

Remote command:

SYSTem:​SEQuencer

INITiate:​SEQuencer:​IMMediate

INITiate:​SEQuencer:​ABORt


Sequencer Mode

MSRA Mode > Applications and Operating Modes > Using the Sequencer in MSRA Mode > Sequencer Mode
Sequencer Mode

Defines how often which measurements are performed. The currently selected mode softkey is highlighted blue. During an active Sequencer process, the selected mode softkey is highlighted orange.

For details on sequential operation see "Sequencer modes" .

"Single Sequence" | Each measurement is performed once, until all measurements in all active channels have been performed.
"Continuous Sequence" | The measurements in each active channel are performed one after the other, repeatedly, in the same order, until sequential operation is stopped. This is the default Sequencer mode.
"Channel-defined Sequence" | First, a single sequence is performed. Then, only channels in continuous sweep mode are repeated.
Remote command:

INITiate:​SEQuencer:​MODE


Refresh All

MSRA Mode > Applications and Operating Modes > Using the Sequencer in MSRA Mode > Refresh All
Refresh All

This function is only available if the Sequencer is deactivated, no sweep is currently running, and only in MSRA or MSRT mode.

The data in the capture buffer is re-evaluated by all active applications, for example after a new sweep was performed while the Sequencer was off.

Note: To update only the displays in the currently active application, use the "Refresh" function in the "Sweep" menu for that application (see "Refresh").

For details on the MSRA operating mode see "Welcome to the MSRA Operating Mode".

For details on the MSRT operating mode see "Welcome to the Realtime Extension (K160R)" .

Remote command:

INITiate:​SEQuencer:​REFResh[:​ALL]


MSRA Basics

MSRA Mode > MSRA Basics
MSRA Basics

Some background knowledge on basic terms and principles used in MSRA operating mode is provided here for a better understanding of the required configuration settings.

Contents
  • Configuration
  • Data Acquisition
  • Multi-Standard Analysis
  • Restrictions for Applications
  • Measurements in the Time and Frequency Domain


Configuration

MSRA Mode > MSRA Basics > Configuration
Configuration
Master parameters

In MSRA mode, only the MSRA Master performs a data acquisition. Thus, all parameters that determine how the I/Q data is captured from the I/Q channel can only be configured in the MSRA Master tab. In all application tabs, these settings are deactivated (or have a different meaning).

Typical master parameters include:
  • Sample rate
  • Record length
  • Bandwidth
  • Center frequency
  • Reference level
  • Trigger settings
  • External reference
  • Impedance, preamplification, attenuation
Channel-specific parameters

Each application, however, can define all parameters concerning analysis individually.

Typical channel-specific parameters include:
  • Center frequency, duration and number of trace points for the application data extract
  • Offset of the application data extract from the trigger event
  • Evaluation methods
  • Range and scaling
  • Trace mode
  • Marker positions
Conflicting parameters

Master and channel-specific parameters can be configured independantly of one another, in any order that is convenient to you. However, there are dependencies between the parameters, as the applications can only evaluate data that has been captured by the MSRA Master previously. Thus, configuring parameters is not restricted, but you are informed about the violation of possible restrictions by error messages in the status bar of the applications where necessary.


Data Acquisition

MSRA Mode > MSRA Basics > Data Acquisition
Data Acquisition

As mentioned before, only the MSRA Master performs a data acquisition. Thus, the MSRA Master defines the center frequency, sample rate and record length of the captured I/Q data. It also defines the trigger event, thus all applications have the same trigger. However, an offset from the trigger can be defined by the individual applications (see "Trigger offset vs. capture offset").

Performing sweeps

When you switch to MSRA mode, the Sequencer is automatically activated in continuous mode. The MSRA Master continuously performs a data acquisition. If any applications are activated, then after each measurement, the data in the active applications is evaluated one after the other. The MSRA Master will then repeat the data acquisition and evaluate the new data etc. The channel displays are updated after each measurement or evaluation.

Alternatively, you can perform measurements manually. You can start a single or continuous sweep from any application, which updates the data in the capture buffer and the results in the current application. The results in the other applications, however, remain unchanged. You must refresh them manually, either individually or all at once, using a "Refresh" function.

Note that in continuous sweep mode, sweeping is aborted when you switch to a different application. You can then continue sweeping from there. This is necessary in order to evaluate the same data in different applications without overwriting the data in the capture buffer.

In single sweep mode, only one sweep is performed; a sweep count is not available - neither for the MSRA Master, nor for the applications. However, depending on the application, a statistics count may be available for statistics based on a single data acquisition. Trace averaging is performed as usual for sweep count = 0, the current trace is averaged with the previously stored averaged trace.

Data availability

The applications can only receive data that is available in the capture buffer. As soon as data has been stored to the capture buffer successfully, a status bit (#9) in the STAT:OPER register is set. If the required application data is not available, an error message is displayed. Details on restrictions are described in "Restrictions for Applications".


Multi-Standard Analysis

MSRA Mode > MSRA Basics > Multi-Standard Analysis
Multi-Standard Analysis
Application data

The applications receive data for analysis from the capture buffer, if necessary resampled or with filters applied. The applications can define their own center frequency, sample rate and record length for their application data, which is an extract of the capture buffer data. The applications may not request more sample points than the captured data contains, or samples from a frequency outside the range of the capture buffer, for example.

Generally, if a signal contains data channels for multiple standards, the individual applications are used to analyze the channel for the corresponding standard. Thus, it is of interest to know which application, or more precisely: which data channel is analyzing which part of the captured data and how each data channel is correlated (in time) to others.

The MSRA Master display indicates the data covered by each application, restricted to the channel bandwidth used by the corresponding standard, by vertical blue lines labeled with the application name. For applications that support several standards (e.g. VSA, LTE) an estimated or user-defined bandwidth is indicated.

MSRA Master indicating covered bandwidth for 4 applications
Analysis interval

Each application receives an extract of the data from the capture buffer. However, the individual evaluation methods of the application need not analyze the complete data range. Some applications allow you to select a specific part of the data for analysis, e.g. an individual frame, burst or pulse, or to use an offline trigger that defines an additional offset to the capture offset. The data range that is actually analyzed is referred to as the analysis interval.

The analysis interval is indicated in the window title bar for each evaluation, and can be queried via remote control.

For applications that do not allow you to restrict the evaluation range (e.g. I/Q Analyzer, Analog Demodulation), the analysis interval is identical to the application data extract.

Trigger offset vs. capture offset

The beginning of the capture buffer is defined by the trigger event and the trigger offset. The trigger source is defined by the MSRA Master, which means that all channels use the same trigger. However, each application might need a different trigger offset or a different number of pretrigger samples. Instead of a trigger offset, the applications define a capture offset. The capture offset is defined as an offset to the beginning of the capture buffer.

Thus, the beginning of the application data extract is calculated as:

[time of trigger event] + [trigger offset] + [capture offset]

Note that while the trigger offset value may be negative, thus starting before the trigger event, the capture offset may not. A negative capture offset would mean the application data would start before the first sample of the capture buffer. The (pre-)trigger offset in the MSRA Master must be configured such that the required number of pre-trigger samples for the applications are available.

Analysis line

A frequent question when analyzing multi-standard radio signals is how each data channel is correlated (in time) to others. Thus, an analysis line has been introduced. The analysis line is a common time marker for all MSRA applications. It can be positioned in any MSRA application or the MSRA Master and is then adjusted in all other applications. Thus, you can easily analyze the results at a specific time in the measurement in all applications and determine correlations (e.g. cross-talk).

If the marked point in time is contained in the analysis interval of the application, the line is indicated in all time-based result displays, such as time, symbol, slot or bit diagrams. By default, the analysis line is displayed, however, it can be hidden from view manually. In all result displays, the "AL" label in the window title bar indicates whether or not the analysis line lies within the analysis interval or not:

  • orange "AL": the line lies within the interval
  • white "AL": the line lies within the interval, but is not displayed (hidden)
  • no "AL": the line lies outside the interval


Restrictions for Applications

MSRA Mode > MSRA Basics > Restrictions for Applications
Restrictions for Applications

As mentioned in various contexts before, the MSRA applications themselves are identical to Signal and Spectrum operating mode, however, the correlation between applications and the MSRA Master require some restrictions. Principally, you are not restricted in setting parameters. However, if any contradictions occur between the configured capture settings and the analysis settings, error messages are displayed in the status bar of the application and an icon ( [image]) is displayed next to the channel label. However, it does not matter in which order you configure the settings - you will not be prevented from doing so.

In particular, the following restrictions apply to applications in MSRA mode:

  • Data acquisition: parameters related to data acquisition can only be configured by the MSRA Master
  • Application data: only data contained in the capture buffer can be analyzed by the application; this implies the following restrictions:
    – Center frequency: must lie within the captured data bandwidth
    – Measurement time/Record length: must be smaller than or equal to the values of the MSRA Master
    – Capture offset: must be smaller than the record length of the MSRA Master
    – Trace averaging: only for sweep count = 0
  • AUTO SET functions: in applications, only the frequency can be adjusted automatically; all other adjustment functions require a new data acquisition

General restrictions concerning sample rates and maximum usable I/Q bandwidths for I/Q data also apply in MSRA mode; see the R&S FSW I/Q Analyzer User Manual for details.


Measurements in the Time and Frequency Domain

MSRA Mode > MSRA Basics > Measurements in the Time and Frequency Domain
Measurements in the Time and Frequency Domain

The I/Q Analyzer application (not Master) in multistandard mode can also perform measurements on the captured I/Q data in the time and frequency domain. In order to do so, the I/Q Analyzer performs an FFT sweep on the captured I/Q data, providing power vs frequency results, or uses the RBW filter to obtain power vs time (zero span) results. This data is then used for the common frequency or time domain measurements provided by the R&S FSW Spectrum application, such as ACLR, SEM or CCDF.

Configuration

Apart from the data capturing process, the measurements are identical in the Spectrum and I/Q Analyzer applications. They are configured using the same settings and provide the same results. The "Magnitude" result display in the I/Q Analyzer, for instance, will principally show the same results as the zero span measurement for the same data. However, while the "Magnitude" evaluation is configured by the I/Q analysis bandwidth and the measurement time, the zero span measurement is configured by the center frequency, RBW and sweep time settings. Internally, these "time domain" settings are converted to the required I/Q settings by the I/Q Analyzer.

The time and frequency domain measurements and the required settings are described in detail in "Measurements" .

Limitations

However, since the data in the I/Q Analyzer application is captured by the Master, independantly of the specific time or frequency measurement requirements concerning the RBW, filter type and number of sweep points in the application, some restrictions may apply to these measurements in the I/Q Analyzer. If not enough samples are available in the captured and converted I/Q data, for example, an error message is displayed in the application.

The maximum span for a frequency sweep on I/Q-based data corresponds to the maximum I/Q bandwidth (see "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input" and "Sample Rates and Bandwidths for Digital I/Q Data").

The maximum resolution bandwidth (RBW) is 1 MHz.

Furthermore, the following functions are not available for time and frequency domain measurements in multistandard mode:

  • Marker demodulation
  • Frequency counter marker
  • Gated measurement
  • Video trigger


Configuration

MSRA Mode > Configuration
Configuration

MSRA is a special operating mode on the R&S FSW, which you activate using the MODE key on the front panel.

For details see "Applications and Operating Modes" .

When you switch the operating mode of a measurement channel to MSRA mode the first time, the Sequencer is automatically activated in continuous mode (see "Using the Sequencer in MSRA Mode"), starting an I/Q Analyzer data acquisition with the default settings (but with a "Spectrum" result display). The "I/Q Analyzer" menu is displayed, providing access to the most important configuration functions.

For a description see
  • "Data Acquisition and Bandwidth Settings"
  • "Display Configuration"

The LINES menu is not available.

Configuring the MSRA Master

The MSRA Master is the only channel that captures data. It also controls global configuration settings for all applications. Thus, all settings that refer to data acquisition can only be configured in the MSRA Master tab. These settings are deactivated in the configuration overviews and dialog boxes for all application channels. All other settings, e.g. concerning the evaluated data range, the display configuration or analysis, can be configured individually for each application and the Master.

Restrictions

Note that although some restrictions apply to parameters that affect both the MSRA Master and applications (see "Restrictions for Applications"), it does not matter in which order you configure them. If any contradictions occur between the captured data and the data to be evaluated, error messages are displayed in the status bar of the application and an icon ( [image] or [image]) is displayed next to the channel label. However, you will not be prevented from configuring contradictory settings.

Importing and Exporting I/Q Data

Note that, as opposed to the Signal and Spectrum Analyzer mode, the I/Q data to be evaluated in MSRA mode cannot be imported to the R&S FSW. However, the captured I/Q data from the MSRA Master can be exported for further analysis in external applications.

For details on exporting I/Q data see "I/Q Data Import and Export" .

Configuring an I/Q Analyzer as an MSRA application

In principle, the I/Q Analyzer in MSRA mode is configured as in Signal and Spectrum Analyzer mode.

However, the I/Q Analyzer application (not Master) in MSRA mode can also perform measurements on the captured I/Q data in the time and frequency domain (see also "Measurements in the Time and Frequency Domain"). Which type of measurement is to be performed - conventional I/Q data analysis or a time or frequency domain measurement - is selected in the "Select Measurement" dialog box, which is now displayed when you do one of the following:

  • In the "I/Q Analyzer" menu, select the "Select Meas" softkey.
  • Press the MEAS key.

The common measurements as in the Spectrum application are listed. In addition, "IQ Analyzer" is provided under "Basic Measurements" to return to the default I/Q Analysis functions.

The time and frequency domain measurements and the required settings are described in detail in "Measurements" . Further configuration of the I/Q Analyzer application is described in "Configuration" .

The following chapters describe configuration for the MSRA Master.

Contents
  • Default Settings for MSRA Measurements
  • Configuration Overview
  • Input Source Settings
  • Amplitude
  • Frequency Settings
  • Trigger Settings
  • Data Acquisition and Bandwidth Settings
  • Output Settings
  • Display Configuration
  • Automatic Settings


Default Settings for MSRA Measurements

MSRA Mode > Configuration > Default Settings for MSRA Measurements
Default Settings for MSRA Measurements

The following default settings are activated directly after the R&S FSW has been set to MSRA mode for the first time, or after presetting the instrument.

Default settings for MSRA mode
Parameter | Value
Application | I/Q Analyzer (Master)
Sequencer mode | Continuous
Sweep mode | Continuous
Reference level | 0 dBm
Attenuation | 10 dB
Acquisition time | 5 ms
Record length | 1001 samples
Sample rate | 100.0 MHz
Trigger settings | FREE RUN
Evaluation | Window 1: Spectrum


Configuration Overview

MSRA Mode > Configuration > Configuration Overview
Configuration Overview

Throughout the measurement channel configuration, an overview of the most important currently defined settings is provided in the "Overview". The "Overview" is displayed when you select the "Overview" icon, which is available at the bottom of all softkey menus.

In addition to the main measurement settings, the "Overview" provides quick access to the main settings dialog boxes. The individual configuration steps are displayed in the order of the data flow. Thus, you can easily configure an entire measurement channel from input over processing to output and analysis by stepping through the dialog boxes as indicated in the "Overview".

The "Overview" varies depending on the application; for detailed descriptions see the corresponding application User Manual.

If the I/Q Analyzer is used as an MSRA application, the "Overview" also provides a measurement selection button in order to perform measurements in the frequency and time domain. See the R&S FSW I/Q Analyzer and I/Q Input User Manual for details.

The "Overview" for the MSRA Master provides quick access to the following configuration dialog boxes (listed in the recommended order of processing):

  1. Input settings

    See "Input Source Settings"

  2. Amplitude settings

    See "Amplitude"

  3. Frequency settings

    See "Frequency Settings"

  4. Optionally, trigger settings

    See "Trigger Settings"

  5. Bandwidth settings

    See "Data Acquisition and Bandwidth Settings"

  6. Optionally, output settings

    See "Output Settings"

  7. Analysis settings and functions

    See "Analysis"

  8. Display configuration

    See "Display Configuration"

To configure settings
►

Select any button to open the corresponding dialog box.

For step-by-step instructions on configuring MSRA measurements, see "How to Perform Measurements in MSRA Mode".

└ Preset Channel
└ Specifics for


Preset Channel

MSRA Mode > Configuration > Configuration Overview > Preset Channel
Preset Channel

Select the "Preset Channel" button in the lower lefthand corner of the "Overview" to restore all measurement settings in the current channel to their default values.

Note that the PRESET key on the front panel restores the entire instrument to its default values and thus closes all measurement channels on the R&S FSW (except for the default Spectrum application channel)!

For details see "Default Settings for MSRA Measurements".

Remote command:

SYSTem:​PRESet:​CHANnel[:​EXECute]


Specifics for

MSRA Mode > Configuration > Configuration Overview > Specifics for
Specifics for

The measurement channel may contain several windows for different results. Thus, the settings indicated in the "Overview" and configured in the dialog boxes vary depending on the selected window.

Select an active window from the "Specifics for" selection list that is displayed in the "Overview" and in all window-specific configuration dialog boxes.

The "Overview" and dialog boxes are updated to indicate the settings for the selected window.


Input Source Settings

MSRA Mode > Configuration > Input Source Settings
Input Source Settings

The input source determines which data the R&S FSW will analyze.

Input settings can be configured in the "Input" dialog box.

Some settings are also available in the "Amplitude" tab of the "Amplitude" dialog box.

Output settings are described in "Output Settings".

Since the Digital I/Q input and the Analog Baseband input use the same digital signal path, both cannot be used simultaneously. When one is activated, established connections for the other are disconnected. When the second input is deactivated, connections to the first are re-established. This may cause a short delay in data transfer after switching the input source.

External mixers are not supported in MSRA/MSRT mode.

Contents
  • Radio Frequency Input
  • Digital I/Q Input Settings
  • Analog Baseband Input Settings
  • Probe Settings


Radio Frequency Input

MSRA Mode > Configuration > Input Source Settings > Radio Frequency Input
Radio Frequency Input

The default input source for the R&S FSW is "Radio Frequency", i.e. the signal at the RF INPUT connector on the front panel of the R&S FSW. If no additional options are installed, this is the only available input source.

└ Input Coupling
└ Impedance
└ High-Pass Filter 1...3 GHz
└ YIG-Preselector
└ Input Connector


Input Coupling

MSRA Mode > Configuration > Input Source Settings > Radio Frequency Input > Input Coupling
Input Coupling

The RF input of the R&S FSW can be coupled by alternating current (AC) or direct current (DC).

AC coupling blocks any DC voltage from the input signal. This is the default setting to prevent damage to the instrument. Very low frequencies in the input signal may be distorted.

However, some specifications require DC coupling. In this case, you must protect the instrument from damaging DC input voltages manually. For details, refer to the data sheet.

Remote command:

INPut:​COUPling


Impedance

MSRA Mode > Configuration > Input Source Settings > Radio Frequency Input > Impedance
Impedance

The reference impedance for the measured levels of the R&S FSW can be set to 50 Ω or 75 Ω.

75 Ω should be selected if the 50 Ω input impedance is transformed to a higher impedance using a 75 Ω adapter of the RAZ type (= 25 Ω in series to the input impedance of the instrument). The correction value in this case is 1.76 dB = 10 log (75Ω/50Ω).

This value also affects the unit conversion (see "Reference Level").

Remote command:

INPut:​IMPedance


High-Pass Filter 1...3 GHz

MSRA Mode > Configuration > Input Source Settings > Radio Frequency Input > High-Pass Filter 1...3 GHz
High-Pass Filter 1...3 GHz

Activates an additional internal high-pass filter for RF input signals from 1 GHz to 3 GHz. This filter is used to remove the harmonics of the R&S FSW in order to measure the harmonics for a DUT, for example.

This function requires option R&S FSW-B13.

(Note: for RF input signals outside the specified range, the high-pass filter has no effect. For signals with a frequency of approximately 4 GHz upwards, the harmonics are suppressed sufficiently by the YIG filter.)

Remote command:

INPut:​FILTer:​HPASs[:​STATe]


YIG-Preselector

MSRA Mode > Configuration > Input Source Settings > Radio Frequency Input > YIG-Preselector
YIG-Preselector

Activates or deactivates the YIG-preselector.

An internal YIG-preselector at the input of the R&S FSW ensures that image frequencies are rejected. However, this is only possible for a restricted bandwidth. In order to use the maximum bandwidth for signal analysis you can deactivate the YIG-preselector at the input of the R&S FSW, which may lead to image-frequency display.

Note that the YIG-preselector is active only on frequencies greater than 8 GHz. Therefore, switching the YIG-preselector on or off has no effect if the frequency is below that value.

Note:

For the following measurements, the YIG-Preselector is off by default (if available).
  • I/Q Analyzer (and thus in all applications in MSRA operating mode)
  • Multi-Carrier Group Delay
  • GSM
  • VSA

Remote command:

INPut:​FILTer:​YIG[:​STATe]


Input Connector

MSRA Mode > Configuration > Input Source Settings > Radio Frequency Input > Input Connector
Input Connector

Determines whether the RF input data is taken from the RF INPUT connector (default) or the optional BASEBAND INPUT I connector. This setting is only available if the Analog Baseband Interface (R&S FSW-B71) is installed and active for input. It is not available for the R&S FSW67.

For more information see "Processing Data From the Analog Baseband Interface" .

Remote command:

INPut:​CONNector


Digital I/Q Input Settings

MSRA Mode > Configuration > Input Source Settings > Digital I/Q Input Settings
Digital I/Q Input Settings

The following settings and functions are available to provide input via the Digital Baseband Interface (R&S FSW-B17) in the applications that support it.

They can be configured via the INPUT/OUTPUT key, in the "Input" dialog box.

For more information see " Processing Data from the Digital Baseband Interface (-B17)" .

└ Digital I/Q Input State
└ Input Sample Rate
└ Full Scale Level
└ Adjust Reference Level to Full Scale Level
└ Connected Instrument
└ DigIConf


Digital I/Q Input State

MSRA Mode > Configuration > Input Source Settings > Digital I/Q Input Settings > Digital I/Q Input State
Digital I/Q Input State

Enables or disable the use of the "Digital IQ" input source for measurements. "Digital IQ" is only available if the Digital Baseband Interface (R&S FSW-B17) is installed.

Remote command:

INPut:​SELect


Input Sample Rate

MSRA Mode > Configuration > Input Source Settings > Digital I/Q Input Settings > Input Sample Rate
Input Sample Rate

Defines the sample rate of the digital I/Q signal source. This sample rate must correspond with the sample rate provided by the connected device, e.g. a generator.

If "Auto" is selected, the sample rate is adjusted automatically by the connected device.

The allowed range is from 100 Hz to 10 GHz.

Remote command:

INPut:​DIQ:​SRATe

INPut:​DIQ:​SRATe:​AUTO


Full Scale Level

MSRA Mode > Configuration > Input Source Settings > Digital I/Q Input Settings > Full Scale Level
Full Scale Level

The "Full Scale Level" defines the level and unit that should correspond to an I/Q sample with the magnitude "1".

If "Auto" is selected, the level is automatically set to the value provided by the connected device.

Remote command:

INPut:​DIQ:​RANGe[:​UPPer]

INPut:​DIQ:​RANGe[:​UPPer]:​UNIT

INPut:​DIQ:​RANGe[:​UPPer]:​AUTO


Adjust Reference Level to Full Scale Level

MSRA Mode > Configuration > Input Source Settings > Digital I/Q Input Settings > Adjust Reference Level to Full Scale Level
Adjust Reference Level to Full Scale Level

If enabled, the reference level is adjusted to the full scale level automatically if any change occurs.

Remote command:

INPut:​DIQ:​RANGe:​COUPling


Connected Instrument

MSRA Mode > Configuration > Input Source Settings > Digital I/Q Input Settings > Connected Instrument
Connected Instrument

Displays the status of the Digital Baseband Interface connection.

This function is only available if the Digital Baseband Interface (R&S FSW-B17) is installed.

If an instrument is connected, the following information is displayed:

  • Name and serial number of the instrument connected to the Digital Baseband Interface
  • Used port
  • Sample rate of the data currently being transferred via the Digital Baseband Interface
  • Level and unit that corresponds to an I/Q sample with the magnitude "1" ("Full Scale Level"), if provided by connected instrument
Remote command:

INPut:​DIQ:​CDEVice


DigIConf

MSRA Mode > Configuration > Input Source Settings > Digital I/Q Input Settings > DigIConf
DigIConf

Starts the optional R&S DigIConf application. This softkey is available in the In-/Output menu, but only if the optional software is installed.

Note that R&S DigIConf requires a USB connection (not LAN!) from the R&S FSW to the R&S EX-IQ-BOX in addition to the Digital Baseband Interface (R&S FSW-B17) connection. R&S DigIConf version 2.20.360.86 Build 170 or higher is required.

To return to the R&S FSW application, press any key on the front panel. The R&S FSW application is displayed with the "Input/Output" menu, regardless of which key was pressed.

For details on the R&S DigIConf application, see the "R&S®EX-IQ-BOX Digital Interface Module R&S®DigIConf Software Operating Manual".

Note: If you close the R&S DigIConf window using the "Close" icon, the window is minimized, not closed.
If you select the "File > Exit" menu item in the R&S DigIConf window, the application is closed. Note that in this case the settings are lost and the EX-IQ-BOX functionality is no longer available until you restart the application using the "DigIConf" softkey in the R&S FSW once again.


Analog Baseband Input Settings

MSRA Mode > Configuration > Input Source Settings > Analog Baseband Input Settings
Analog Baseband Input Settings

The following settings and functions are available to provide input via the Analog Baseband Interface (R&S FSW-B71) in the applications that support it.

They can be configured via the INPUT/OUTPUT key, in the "Input" dialog box.

For more information see "Processing Data From the Analog Baseband Interface" .

└ Analog Baseband Input State
└ I/Q Mode
└ Input configuration
└ Center Frequency


Analog Baseband Input State

MSRA Mode > Configuration > Input Source Settings > Analog Baseband Input Settings > Analog Baseband Input State
Analog Baseband Input State

Enables or disable the use of the "Analog Baseband" input source for measurements. "Analog Baseband" is only available if the Analog Baseband Interface (R&S FSW-B71) is installed.

Remote command:

INPut:​SELect


I/Q Mode

MSRA Mode > Configuration > Input Source Settings > Analog Baseband Input Settings > I/Q Mode
I/Q Mode

Defines the format of the input signal.

For more information see "I/Q Processing Modes" .

"I + jQ"

The input signal is filtered and resampled to the sample rate of the application.

Two inputs are required for a complex signal, one for the in-phase component, and one for the quadrature component.

"I Only / Low IF I"

The input signal at the BASEBAND INPUT I connector is filtered and resampled to the sample rate of the application.

If the center frequency is set to 0 Hz, the real baseband signal is displayed without down-conversion (Real Baseband I).

If a center frequency greater than 0 Hz is set, the input signal is down-converted with the center frequency (Low IF I).

"Q Only / Low IF Q"

The input signal at the BASEBAND INPUT Q connector is filtered and resampled to the sample rate of the application.

If the center frequency is set to 0 Hz, the real baseband signal is displayed without down-conversion (Real Baseband Q).

If a center frequency greater than 0 Hz is set, the input signal is down-converted with the center frequency (Low IF Q).

Remote command:

INPut:​IQ:​TYPE


Input configuration

MSRA Mode > Configuration > Input Source Settings > Analog Baseband Input Settings > Input configuration
Input configuration

Defines whether the input is provided as a differential signal via all 4 Analog Baseband connectors or as a plain I/Q signal via 2 simple-ended lines.

Note: Both single-ended and differential probes are supported as input; however, since only one connector is occupied by a probe, the "Single-ended" setting must be used for all probes.
For details on probes see "Using Probes" .

"Differential" | I, Q and inverse I,Q data
"Single Ended" | I, Q data only
Remote command:

INPut:​IQ:​BALanced[:​STATe]


Center Frequency

MSRA Mode > Configuration > Input Source Settings > Analog Baseband Input Settings > Center Frequency
Center Frequency

Defines the center frequency for analog baseband input.

For real-type baseband input (I or Q only), the center frequency is always 0 Hz.

Note: If the analysis bandwidth to either side of the defined center frequency exceeds the minimum frequency (0 Hz) or the maximum frequency (40 MHz/80 MHz), an error is displayed. In this case, adjust the center frequency or the analysis bandwidth.

Remote command:

[SENSe:​]FREQuency:​CENTer


Probe Settings

MSRA Mode > Configuration > Input Source Settings > Probe Settings
Probe Settings

Probes are configured in a separate tab on the "Input" dialog box which is displayed when you select the INPUT/OUTPUT key and then "Input Source Config".

For each possible probe connector (Baseband Input I, Baseband Input Q), the detected type of probe, if any, is displayed. The following information is provided for each connected probe:

  • Probe name
  • Serial number
  • R&S part number
  • Type of probe ("Differential", "Single Ended")

For more information on using probes with an R&S FSW, see "Using Probes" .

For general information on the R&S®RTO probes, see the device manuals.

└ Microbutton Action


Microbutton Action

MSRA Mode > Configuration > Input Source Settings > Probe Settings > Microbutton Action
Microbutton Action

Active R&S probes (except for RT-ZS10E) have a configurable microbutton on the probe head. By pressing this button, you can perform an action on the instrument directly from the probe.

Select the action that you want to start from the probe:

"Run single" | Starts one data acquisition.
"No action" | Prevents unwanted actions due to unintended usage of the microbutton.
Remote command:

[SENSe:​]PROBe<p>:​SETup:​MODE


Amplitude

MSRA Mode > Configuration > Amplitude
Amplitude

The amplitude is configured in the "Amplitude" dialog box. Amplitude settings are identical to the Signal and Spectrum Analyzer mode.

See "Amplitude Settings".

Contents
  • Amplitude Settings
  • Amplitude Settings for Analog Baseband Input


Amplitude Settings

MSRA Mode > Configuration > Amplitude > Amplitude Settings
Amplitude Settings

Amplitude settings determine how the R&S FSW must process or display the expected input power levels.

Amplitude settings for input from the Analog Baseband interface (R&S FSW-B71) are described in "Amplitude Settings for Analog Baseband Input".

To configure the amplitude settings

Amplitude settings can be configured via the AMPT key or in the "Amplitude" dialog box.

►

To display the "Amplitude" dialog box, do one of the following:

  • Select "Input/Frontend" from the "Overview" and then switch to the "Amplitude" tab.
  • Select the AMPT key and then the "Amplitude Config" softkey.
└ Reference Level
└ Shifting the Display (Offset)
└ RF Attenuation
└ Attenuation Mode / Value
└ Using Electronic Attenuation (Option B25)
└ Input Settings
└ Preamplifier (option B24)
└ Input Coupling
└ Impedance


Reference Level

MSRA Mode > Configuration > Amplitude > Amplitude Settings > Reference Level
Reference Level

Defines the expected maximum reference level. Signal levels above this value may not be measured correctly, which is indicated by the "IF OVLD" status display ("OVLD" for analog baseband or digitial baseband input).

The reference level is also used to scale power diagrams; the reference level is then used as the maximum on the y-axis.

Since the R&S FSW hardware is adapted according to this value, it is recommended that you set the reference level close above the expected maximum signal level to ensure an optimum measurement (no compression, good signal-to-noise ratio).

Note that the "Reference Level" value ignores the "Shifting the Display (Offset)". It is important to know the actual power level the R&S FSW must handle.

For details see "Reference Level" .

Note that for input from the External Mixer (R&S FSW-B21) the maximum reference level also depends on the conversion loss, see "Reference level" .

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RLEVel

└ Shifting the Display (Offset)


Shifting the Display (Offset)

MSRA Mode > Configuration > Amplitude > Amplitude Settings > Reference Level > Shifting the Display (Offset)
Shifting the Display (Offset)

Defines an arithmetic level offset. This offset is added to the measured level irrespective of the selected unit. The scaling of the y-axis is changed accordingly.

Define an offset if the signal is attenuated or amplified before it is fed into the R&S FSW so the application shows correct power results. All displayed power level results will be shifted by this value.

Note, however, that the "Reference Level" value ignores the "Reference Level Offset". It is important to know the actual power level the R&S FSW must handle.

To determine the required offset, consider the external attenuation or gain applied to the input signal. A positive value indicates that an attenuation took place (R&S FSW increases the displayed power values) , a negative value indicates an external gain (R&S FSW decreases the displayed power values).

The setting range is ±200 dB in 0.01 dB steps.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RLEVel:​OFFSet


RF Attenuation

MSRA Mode > Configuration > Amplitude > Amplitude Settings > RF Attenuation
RF Attenuation

Defines the attenuation applied to the RF input.

└ Attenuation Mode / Value


Attenuation Mode / Value

MSRA Mode > Configuration > Amplitude > Amplitude Settings > RF Attenuation > Attenuation Mode / Value
Attenuation Mode / Value

The RF attenuation can be set automatically as a function of the selected reference level (Auto mode). This ensures that the optimum RF attenuation is always used. It is the default setting. By default and when "Using Electronic Attenuation (Option B25)" is not available, mechanical attenuation is applied.

In "Manual" mode, you can set the RF attenuation in 1 dB steps (down to 0 dB, also using the rotary knob). Other entries are rounded to the next integer value. The range is specified in the data sheet. If the defined reference level cannot be set for the defined RF attenuation, the reference level is adjusted accordingly and the warning "Limit reached" is displayed.

NOTICE! Risk of hardware damage due to high power levels. When decreasing the attenuation manually, ensure that the power level does not exceed the maximum level allowed at the RF input, as an overload may lead to hardware damage.

Note: In "Auto" mode, RF attenuation is provided by the electronic attenuator as much as possible (if option B25 is installed and active) to reduce the amount of mechanical switching required.

For details see "RF Attenuation" .

Remote command:

INPut:​ATTenuation

INPut:​ATTenuation:​AUTO


Using Electronic Attenuation (Option B25)

MSRA Mode > Configuration > Amplitude > Amplitude Settings > Using Electronic Attenuation (Option B25)
Using Electronic Attenuation (Option B25)

If option R&S FSW-B25 is installed, you can also activate an electronic attenuator.

In "Auto" mode, the settings are defined automatically; in "Manual" mode, you can define the mechanical and electronic attenuation separately.

Note: Electronic attenuation is not available for stop frequencies (or center frequencies in zero span) >13.6 GHz.
In "Auto" mode, RF attenuation is provided by the electronic attenuator as much as possible to reduce the amount of mechanical switching required. Mechanical attenuation may provide a better signal-to-noise ratio, however.
When you switch off electronic attenuation, the RF attenuation is automatically set to the same mode (auto/manual) as the electronic attenuation was set to. Thus, the RF attenuation may be set to automatic mode, and the full attenuation is provided by the mechanical attenuator, if possible.

Both the electronic and the mechanical attenuation can be varied in 1 dB steps. Other entries are rounded to the next lower integer value.

If the defined reference level cannot be set for the given attenuation, the reference level is adjusted accordingly and the warning "Limit reached" is displayed in the status bar.

Remote command:

INPut:​EATT:​STATe

INPut:​EATT:​AUTO

INPut:​EATT


Input Settings

MSRA Mode > Configuration > Amplitude > Amplitude Settings > Input Settings
Input Settings

Some input settings affect the measured amplitude of the signal, as well.

└ Preamplifier (option B24)
└ Input Coupling
└ Impedance


Preamplifier (option B24)

MSRA Mode > Configuration > Amplitude > Amplitude Settings > Input Settings > Preamplifier (option B24)
Preamplifier (option B24)

If option R&S FSW-B24 is installed, a preamplifier can be activated for the RF input signal.

You can use a preamplifier to analyze signals from DUTs with low input power.

For R&S FSW 26 or higher models, the input signal is amplified by 30 dB if the preamplifier is activated.

For R&S FSW 8 or 13 models, the following settings are available:

"Off" | Deactivates the preamplifier.
"15 dB" | The RF input signal is amplified by about 15 dB.
"30 dB" | The RF input signal is amplified by about 30 dB.
Remote command:

INPut:​GAIN:​STATe

INPut:​GAIN[:​VALue]


Amplitude Settings for Analog Baseband Input

MSRA Mode > Configuration > Amplitude > Amplitude Settings for Analog Baseband Input
Amplitude Settings for Analog Baseband Input

The following settings and functions are available to define amplitude settings for input via the Analog Baseband Interface (R&S FSW-B71) in the applications that support it.

They can be configured via the AMPT key or in the "Amplitude" tab of the "Input" dialog box.

The input settings provided here are identical to those in the "Input Source" > "Analog Baseband" tab, see "Analog Baseband Input Settings".

For more information see "Processing Data From the Analog Baseband Interface" .

└ Reference Level
└ Shifting the Display (Offset)
└ Full Scale Level Mode / Value


Full Scale Level Mode / Value

MSRA Mode > Configuration > Amplitude > Amplitude Settings for Analog Baseband Input > Full Scale Level Mode / Value
Full Scale Level Mode / Value

The full scale level defines the maximum power you can input at the Baseband Input connector without clipping the signal.

The full scale level can be defined automatically according to the reference level, or manually.

For manual input, the following values can be selected:

  • 0.25 V
  • 0.5 V
  • 1 V
  • 2 V

If probes are connected, the possible full scale values are adapted according to the probe's attenuation and maximum allowed power.

For details on probes see "Processing Data From the Analog Baseband Interface" .

Remote command:

INPut:​IQ:​FULLscale:​AUTO

INPut:​IQ:​FULLscale[:​LEVel]


Frequency Settings

MSRA Mode > Configuration > Frequency Settings
Frequency Settings

Frequency settings for the input signal can be configured via the "Frequency" dialog box, which is displayed when you do one of the following:

  • Select the FREQ key and then the "Frequency Config" softkey.
  • Select "Frequency" from the "Overview".
└ Center frequency
└ Center Frequency Stepsize
└ Frequency Offset


Center frequency

MSRA Mode > Configuration > Frequency Settings > Center frequency
Center frequency

Defines the normal center frequency of the signal. The allowed range of values for the center frequency depends on the frequency span.

fmax and spanmin are specified in the data sheet.

Remote command:

[SENSe:​]FREQuency:​CENTer


Center Frequency Stepsize

MSRA Mode > Configuration > Frequency Settings > Center Frequency Stepsize
Center Frequency Stepsize

Defines the step size by which the center frequency is increased or decreased when the arrow keys are pressed. When you use the rotary knob the center frequency changes in steps of only 1/10 of the "Center Frequency Stepsize".

The step size can be coupled to another value or it can be manually set to a fixed value.

For more details see "Stepping Through the Frequency Range - Center Frequency Stepsize" .

"= Center" | Sets the step size to the value of the center frequency. The used value is indicated in the "Value" field.
"Manual" | Defines a fixed step size for the center frequency. Enter the step size in the "Value" field.
Remote command:

[SENSe:​]FREQuency:​CENTer:​STEP


Frequency Offset

MSRA Mode > Configuration > Frequency Settings > Frequency Offset
Frequency Offset

Shifts the displayed frequency range along the x-axis by the defined offset.

This parameter has no effect on the R&S FSW hardware, or on the captured data or on data processing. It is simply a manipulation of the final results in which absolute frequency values are displayed. Thus, the x-axis of a spectrum display is shifted by a constant offset if it shows absolute frequencies, but not if it shows frequencies relative to the signal's center frequency.

A frequency offset can be used to correct the display of a signal that is slightly distorted by the measurement setup, for example.

The allowed values range from -100 GHz to 100 GHz. The default setting is 0 Hz.

Remote command:

[SENSe:​]FREQuency:​OFFSet


Trigger Settings

MSRA Mode > Configuration > Trigger Settings
Trigger Settings

Trigger settings determine when the input signal is measured. These settings are only available for the MSRA Master.

The "Capture Offset", which has a similar function to the trigger offset but is available for MSRA applications only, is described in "Data Acquisition and Bandwidth Settings".

External triggers from one of the TRIGGER INPUT/OUTPUT connectors on the R&S FSW are configured in a separate tab of the dialog box.

For step-by-step instructions on configuring triggered measurements, see "How to Configure a Triggered and Gated Measurement" .

For step-by-step instructions on configuring triggered measurements, see the R&S FSW User Manual.

└ Trigger Source
└ Trigger Source
└ Free Run
└ External Trigger 1/2/3
└ Baseband Power
└ Digital I/Q
└ RF Power
└ I/Q Power
└ Power Sensor
└ Trigger Level (Repetition interval)
└ Drop-Out Time
└ Trigger Offset
└ Hysteresis
└ Trigger Holdoff
└ Slope
└ Trigger 2/3
└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


Trigger Source

MSRA Mode > Configuration > Trigger Settings > Trigger Source
Trigger Source

The trigger settings define the beginning of a measurement.

└ Trigger Source
└ Free Run
└ External Trigger 1/2/3
└ Baseband Power
└ Digital I/Q
└ RF Power
└ I/Q Power
└ Power Sensor
└ Trigger Level (Repetition interval)
└ Drop-Out Time
└ Trigger Offset
└ Hysteresis
└ Trigger Holdoff
└ Slope


Trigger Source

MSRA Mode > Configuration > Trigger Settings > Trigger Source > Trigger Source
Trigger Source

Defines the trigger source. If a trigger source other than "Free Run" is set, "TRG" is displayed in the channel bar and the trigger source is indicated.

Remote command:

TRIGger[:​SEQuence]:​SOURce

└ Free Run
└ External Trigger 1/2/3
└ Baseband Power
└ Digital I/Q
└ RF Power
└ I/Q Power
└ Power Sensor


Free Run

MSRA Mode > Configuration > Trigger Settings > Trigger Source > Trigger Source > Free Run
Free Run

No trigger source is considered. Data acquisition is started manually or automatically and continues until stopped explicitely.

Remote command:

TRIG:SOUR IMM, see TRIGger[:​SEQuence]:​SOURce


External Trigger 1/2/3

MSRA Mode > Configuration > Trigger Settings > Trigger Source > Trigger Source > External Trigger 1/2/3
External Trigger 1/2/3

Data acquisition starts when the TTL signal fed into the specified input connector (on the front or rear panel) meets or exceeds the specified trigger level.

(See "Trigger Level (Repetition interval)").

Note: The "External Trigger 1" softkey automatically selects the trigger signal from the TRIGGER INPUT connector on the front panel.

For details see "TRIGGER INPUT / OUTPUT" and "TRIGGER 3 INPUT/ OUTPUT" .

"External Trigger 1" | Trigger signal from the TRIGGER 1 INPUT connector on the front panel.
"External Trigger 2" | Trigger signal from the TRIGGER 2 INPUT/OUTPUT connector on the front panel.
"External Trigger 3" | Trigger signal from the TRIGGER 3 INPUT/ OUTPUT connector on the rear panel.
Remote command:

TRIG:SOUR EXT, TRIG:SOUR EXT2

TRIG:SOUR EXT3

See TRIGger[:​SEQuence]:​SOURce


Baseband Power

MSRA Mode > Configuration > Trigger Settings > Trigger Source > Trigger Source > Baseband Power
Baseband Power

Defines triggering on the baseband power (for baseband input via the Digital Baseband Interface R&S FSW-B17 or the Analog Baseband interface R&S FSW-B71)).

For more information on the Digital Baseband Interface see "Digital I/Q Data Processing" .

For more information on the Analog Baseband Interface see "Processing Data From the Analog Baseband Interface" .

Remote command:

TRIG:SOUR BBP, see TRIGger[:​SEQuence]:​SOURce


Digital I/Q

MSRA Mode > Configuration > Trigger Settings > Trigger Source > Trigger Source > Digital I/Q
Digital I/Q

For applications that process I/Q data, such as the I/Q Analyzer or optional applications, and only if the Digital Baseband Interface (R&S FSW-B17) is available:

Defines triggering of the measurement directly via the LVDS connector. In the selection list you must specify which general purpose bit (GP0 to GP5) will provide the trigger data.

Note: If the Digital I/Q enhanced mode is used, i.e. the connected device supports transfer rates up to 200 Msps, only the general purpose bits GP0 and GP1 are available as a Digital I/Q trigger source.

The following table describes the assignment of the general purpose bits to the LVDS connector pins.

Assignment of general purpose bits to LVDS connector pins
Bit | LVDS pin
GP0 | SDATA4_P - Trigger1
GP1 | SDATA4_P - Trigger2
GP2 *) | SDATA0_P - Reserve1
GP3 *) | SDATA4_P - Reserve2
GP4 *) | SDATA0_P - Marker1
GP5 *) | SDATA4_P - Marker2
*): not available for Digital I/Q enhanced mode
Remote command:

TRIG:SOUR GP0, see TRIGger[:​SEQuence]:​SOURce


RF Power

MSRA Mode > Configuration > Trigger Settings > Trigger Source > Trigger Source > RF Power
RF Power

Defines triggering of the measurement via signals which are outside the displayed measurement range.

For this purpose the instrument uses a level detector at the first intermediate frequency. The input signal must be in the frequency range between 500 MHz and 8 GHz.

The resulting trigger level at the RF input depends on the RF attenuation and preamplification. For details on available trigger levels see the data sheet.

Note: If the input signal contains frequencies outside of this range (e.g. for fullspan measurements), the sweep may be aborted and a message indicating the allowed input frequencies is displayed in the status bar.

A "Trigger Offset", "Trigger Polarity" and "Trigger Holdoff" (to improve the trigger stability) can be defined for the RF trigger, but no "Hysteresis".

Remote command:

TRIG:SOUR RFP, see TRIGger[:​SEQuence]:​SOURce


I/Q Power

MSRA Mode > Configuration > Trigger Settings > Trigger Source > Trigger Source > I/Q Power
I/Q Power

This trigger source is not available if the optional Digital Baseband Interface (R&S FSW-B17) or Analog Baseband Interface (R&S FSW-B71) is used for input. It is also not available for analysis bandwidths ≥ 160 MHz.

Triggers the measurement when the magnitude of the sampled I/Q data exceeds the trigger threshold.

Remote command:

TRIG:SOUR IQP, see TRIGger[:​SEQuence]:​SOURce


Power Sensor

MSRA Mode > Configuration > Trigger Settings > Trigger Source > Trigger Source > Power Sensor
Power Sensor

Uses an external power sensor as a trigger source. This option is only available if a power sensor is connected and configured.

Note: For R&S power sensors, the "Gate Mode" Lvl is not supported. The signal sent by these sensors merely reflects the instant the level is first exceeded, rather than a time period. However, only time periods can be used for gating in level mode. Thus, the trigger impulse from the sensors is not long enough for a fully gated measurement; the measurement cannot be completed.

Remote command:

TRIG:SOUR PSE, see TRIGger[:​SEQuence]:​SOURce


Trigger Level (Repetition interval)

MSRA Mode > Configuration > Trigger Settings > Trigger Source > Trigger Level (Repetition interval)
Trigger Level (Repetition interval)

Defines the trigger level for the specified trigger source. For time triggers, the repetition interval is defined.

For details on supported trigger levels, see the data sheet.

Remote command:

TRIGger[:​SEQuence]:​LEVel[:​EXTernal<port>]


Drop-Out Time

MSRA Mode > Configuration > Trigger Settings > Trigger Source > Drop-Out Time
Drop-Out Time

Defines the time the input signal must stay below the trigger level before triggering again.

For more information on the drop-out time see "Trigger Drop-Out Time" .

Note: For input from the Analog Baseband Interface (R&S FSW-B71) using the baseband power trigger (BBP), the default drop out time is set to 100 ns to avoid unintentional trigger events (as no hysteresis can be configured in this case).

Remote command:

TRIGger[:​SEQuence]:​DTIMe


Trigger Offset

MSRA Mode > Configuration > Trigger Settings > Trigger Source > Trigger Offset
Trigger Offset

Defines the time offset between the trigger event and the start of the sweep for the MSRA Master.

This setting is not available in MSRA application measurement channels. For applications, use the "Capture Offset" instead.

offset > 0: | Start of the sweep is delayed
offset < 0: | Sweep starts earlier (pre-trigger) Maximum allowed range limited by the sweep time: pretriggermax = sweep time
Remote command:

TRIGger[:​SEQuence]:​HOLDoff[:​TIME]


Hysteresis

MSRA Mode > Configuration > Trigger Settings > Trigger Source > Hysteresis
Hysteresis

Defines the distance in dB to the trigger level that the trigger source must exceed before a trigger event occurs. Settting a hysteresis avoids unwanted trigger events caused by noise oscillation around the trigger level.

This setting is only available for "IF Power" trigger sources. The range of the value is between 3 dB and 50 dB with a step width of 1 dB.

For more information see "Trigger Hysteresis" .

Remote command:

TRIGger[:​SEQuence]:​IFPower:​HYSTeresis


Trigger Holdoff

MSRA Mode > Configuration > Trigger Settings > Trigger Source > Trigger Holdoff
Trigger Holdoff

Defines the minimum time (in seconds) that must pass between two trigger events. Trigger events that occur during the holdoff time are ignored.

For more information see "Trigger Holdoff" .

Remote command:

TRIGger[:​SEQuence]:​IFPower:​HOLDoff


Slope

MSRA Mode > Configuration > Trigger Settings > Trigger Source > Slope
Slope

For all trigger sources except time and frequency mask (Realtime only) you can define whether triggering occurs when the signal rises to the trigger level or falls down to it.

Remote command:

TRIGger[:​SEQuence]:​SLOPe


Trigger 2/3

MSRA Mode > Configuration > Trigger Settings > Trigger 2/3
Trigger 2/3

Defines the usage of the variable TRIGGER INPUT/OUTPUT connectors, where:

"Trigger 2": TRIGGER INPUT/OUTPUT connector on the front panel

"Trigger 3": TRIGGER 3 INPUT/ OUTPUT connector on the rear panel

(Trigger 1 is INPUT only.)

Note: Providing trigger signals as output is described in detail in "How to Output a Trigger Signal" .

"Input" | The signal at the connector is used as an external trigger source by the R&S FSW. No further trigger parameters are available for the connector.
"Output" | The R&S FSW sends a trigger signal to the output connector to be used by connected devices. Further trigger parameters are available for the connector.
Remote command:

OUTPut:​TRIGger<port>:​LEVel

OUTPut:​TRIGger<port>:​DIRection

└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


Output Type

MSRA Mode > Configuration > Trigger Settings > Trigger 2/3 > Output Type
Output Type

Type of signal to be sent to the output

"Device Triggered" | (Default) Sends a trigger when the R&S FSW triggers.
"Trigger Armed" | Sends a (high level) trigger when the R&S FSW is in "Ready for trigger" state. This state is indicated by a status bit in the STATus:OPERation register (bit 5), as well as by a low level signal at the AUX port (pin 9).
"User Defined" | Sends a trigger when user selects "Send Trigger" button. In this case, further parameters are available for the output signal.
Remote command:

OUTPut:​TRIGger<port>:​OTYPe

└ Level
└ Pulse Length
└ Send Trigger


Level

MSRA Mode > Configuration > Trigger Settings > Trigger 2/3 > Output Type > Level
Level

Defines whether a constant high (1) or low (0) signal is sent to the output connector.

Remote command:

OUTPut:​TRIGger<port>:​LEVel


Pulse Length

MSRA Mode > Configuration > Trigger Settings > Trigger 2/3 > Output Type > Pulse Length
Pulse Length

Defines the length of the pulse sent as a trigger to the output connector.

Remote command:

OUTPut:​TRIGger<port>:​PULSe:​LENGth


Send Trigger

MSRA Mode > Configuration > Trigger Settings > Trigger 2/3 > Output Type > Send Trigger
Send Trigger

Sends a user-defined trigger to the output connector immediately. Note that the trigger pulse level is always opposite to the constant signal level defined by the output "Level" setting, e.g. for "Level = High", a constant high signal is output to the connector until the "Send Trigger" button is selected. Then, a low pulse is sent.

Which pulse level will be sent is indicated by a graphic on the button.

Remote command:

OUTPut:​TRIGger<port>:​PULSe:​IMMediate


Data Acquisition and Bandwidth Settings

MSRA Mode > Configuration > Data Acquisition and Bandwidth Settings
Data Acquisition and Bandwidth Settings

How data is to be acquired is configured in the "Bandwidth" dialog box.

Contents
  • Data Acquisition
  • Sweep Settings


Data Acquisition

MSRA Mode > Configuration > Data Acquisition and Bandwidth Settings > Data Acquisition
Data Acquisition

The data acquisition settings define which parts of the input signal are captured for further evaluation in the applications. They are configured in the "Data Acquisition" tab of the "Bandwidth" dialog box.

►

To display this dialog box, do one of the following:

  • Select the "Bandwidth" button in the configuration "Overview"
  • Select the BW key and then the "Data Acquisition" softkey.
  • Select the "Data Acquisition" softkey in the "I/Q Analyzer" menu.

Configuring data acquisition is only possible for the MSRA Master channel. In I/Q Analyzer application channels, these settings define the analysis interval (see "Multi-Standard Analysis"). Be sure to select the correct measurement channel before changing these settings.

└ Sample Rate
└ Analysis Bandwidth
└ Maximum Bandwidth
└ Meas Time
└ Record Length
└ RBW
└ Advanced FFT mode / Basic settings
└ Transformation Algorithm
└ FFT Length
└ Window Function
└ Window Overlap
└ Window Length
└ Capture Offset


Sample Rate

MSRA Mode > Configuration > Data Acquisition and Bandwidth Settings > Data Acquisition > Sample Rate
Sample Rate

Defines the I/Q data sample rate of the R&S FSW. This value is dependent on the defined "Analysis Bandwidth" and the defined signal source.

Up to the "Maximum Bandwidth", the following rule applies:

sample rate = analysis bandwidth / 0.8

For details on the dependencies see "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input".

In particular, note the irregularity mentioned in "Max. Sample Rate and Bandwidth with Activated I/Q Bandwidth Extension Option B500".

Remote command:

TRACe:​IQ:​SRATe


Analysis Bandwidth

MSRA Mode > Configuration > Data Acquisition and Bandwidth Settings > Data Acquisition > Analysis Bandwidth
Analysis Bandwidth

Defines the flat, usable bandwidth of the final I/Q data. This value is dependent on the defined "Sample Rate" and the defined signal source.

Up to the "Maximum Bandwidth", the following rule applies:

analysis bandwidth = 0.8 * sample rate

For details on the dependencies see "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input".

In particular, note the irregularity mentioned in "Max. Sample Rate and Bandwidth with Activated I/Q Bandwidth Extension Option B500".

Note: For input from the Analog Baseband interface (R&S FSW-B71): If the frequency range defined by the analysis bandwidth and the center frequency exceeds the minimum frequency (0 Hz for low IF evaluation) or the maximum frequency (for I+jQ evaluation), an error is displayed. In this case, adjust the center frequency (see "Center Frequency") or the analysis bandwidth to exclude possible unwanted signal components.

Remote command:

TRACe:​IQ:​BWIDth


Maximum Bandwidth

MSRA Mode > Configuration > Data Acquisition and Bandwidth Settings > Data Acquisition > Maximum Bandwidth
Maximum Bandwidth

Defines the maximum bandwidth to be used by the R&S FSW for I/Q data acquisition. This setting is only available if the bandwidth extension option R&S FSW-B160/-B320/-B500 is installed. Otherwise the maximum bandwidth is determined automatically.

For details on the maximum bandwidth see "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input".

"Auto"

(Default) All installed bandwidth extension options are activated. The currently available maximum bandwidth is allowed (see "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input").

Note that using bandwidth extension options R&S FSW-B160/-B320 may cause more spurious effects (option B500 does not).

"80 MHz"

Restricts the analysis bandwidth to a maximum of 80 MHz.

The bandwidth extension options R&S FSW-B160/-B320/-B500 are deactivated.

"160 MHz"

Restricts the analysis bandwidth to a maximum of 160 MHz. The bandwidth extension option R&S FSW-B320 is deactivated.

(Not available or required if bandwidth extension option R&S FSW-B500 is installed.)

Remote command:

TRACe:​IQ:​WBANd[:​STATe]

TRACe:​IQ:​WBANd:​MBWIDTH


Meas Time

MSRA Mode > Configuration > Data Acquisition and Bandwidth Settings > Data Acquisition > Meas Time
Meas Time

Defines the I/Q acquisition time. By default, the measurement time is calculated as the number of I/Q samples ("Record Length") divided by the sample rate. If you change the measurement time, the "Record Length" is automatically changed, as well.

For details on the maximum number of samples see also "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input".

Remote command:

[SENSe:​]SWEep:​TIME


Record Length

MSRA Mode > Configuration > Data Acquisition and Bandwidth Settings > Data Acquisition > Record Length
Record Length

Defines the number of I/Q samples to record. By default, the number of sweep points is used. The record length is calculated as the measurement time multiplied by the sample rate. If you change the record length, the "Meas Time" is automatically changed, as well.

Note: For the I/Q vector result display, the number of I/Q samples to record ("Record Length") must be identical to the number of trace points to be displayed ("Sweep Points"). Thus, the sweep points are not editable for this result display. If the "Record Length" is edited, the sweep points are adapted automatically.
For record lengths outside the valid range of sweep points, i.e. less than 101 points or more than 100001 points, the diagram does not show valid results.

Remote command:

TRACe:​IQ:​RLENgth


RBW

MSRA Mode > Configuration > Data Acquisition and Bandwidth Settings > Data Acquisition > RBW
RBW

Defines the resolution bandwidth. The maximum RBW corresponds to the "Analysis Bandwidth". The minimum RBW depends on the sample rate.

Depending on the selected RBW mode, the value is either determined automatically or can be defined manually. As soon as you enter a value in the input field, the RBW mode is changed to "Manual".

If the "Advanced Fourier Transformation Params" option is enabled, advanced FFT mode is selected and the RBW cannot be defined directly.

Note that the RBW is correlated with the "Sample Rate" and "Record Length" (and possibly the "Window Function" and "Window Length"). Changing any one of these parameters may cause a change to one or more of the other parameters.

"Auto mode"

(Default) The RBW is determined automatically depending on the "Sample Rate" and "Record Length".

"Manual mode"

The RBW can be defined by the user. The maximum RBW corresponds to the "Analysis Bandwidth". The minimum RBW depends on the sample rate.

The user-defined RBW is used and the "Window Length" (and possibly "Sample Rate") are adapted accordingly.

"Advanced FFT mode"

This mode is used if the "Advanced Fourier Transformation Params" option is enabled.

The RBW is determined by the advanced FFT parameters.

Remote command:

[SENSe:​]IQ:​BANDwidth|BWIDth:​MODE

[SENSe:​]IQ:​BANDwidth|BWIDth:​RESolution


Advanced FFT mode / Basic settings

MSRA Mode > Configuration > Data Acquisition and Bandwidth Settings > Data Acquisition > Advanced FFT mode / Basic settings
Advanced FFT mode / Basic settings

Shows or hides the "Advanced Fourier Transformation" parameters in the "Data Acquisition" dialog box. These parameters are only available and required for the advanced FFT mode.

└ Transformation Algorithm
└ FFT Length
└ Window Function
└ Window Overlap
└ Window Length


Transformation Algorithm

MSRA Mode > Configuration > Data Acquisition and Bandwidth Settings > Data Acquisition > Advanced FFT mode / Basic settings > Transformation Algorithm
Transformation Algorithm

Defines the FFT calculation method.

For more information see "Basics on FFT" .

"Single" | One FFT is calculated for the entire record length; if the "FFT Length" is larger than the record length, zeros are appended to the captured data.
"Averaging" | Several overlapping FFTs are calculated for each record; the results are combined to determine the final FFT result for the record. The number of FFTs to be averaged is determined by the "Window Overlap" and the "Window Length".
Remote command:

[SENSe:​]IQ:​FFT:​ALGorithm


FFT Length

MSRA Mode > Configuration > Data Acquisition and Bandwidth Settings > Data Acquisition > Advanced FFT mode / Basic settings > FFT Length
FFT Length

Defines the number of frequency points determined by each FFT calculation. The more points are used, the higher the resolution in the spectrum becomes, but the longer the calculation takes.

In advanced FFT mode, the number of sweep points is set to the FFT length automatically.

Note: If you use the arrow keys or the rotary knob to change the FFT length, the value is incremented or decremented by powers of 2.
If you enter the value manually, any integer value from 3 to 524288 is available.

For more information see "Basics on FFT" .

Remote command:

[SENSe:​]IQ:​FFT:​LENGth


Window Function

MSRA Mode > Configuration > Data Acquisition and Bandwidth Settings > Data Acquisition > Advanced FFT mode / Basic settings > Window Function
Window Function

In the I/Q analyzer you can select one of several FFT window types.

For details on the effects of FFT windowing functions see "Basics on FFT" .

The following window types are available:
  • Blackman-Harris
  • Flattop
  • Gauss
  • Rectangular
  • 5-Term
Remote command:

[SENSe:​]IQ:​FFT:​WINDow:​TYPE


Window Overlap

MSRA Mode > Configuration > Data Acquisition and Bandwidth Settings > Data Acquisition > Advanced FFT mode / Basic settings > Window Overlap
Window Overlap

Defines the part of a single FFT window that is re-calculated by the next FFT calculation when using multiple FFT windows.

For more information see "Basics on FFT" .

Remote command:

[SENSe:​]IQ:​FFT:​WINDow:​OVERlap


Window Length

MSRA Mode > Configuration > Data Acquisition and Bandwidth Settings > Data Acquisition > Advanced FFT mode / Basic settings > Window Length
Window Length

Defines the number of samples to be included in a single FFT window in averaging mode. (In single mode, the window length corresponds to the "Record Length".)

Values from 3 to 524288 are available, however, the window length may not be longer than the "FFT Length".

For more information see "Basics on FFT" .

Remote command:

[SENSe:​]IQ:​FFT:​WINDow:​LENGth


Capture Offset

MSRA Mode > Configuration > Data Acquisition and Bandwidth Settings > Data Acquisition > Capture Offset
Capture Offset

This setting is only available for applications in MSRA operating mode. It has a similar effect as the trigger offset in other measurements: it defines the time offset between the capture buffer start and the start of the extracted application data.

In MSRA mode, the offset must be a positive value, as the capture buffer starts at the trigger time = 0.

For more information see "Trigger offset vs. capture offset".

Remote command:

[SENSe:​]MSRA:​CAPTure:​OFFSet


Sweep Settings

MSRA Mode > Configuration > Data Acquisition and Bandwidth Settings > Sweep Settings
Sweep Settings

The sweep settings are configured via the SWEEP key or in the "Sweep" tab of the "Bandwidth" dialog box.

►

To display this dialog box, do one of the following:

  • Select the "Bandwidth" button in the configuration "Overview" and switch to the "Sweep" tab.
  • Select the SWEEP key and then the "Sweep Config" softkey.

For background information on performing sweeps in MSRA mode see "Data Acquisition".

└ Sweep Points
└ Refresh
└ Continuous Sweep/RUN CONT
└ Single Sweep/ RUN SINGLE
└ Continue Single Sweep


Sweep Points

MSRA Mode > Configuration > Data Acquisition and Bandwidth Settings > Sweep Settings > Sweep Points
Sweep Points

In the I/Q Analyzer application, a specific frequency bandwidth is swept for a specified measurement time. During this time, a defined number of samples (= "Record Length") are captured. These samples are then evaluated by the applications. Therefore, in this case the number of sweep points does not define the amount of data to be acquired, but rather the number of trace points that are evaluated and displayed in the result diagrams.

Note: As opposed to previous versions of the I/Q Analyzer, the sweep settings are now window-specific. For some result displays, the sweep points may not be editable as they are determined automatically, or restrictions may apply.
For the I/Q vector result display, the number of I/Q samples to record ("Record Length") must be identical to the number of trace points to be displayed ("Sweep Points"). Thus, the sweep points are not editable for this result display. If the "Record Length" is edited, the sweep points are adapted automatically. For record lengths outside the valid range of sweep points, i.e. less than 101 points or more than 32001 points, the diagram does not show valid results.
Using fewer than 4096 sweep points with a detector other than Auto Peak may lead to wrong level results.

Remote command:

[SENSe:​]SWEep:​POINts


Refresh

MSRA Mode > Configuration > Data Acquisition and Bandwidth Settings > Sweep Settings > Refresh
Refresh

This function is only available if the Sequencer is deactivated and only for MSRA applications.

The data in the capture buffer is re-evaluated by the currently active application only. The results for any other applications remain unchanged.

This is useful, for example, after evaluation changes have been made or if a new sweep was performed from another application; in this case, only that application is updated automatically after data acquisition.

Note: To update all active applications at once, use the "Refresh all" function in the "Sequencer" menu.
(See "Refresh All").

Remote command:

INITiate:​REFResh


Continuous Sweep/RUN CONT

MSRA Mode > Configuration > Data Acquisition and Bandwidth Settings > Sweep Settings > Continuous Sweep/RUN CONT
Continuous Sweep/RUN CONT

After triggering, initiates data acquisition continuously until stopped. If the Sequencer is off, only the evaluation for the currently displayed measurement channel is updated.

While the measurement is running, the "Continuous Sweep" softkey and the RUN CONT key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again. The results are not deleted until a new measurement is started.

Note: Sequencer. If the Sequencer is active, the "Continuous Sweep" softkey only controls the sweep mode for the currently selected channel; however, the sweep mode only has an effect the next time the Sequencer activates that channel, and only for a channel-defined sequence. In this case, a channel in continuous sweep mode is swept repeatedly.
Furthermore, the RUN CONT key on the front panel controls the Sequencer, not individual sweeps. RUN CONT starts the Sequencer in continuous mode.
For details on the Sequencer, see "The Sequencer Concept" .

Remote command:

INITiate:​CONTinuous


Single Sweep/ RUN SINGLE

MSRA Mode > Configuration > Data Acquisition and Bandwidth Settings > Sweep Settings > Single Sweep/ RUN SINGLE
Single Sweep/ RUN SINGLE

After triggering, starts a single data acquisition. If the Sequencer is off, only the evaluation for the currently displayed measurement channel is updated.

While the measurement is running, the "Single Sweep" softkey and the RUN SINGLE key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again.

Note: Sequencer. If the Sequencer is active, the "Single Sweep" softkey only controls the sweep mode for the currently selected channel; however, the sweep mode only has an effect the next time the Sequencer activates that channel, and only for a channel-defined sequence. In this case, a channel in single sweep mode is swept only once by the Sequencer.
Furthermore, the RUN SINGLE key on the front panel controls the Sequencer, not individual sweeps. RUN SINGLE starts the Sequencer in single mode.
If the Sequencer is off, only the evaluation for the currently displayed measurement channel is updated.
For details on the Sequencer, see "The Sequencer Concept" .

Remote command:

INITiate[:​IMMediate]


Continue Single Sweep

MSRA Mode > Configuration > Data Acquisition and Bandwidth Settings > Sweep Settings > Continue Single Sweep
Continue Single Sweep

After triggering, repeats data acquisition without deleting the trace of the last measurement. If the Sequencer is off, only the evaluation for the currently displayed measurement channel is updated.

While the measurement is running, the "Continue Single Sweep" softkey and the RUN SINGLE key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again.

Remote command:

INITiate:​CONMeas


Output Settings

MSRA Mode > Configuration > Output Settings
Output Settings

The R&S FSW can provide output to special connectors for other devices.

For details on connectors refer to "Instrument Tour" .

Providing trigger signals as output is described in "How to Output a Trigger Signal" .

Output settings can be configured via the INPUT/OUTPUT key or in the "Outputs" dialog box.

└ Noise Source
└ Trigger 2/3
└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


Noise Source

MSRA Mode > Configuration > Output Settings > Noise Source
Noise Source

Switches the supply voltage for an external noise source on or off.

External noise sources are useful when you are measuring power levels that fall below the noise floor of the R&S FSW itself, for example when measuring the noise level of a DUT.

Remote command:

DIAGnostic:​SERVice:​NSOurce


Display Configuration

MSRA Mode > Configuration > Display Configuration
Display Configuration

The captured signal can be displayed using various evaluation methods. All evaluation methods available for the current application are displayed in the evaluation bar in SmartGrid mode when you do one of the following:

  • Select the [image] "SmartGrid" icon from the toolbar.
  • Select the "Display Config" button in the "Overview".
  • Press the MEAS key.
  • Select the "Display Config" softkey in the main application menu.

Up to 6 evaluations can be displayed in the I/Q Analyzer and thus in the MSRA Master at any time, including several graphical diagrams, marker tables or peak lists.

For a description of the available evaluation methods see the "Measurements and Result Displays" topic of the corresponding application User Manual.

The evaluation methods are described in "Measurement and Result Displays" . For details on working with the SmartGrid see "Laying out the Result Display with the SmartGrid" .

The evaluation methods for the MSRA Master are described in the "Measurements and Result Displays" topic of the R&S I/Q Analyzer User Manual. For details on working with the SmartGrid see the R&S FSW Getting Started manual.


Automatic Settings

MSRA Mode > Configuration > Automatic Settings
Automatic Settings

Some settings can be adjusted by the R&S FSW automatically according to the current measurement settings.

To activate the automatic adjustment of a setting, select the corresponding function in the AUTO SET menu or in the configuration dialog box for the setting, where available.

Settings related to data acquisition (measurement time, hysteresis) can only be adjusted in the MSRA Master, not in the applications.

└ Adjusting all Determinable Settings Automatically (Auto All)
└ Adjusting the Center Frequency Automatically (Auto Freq)
└ Setting the Reference Level Automatically (Auto Level)
└ Resetting the Automatic Measurement Time (Meastime Auto)
└ Changing the Automatic Measurement Time (Meastime Manual)
└ Upper Level Hysteresis
└ Lower Level Hysteresis


Adjusting all Determinable Settings Automatically (Auto All)

MSRA Mode > Configuration > Automatic Settings > Adjusting all Determinable Settings Automatically (Auto All)
Adjusting all Determinable Settings Automatically (Auto All)

Activates all automatic adjustment functions for the current measurement settings.

This includes:

  • Auto Level

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​ALL


Adjusting the Center Frequency Automatically (Auto Freq)

MSRA Mode > Configuration > Automatic Settings > Adjusting the Center Frequency Automatically (Auto Freq)
Adjusting the Center Frequency Automatically (Auto Freq)

This function adjusts the center frequency automatically.

The optimum center frequency is the frequency with the highest S/N ratio in the frequency span. As this function uses the signal counter, it is intended for use with sinusoidal signals.

(See "Performing a Highly Accurate Frequency Measurement (Signal Count)" )

Remote command:

[SENSe:​]ADJust:​FREQuency


Setting the Reference Level Automatically (Auto Level)

MSRA Mode > Configuration > Automatic Settings > Setting the Reference Level Automatically (Auto Level)
Setting the Reference Level Automatically (Auto Level)

Automatically determines the optimal reference level for the current input data. At the same time, the internal attenuators and the preamplifier (for analog baseband input: the full scale level) are adjusted so the signal-to-noise ratio is optimized, while signal compression, clipping and overload conditions are minimized.

In order to do so, a level measurement is performed to determine the optimal reference level.

This function is only available for the MSRA/MSRT Master, not for the applications.

You can change the measurement time for the level measurement if necessary (see "Changing the Automatic Measurement Time (Meastime Manual)").

Remote command:

[SENSe:​]ADJust:​LEVel


Resetting the Automatic Measurement Time (Meastime Auto)

MSRA Mode > Configuration > Automatic Settings > Resetting the Automatic Measurement Time (Meastime Auto)
Resetting the Automatic Measurement Time (Meastime Auto)

Resets the measurement duration for automatic settings to the default value.

For details see "Adjusting Settings Automatically" .

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​CONFigure:​DURation:​MODE


Changing the Automatic Measurement Time (Meastime Manual)

MSRA Mode > Configuration > Automatic Settings > Changing the Automatic Measurement Time (Meastime Manual)
Changing the Automatic Measurement Time (Meastime Manual)

This function allows you to change the measurement duration for automatic setting adjustments. Enter the value in seconds.

For details see "Adjusting Settings Automatically" .

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​CONFigure:​DURation:​MODE

[SENSe:​]ADJust:​CONFigure:​DURation


Upper Level Hysteresis

MSRA Mode > Configuration > Automatic Settings > Upper Level Hysteresis
Upper Level Hysteresis

When the reference level is adjusted automatically using the Auto Level function, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines an upper threshold the signal must exceed (compared to the last measurement) before the reference level is adapted automatically.

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​CONFigure:​HYSTeresis:​UPPer


Lower Level Hysteresis

MSRA Mode > Configuration > Automatic Settings > Lower Level Hysteresis
Lower Level Hysteresis

When the reference level is adjusted automatically using the Auto Level function, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines a lower threshold the signal must fall below (compared to the last measurement) before the reference level is adapted automatically.

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​CONFigure:​HYSTeresis:​LOWer


Analysis

MSRA Mode > Analysis
Analysis

The data that was captured by the MSRA Master can be analyzed in various different applications.

The analysis settings and functions available in MSRA mode are those described for the individual applications. The MSRA Master is in effect an I/Q Analyzer application and has the same analysis functions and settings.

See "Analysis" for a description of the analysis functions and settings available for the I/Q Analyzer and thus the MSRA master.

Configuring the application data extract and analysis interval

The settings required to configure the application data extract or analysis intervals vary depending on the application. See the corresponding application manuals for details.

For the I/Q Analyzer, the settings are the same as those used to define the actual data acquisition (see "Data Acquisition". In MSRA application channels, they define the analysis interval. Be sure to select the correct measurement channel before executing these commands.

Exporting I/Q Data

The captured I/Q data from the MSRA Master can be exported for further analysis in external applications.

The export functions are available in the "Save/Recall" menu which is displayed when you select the [image] "Save" or [image] "Open" icon in the toolbar.

For details on exporting I/Q data see "I/Q Data Import and Export" .

Contents
  • Configuring the Analysis Line


Configuring the Analysis Line

MSRA Mode > Analysis > Configuring the Analysis Line
Configuring the Analysis Line

To hide or show and position the analysis line, a dialog box is available. To display the "Analysis Line" dialog box, select the "AL" icon in the toolbar (only available in MSRA mode). The current position of the analysis line is indicated on the icon.

└ Position
└ Show Line


Position

MSRA Mode > Analysis > Configuring the Analysis Line > Position
Position

Defines the position of the analysis line in the time domain. The position must lie within the measurement time of the multistandard measurement.

Remote command:

CALCulate:​MSRA:​ALINe[:​VALue]


Show Line

MSRA Mode > Analysis > Configuring the Analysis Line > Show Line
Show Line

Hides or displays the analysis line in the time-based windows. By default, the line is displayed.

Note: even if the analysis line display is off, the indication whether or not the currently defined line position lies within the analysis interval of the active application remains in the window title bars.

Remote command:

CALCulate:​MSRA:​ALINe:​SHOW


How to Perform Measurements in MSRA Mode

MSRA Mode > How to Perform Measurements in MSRA Mode
How to Perform Measurements in MSRA Mode

The following step-by-step instructions demonstrate how to perform a measurement in MSRA mode.

How to capture I/Q data in MSRA mode

  1. Press the MODE key on the front panel and select the "MSRA" operating mode.

    Confirm the message.

  2. Select the "Overview" softkey to display the "Overview" for an MSRA measurement.

  3. Select the "Input" button to select the input signal source.

  4. Select the "Amplitude" button to define the attenuation, reference level or other settings that affect the input signal's amplitude and scaling.

  5. Select the "Frequency" button to define the input signal's center frequency.

  6. Optionally, select the "Trigger" button and define a trigger for data acquisition, for example an IQ Power trigger to start capturing data only when a specific power is exceeded.

  7. Select the "Bandwidth" button and define the bandwidth parameters for data acquisition:

    • "Sample rate" or "Analysis Bandwidth:" the span of the input signal to be captured for analysis, or the rate at which samples are captured (both values are correlated)
    • Optionally, if a bandwidth extension (> 160 MHz) is installed, the "Maximum Bandwidth", depending on whether you require a larger bandwidth or fewer spurious emissions.
    • "Measurement Time:" how long the data is to be captured
    • "Record Length": the number of samples to be captured (also defined by sample rate and measurement time)

  8. If necessary, select the "Display Config" button and select other displays (up to a total of 6) required to control the acquired data.

    Arrange them on the display to suit your preferences.

  9. Exit the SmartGrid mode.

  10. Optionally, stop continuous measurement mode by the Sequencer and perform a single data acquisition:

    1. Select the Sequencer icon ( [image]) from the toolbar.

    2. Set the Sequencer state to "OFF".

    3. Press the RUN SINGLE key.

  11. Optionally, export the captured or analyzed I/Q data (depending on the active channel) to a file.

    1. Select the [image] "Save" icon in the toolbar.

    2. Select the "I/Q Export" softkey.

    3. Define a file name and storage location and select "Save".

    The captured data is stored to a file with the extension .iq.tar.

    Now you can analyze the captured I/Q data in various MSRA applications at the same time.

How to analyze the captured I/Q data in MSRA applications

  1. Press the MODE key on the front panel and select an MSRA application.

  2. Select the "Overview" softkey to display the "Overview" for the MSRA application.

  3. Define the application data extract, i.e. the range of the capture buffer you want to analyze in this application.

  4. Define the analysis interval, i.e. the frame number or similar within the application data you want to analyze in this application (not necessary for I/Q Analyzer or Analog Demodulation applications).

  5. Select the "Frequency" button and define the center frequency for the analysis interval.

  6. Select the "Display Config" button and select other displays (up to a total of 6) to analyze the data in the configured interval.

    Arrange them on the display to suit your preferences.

  7. Exit the SmartGrid mode.

    Repeat these steps for any other applications.

How to perform multi-standard analysis of the I/Q data

  1. Perform a single I/Q data aquisition measurement as described in "How to capture I/Q data in MSRA mode".

  2. Activate measurement channels for the MSRA applications you require as described in "How to analyze the captured I/Q data in MSRA applications".

  3. Select the MSRA View to get an overview of the captured data and the configured applications.

    Determine the individual data ranges that are relevant for a specific standard. If necessary, adapt the application data and analysis interval settings for the applications to reflect the relevant data ranges.

  4. If the results indicate that dependencies between different standards in the signal may exist:

    1. Select the application in which unusual data occurs.

    2. If necessary, perform a new data acquisition.

    3. Determine the bandwidth or measurement time of the unusual data.

    4. Select the MSRA View to compare the data with the other standard applications.

      If a specific event (e.g. a burst, spur etc.) occurs in another standard at the same time as the unusual data in the first application, the two effects may be correlated.

    5. Select the possibly dependant standard application.

    6. Define an analysis interval for the conspicuous data range (as described in "How to analyze the captured I/Q data in MSRA applications").

    7. Refresh the result display for the changed analysis interval ("Sweep" menu).

    Now you can analyze the data in detail to determine the cause of the unusual signal behavior.

How to perform a measurement in the time or frequency domain in MSRA mode

  1. Capture I/Q data with the MSRA Master as described in "How to capture I/Q data in MSRA mode".

  2. Activate an "I/Q Analyzer" channel as an MSRA application as described in "How to analyze the captured I/Q data in MSRA applications".

  3. In the I/Q Analyzer application, press the MEAS key on the front panel of the R&S FSW.

  4. From the "Select Measurement" dialog box, select the required measurement in the time or frequency domain.

  5. Configure the measurement as described in "Measurements" .

    The I/Q data captured by the MSRA Master is analyzed in the time or frequency domain, according to the selected measurement and result displays.

  6. To switch back to a conventional I/Q analysis, press the MEAS key on the front panel of the R&S FSW and select the "IQ Analyzer" measurement.


Measurement Example: Analyzing MSR Signals

MSRA Mode > Measurement Example: Analyzing MSR Signals
Measurement Example: Analyzing MSR Signals

Using the MSRA, you can examine crosstalk between different radio access technologies (RAT) sent out from a base station at the same time. Furthermore, you can determine any signal interference between two or more carriers due to time correlation, as you can analyze the same signal data (captured at exactly the same time) in various applications.

The following measurement example demonstrates how to capture data from a signal with 4 carriers using different standards (GSM, WCDMA, LTE, GSM) and then analyze the data in the MSRA operating mode using the I/Q Analyzer and the 3GPP FDD BTS application.

Measurement setup

The measurements are performed using the following instruments and accessories:

  • The R&S FSW with application firmware R&S FSW-K72: 3GPP FDD BTS Measurements
  • A Vector Signal Generator:
    R&S SMU (with options R&S SMU-K240 Dig. Std GSM/EDGE, SMU-K242 Dig. Std 3GPP FDD, SMU-K255 Dig. Std EUTRA)
    or
    R&S SMBV (with options R&S SMBV -K240 Dig. Std GSM/EDGE, SMBV-K242 Dig. Std 3GPP FDD, SMBV-K255 Dig. Std EUTRA)
    (The vector signal generator is referred to as SMx in the example.)
  • 1 coaxial cable, 50Ω, approx. 1 m, N connector
  • 1 coaxial cable, 50Ω, approx. 1 m, BNC connector
To set up the instruments

  1. Connect the "RF output" of the SMx to the RF INPUT connector on the front panel of the R&S FSW (coaxial cable with an N connector).

  2. Connect the "Marker1" output of the SMx to the TRIGGER INPUT connector on the front panel of the R&S FSW (coaxial cable with a BNC connector).

Preparation

The waveform of the described multi-standard signal is provided in the following file on the R&S FSW:

C:\R_S\Instr\user\Waveforms\MSRA_GSM_WCDMA_LTE_GSM.wv

The signal is described in the Readme.txt file in the same folder.

►

Copy the file from the R&S FSW to the SMx using a USB stick, for example.

Settings on the R&S SMx

  1. Press the PRESET key to reset the instrument.

  2. Press the FREQ key and set the frequency to 1 GHz.

  3. Press the LEVEL key and set the level to 0 dBm.

  4. Press the RF ON/OFF key to switch the RF on.

  5. Press the DIAGRAM key and then select "Load Waveform" to load the signal data from the provided file. From the drive for the USB stick, select the file C:\R_S\Instr\user\Waveforms\MSRA_GSM_WCDMA_LTE_GSM.wv.

  6. Select the "Trigger/Marker" menu and set "Marker1" to "Restart".

    Press the ESC key to close the dialog box.

  7. Switch the "State" button to "ON" to activate the waveform.

Settings on the R&S FSW

  1. Press the PRESET key to preset the R&S FSW.

  2. Press the MODE key and select the "Multi-Standard Radio Analyzer" tab. Confirm the message to switch to MSRA mode.

  3. Press the FREQ key and set the "Center Frequency" to 1 GHz.

  4. Press the AMPT key and set the reference level to 10 dBm.

  5. Press the TRIG key and select "External Trigger 1" to use the external trigger from the SMU.

  6. Press the MEAS CONFIG key, select the "Data Acquisition" softkey and set the "Sample Rate" to 15 MHz.

    Since the R&S FSW is set to continuous sweep mode by default, data acquisition is started automatically. The spectrum of the stored MSR signal from the file is displayed in the "MSRA Master" tab.

To analyze the GSM signal

Activate an I/Q Analyzer to analyze the GSM signal in more detail. Only the area around the first carrier is of interest.

  1. Press the MODE key and select the "I/Q Analyzer" button.

  2. Press the FREQ key and set the center frequency to 994.9 MHz.

  3. Press the MEAS CONFIG key, select the "Data Acquisition" softkey and set the "Sample Rate" to 1 MHz.

  4. Set the "Meas Time" to 5 ms.

    The I/Q Analyzer obtains an extract of the data captured by the MSRA Master. Which spectrum of the captured data is analyzed is indicated by vertical blue lines in the MSRA Master window (see figure "MSRA View for I/Q Analyzer and 3GPP FDD BTS applications").

To analyze the WCDMA signal

Activate a measurement channel for the 3GPP FDD BTS application to analyze the WCDMA signal in more detail. Now the second carrier is of interest.

  1. Press the MODE key and select the "3GPP FDD BTS" button.

  2. Press the FREQ key and set the center frequency to 997.5 MHz.

    The 3GPP FDD BTS application obtains an extract of the data captured by the MSRA Master.

  3. Select the "MSRA View" tab to see the captured data and the GSM and WCDMA results at once.

    Which spectrum of the captured data is analyzed is indicated by vertical blue lines in the "MSRA Master" window.

    MSRA View for I/Q Analyzer and 3GPP FDD BTS applications

  4. Select the "3GPP FDD BTS" tab to return to the detailed WCDMA results.

  5. Display the composite EVM of the WCDMA carrier:

    1. Press the MEAS CONFIG key, then select the "Display Config" softkey.

    2. Scroll through the result display buttons until you see "Composite EVM", then drag the button to the diagram area of the display.

      The "Code Domain Power" display is replaced by the "Composite EVM" display.

    3. Select the red cross at the top of the result display list ( [image]) to close the SmartGrid mode.

  6. To optimize the diagram display, press the AUTO SET key and select "Auto Scale Window".

    Composite EVM of the WCDMA carrier

    The slots 1, 2, 8, and 9 show a much higher EVM than the other slots.

  7. Analyze the EVM for the chips in these slots:

    1. Press the MEAS CONFIG key, then select the "Display Config" softkey.

    2. Drag the "EVM vs Chip" button over the "Result Summary" beneath the "Composite EVM" display to replace it.

    3. Select the red cross at the top of the result display list ( [image]) to close the SmartGrid mode.

    The EVM vs Chip results are displayed for slot 0.

  8. Take a closer look at slot 1, which had a high EVM:

    1. Select the "Evaluation Range" softkey and set the "Slot" to 1.

      Slot 1 is highlighted red in the Composite EVM display.

    2. Select the "EVM vs Chip" window to set the focus on it.

      The EVM for the individual chips in slot 1 is displayed.

      Note the analysis interval displayed in the window title bar, which indicates that the data displayed in the "EVM vs Chip" window was captured in the time interval 667 μs to 1.3 ms (referred to the absolute time of the I/Q signal captured with the MSRA Master).

    3. Press the PEAK SEARCH key to place Marker1 on the chip with the highest EVM in slot 1.

    Determining the chip with the highest EVM in a WCDMA slot
To determine time correlations in the MSR signal

You can use the analysis line to mark an occurrance in time in one application and see the same moment in time in another application, and thus find the source of irregularities.

  1. Select the "I/Q Analyzer" tab.

  2. Select the [image] icon in the toolbar and move the analysis line (either using the rotary knob or by dragging the line on the screen) until it reaches the irregular EVM in the "EVM vs Chip" display. The new position of the analysis line in the example is 1.156ms.

    If you switch to the IQ Analyzer and regard the "Magnitude" display, you see that the analysis line is on the rising edge of the GSM burst.

    Correlating events in an MSR signal

    You can assume the GSM burst had an effect on the WCDMA carrier, causing an error.

Conclusion of the measurement example

In MSRA mode it is very easy to find crosstalk between different carriers by detecting time correlations between different signals, since the analysis is performed on the same recorded I/Q data. This is especially easy to detect using the analysis line in the MSRA View, as the time of a particular event is visible in the captured data and all individual application windows at once.

MSRA View of MSR signal with time correlations
Capturing and analyzing long data sequences

The MSRA also allows you to capture very long data sequences. In order to examine particular areas of the large I/Q memory, each MSRA application supports a "Capture Offset" setting (TRIG menu, or "Data acquisition"/"Signal Capture" dialog box).

In the "MSRA Master" tab, the vertical blue lines in the "Magnitude" result display indicate which time interval of the I/Q data is analyzed by the individual applications. In this example, 40 ms are captured, the 3GPP FDD BTS application starts analysis at a Capture Offset of 20 ms (5 divisions with 4.0 ms/div), and the I/Q Analyzer starts with an offset of 31.5 ms.


Remote Commands to Perform Measurements in MSRA Mode

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode
Remote Commands to Perform Measurements in MSRA Mode

The following commands are specific to performing measurements in MSRA mode in a remote environment. Generally, the remote commands are identical to those used in Spectrum mode as described in the R&S FSW User Manual. However, some restrictions or conditions may apply to specific commands (see also "MSRA Basics").

You must always switch to MSRA mode before executing any MSRA-specific commands (using INST:MODE MSR).

It is assumed that the R&S FSW has already been set up for remote control in a network as described in "How to Set Up a Network and Remote Control" .

Note that basic tasks that are also performed in the base unit in the same way are not described here.

In particular, this includes:

  • Managing Settings and Results, i.e. storing and loading settings and result data, see "Managing Settings and Results"
  • Basic instrument configuration, e.g. checking the system configuration, customizing the screen layout, or configuring networks and remote operation, see "Configuring the "
  • Using the common status registers, see "Using the Status Register"

The following tasks specific to MSRA mode are described here:

Contents
  • Introduction
  • Common Suffixes
  • Activating MSRA Measurements
  • Configuring MSRA Measurements
  • Capturing Data and Performing Sweeps
  • Retrieving Results
  • Querying the Status Registers
  • Analyzing MSRA Measurements
  • Commands Specific to MSRA Applications
  • Programming Example: Analyzing MSR Signals


Introduction

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Introduction
Introduction

Commands are program messages that a controller (e.g. a PC) sends to the instrument or software. They operate its functions ('setting commands' or 'events') and request information ('query commands'). Some commands can only be used in one way, others work in two ways (setting and query). If not indicated otherwise, the commands can be used for settings and queries.

The syntax of a SCPI command consists of a header and, in most cases, one or more parameters. To use a command as a query, you have to append a question mark after the last header element, even if the command contains a parameter.

A header contains one or more keywords, separated by a colon. Header and parameters are separated by a "white space" (ASCII code 0 to 9, 11 to 32 decimal, e.g. blank). If there is more than one parameter for a command, these are separated by a comma from one another.

Only the most important characteristics that you need to know when working with SCPI commands are described here. For a more complete description, refer to the User Manual of the R&S FSW.

Remote command examples

Note that some remote command examples mentioned in this general introduction may not be supported by this particular application.

Contents
  • Long and Short Form
  • Numeric Suffixes
  • Optional Keywords
  • Alternative Keywords
  • SCPI Parameters


Long and Short Form

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Introduction > Long and Short Form
Long and Short Form

The keywords have a long and a short form. You can use either the long or the short form, but no other abbreviations of the keywords.

The short form is emphasized in upper case letters. Note however, that this emphasis only serves the purpose to distinguish the short from the long form in the manual. For the instrument, the case does not matter.

Example:

SENSe:FREQuency:CENTer is the same as SENS:FREQ:CENT.


Numeric Suffixes

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Introduction > Numeric Suffixes
Numeric Suffixes

Some keywords have a numeric suffix if the command can be applied to multiple instances of an object. In that case, the suffix selects a particular instance (e.g. a measurement window).

Numeric suffixes are indicated by angular brackets (<n>) next to the keyword.

If you don't quote a suffix for keywords that support one, a 1 is assumed.

Example:

DISPlay[:WINDow<1...4>]:ZOOM:STATe enables the zoom in a particular measurement window, selected by the suffix at WINDow.

DISPlay:WINDow4:ZOOM:STATe ON refers to window 4.


Optional Keywords

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Introduction > Optional Keywords
Optional Keywords

Some keywords are optional and are only part of the syntax because of SCPI compliance. You can include them in the header or not.

Note that if an optional keyword has a numeric suffix and you need to use the suffix, you have to include the optional keyword. Otherwise, the suffix of the missing keyword is assumed to be the value 1.

Optional keywords are emphasized with square brackets.

Example:

Without a numeric suffix in the optional keyword:

[SENSe:]FREQuency:CENTer is the same as FREQuency:CENTer

With a numeric suffix in the optional keyword:

DISPlay[:WINDow<1...4>]:ZOOM:STATe

DISPlay:ZOOM:STATe ON enables the zoom in window 1 (no suffix).

DISPlay:WINDow4:ZOOM:STATe ON enables the zoom in window 4.


Alternative Keywords

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Introduction > Alternative Keywords
Alternative Keywords

A vertical stroke indicates alternatives for a specific keyword. You can use both keywords to the same effect.

Example:

[SENSe:]BANDwidth|BWIDth[:RESolution]

In the short form without optional keywords, BAND 1MHZ would have the same effect as BWID 1MHZ.


SCPI Parameters

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Introduction > SCPI Parameters
SCPI Parameters

Many commands feature one or more parameters.

If a command supports more than one parameter, these are separated by a comma.

Example:

LAYout:ADD:WINDow Spectrum,LEFT,MTABle

Parameters may have different forms of values.

Contents
  • Numeric Values
  • Boolean
  • Character Data
  • Character Strings
  • Block Data


Numeric Values

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Introduction > SCPI Parameters > Numeric Values
Numeric Values

Numeric values can be entered in any form, i.e. with sign, decimal point or exponent. In case of physical quantities, you can also add the unit. If the unit is missing, the command uses the basic unit.

Example:

with unit: SENSe:FREQuency:CENTer 1GHZ

without unit: SENSe:FREQuency:CENTer 1E9 would also set a frequency of 1 GHz.

Values exceeding the resolution of the instrument are rounded up or down.

If the number you have entered is not supported (e.g. in case of discrete steps), the command returns an error.

Instead of a number, you can also set numeric values with a text parameter in special cases.

  • MIN/MAX
    Defines the minimum or maximum numeric value that is supported.
  • DEF
    Defines the default value.
  • UP/DOWN
    Increases or decreases the numeric value by one step. The step size depends on the setting. In some cases you can customize the step size with a corresponding command.
Querying numeric values

When you query numeric values, the system returns a number. In case of physical quantities, it applies the basic unit (e.g. Hz in case of frequencies). The number of digits after the decimal point depends on the type of numeric value.

Example:

Setting: SENSe:FREQuency:CENTer 1GHZ

Query: SENSe:FREQuency:CENTer? would return 1E9

In some cases, numeric values may be returned as text.

  • INF/NINF
    Infinity or negative infinity. Represents the numeric values 9.9E37 or -9.9E37.
  • NAN
    Not a number. Represents the numeric value 9.91E37. NAN is returned in case of errors.


Boolean

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Introduction > SCPI Parameters > Boolean
Boolean

Boolean parameters represent two states. The "ON" state (logically true) is represented by "ON" or a numeric value 1. The "OFF" state (logically untrue) is represented by "OFF" or the numeric value 0.

Querying boolean parameters

When you query boolean parameters, the system returns either the value 1 ("ON") or the value 0 ("OFF").

Example:

Setting: DISPlay:WINDow:ZOOM:STATe ON

Query: DISPlay:WINDow:ZOOM:STATe? would return 1


Character Data

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Introduction > SCPI Parameters > Character Data
Character Data

Character data follows the syntactic rules of keywords. You can enter text using a short or a long form. For more information see "Long and Short Form".

Querying text parameters

When you query text parameters, the system returns its short form.

Example:

Setting: SENSe:BANDwidth:RESolution:TYPE NORMal

Query: SENSe:BANDwidth:RESolution:TYPE? would return NORM


Character Strings

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Introduction > SCPI Parameters > Character Strings
Character Strings

Strings are alphanumeric characters. They have to be in straight quotation marks. You can use a single quotation mark ( ' ) or a double quotation mark ( " ).

Example:

INSTRument:DELete 'Spectrum'


Block Data

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Introduction > SCPI Parameters > Block Data
Block Data

Block data is a format which is suitable for the transmission of large amounts of data.

The ASCII character # introduces the data block. The next number indicates how many of the following digits describe the length of the data block. In the example the 4 following digits indicate the length to be 5168 bytes. The data bytes follow. During the transmission of these data bytes all end or other control signs are ignored until all bytes are transmitted. #0 specifies a data block of indefinite length. The use of the indefinite format requires a NL^END message to terminate the data block. This format is useful when the length of the transmission is not known or if speed or other considerations prevent segmentation of the data into blocks of definite length.


Common Suffixes

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Common Suffixes
Common Suffixes

The following common suffixes are used in remote commands specific to MSRA mode:

Suffix | Value range | Description
<m> | 1..16 | Marker
<n> | 1..6 | Window
<t> | 1..6 | Trace


Activating MSRA Measurements

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Activating MSRA Measurements
Activating MSRA Measurements

MSRA measurements requires a special operating mode on the R&S FSW. A measurement is started immediately with the default settings.

The special MSRA Master measurement channel is of the channel type "IQ" and is referred to by the channel name "MSRA Master". This channel cannot be replaced, deleted, or renamed.

List of Commands
INSTrument:CREate:DUPLicate
INSTrument:CREate[:NEW]
INSTrument:CREate:REPLace
INSTrument:DELete
INSTrument:LIST?
INSTrument:MODE
INSTrument:REName
INSTrument[:SELect]
SYSTem:PRESet:COMPatible
SYSTem:PRESet:CHANnel[:EXECute]


INSTrument:CREate:DUPLicate

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Activating MSRA Measurements > INSTrument:CREate:DUPLicate
INSTrument:CREate:DUPLicate

This command duplicates the currently selected measurement channel, i.e starts a new measurement channel of the same type and with the identical measurement settings. The name of the new channel is the same as the copied channel, extended by a consecutive number (e.g. "Spectrum" -> "Spectrum 2").

The channel to be duplicated must be selected first using the INST:SEL command.

(See INSTrument[:​SELect]).

This command is not available if the MSRA Master channel is selected.

Example: | INST:SEL 'Spectrum' INST:CRE:DUPL Duplicates the channel named 'Spectrum' and creates a new measurement channel named 'Spectrum 2'.
Usage: | Event


INSTrument:CREate[:NEW]

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Activating MSRA Measurements > INSTrument:CREate[:NEW]
INSTrument:CREate[:NEW] <ChannelType>, <ChannelName>

This command adds an additional measurement channel. The number of measurement channels you can configure at the same time depends on available memory.

Parameters:
<ChannelType>

Channel type of the new channel.

For a list of available channel types see INSTrument:​LIST?.

<ChannelName>

String containing the name of the channel. The channel name is displayed as the tab label for the measurement channel.

Note: If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel (see INSTrument:​LIST?).

Example: INST:CRE SAN, 'Spectrum 2'

Adds an additional spectrum display named "Spectrum 2".

Example:

See "I/Q Analysis with Graphical Evaluation" .

Example:

See "Programming Example: Performing a Sequence of Measurements" .

Manual operation: See "New Channel"


INSTrument:CREate:REPLace

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Activating MSRA Measurements > INSTrument:CREate:REPLace
INSTrument:CREate:REPLace <ChannelName1>,<ChannelType>,<ChannelName2>

This command replaces a measurement channel with another one.

Parameters:
<ChannelName1> | String containing the name of the measurement channel you want to replace.
<ChannelType> | Channel type of the new channel. For a list of available channel types see INSTrument:​LIST?.
<ChannelName2> | String containing the name of the new channel. Note: If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel (see INSTrument:​LIST?).
Example: | INST:CRE:REPL 'Spectrum2',IQ,'IQAnalyzer' Replaces the channel named 'Spectrum2' by a new measurement channel of type 'IQ Analyzer' named 'IQAnalyzer'.
Manual operation: | See "Replace Current Channel"


INSTrument:DELete

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Activating MSRA Measurements > INSTrument:DELete
INSTrument:DELete <ChannelName>

This command deletes a measurement channel. If you delete the last measurement channel, the default "Spectrum" channel is activated.

Parameters:
<ChannelName> | String containing the name of the channel you want to delete. A measurement channel must exist in order to be able delete it.
Example: | INST:DEL 'Spectrum4' Deletes the spectrum channel with the name 'Spectrum4'.


INSTrument:LIST?

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Activating MSRA Measurements > INSTrument:LIST?
INSTrument:LIST?

This command queries all active measurement channels. This is useful in order to obtain the names of the existing measurement channels, which are required in order to replace or delete the channels.

Return values:
<ChannelType>, <ChannelName> | For each channel, the command returns the channel type and channel name (see tables below). Tip: to change the channel name, use the INSTrument:​REName command.
Example: | INST:LIST? Result for 3 measurement channels: 'ADEM','Analog Demod','IQ','IQ Analyzer','SANALYZER','Spectrum'
Usage: | Query only
Available measurement channel types and default channel names in MSRA mode
Application | <ChannelType> Parameter | Default Channel Name*)
I/Q Analyzer | IQ | IQ Analyzer
Analog Demodulation (R&S FSW-K7) | ADEM | Analog Demod
GSM (R&S FSW-K10) | GSM | GSM
VSA (R&S FSW-K70) | DDEM | VSA
3GPP FDD BTS (R&S FSW-K72) | BWCD | 3G FDD BTS
TD-SCDMA BTS (R&S FSW-K76) | BTDS | TD-SCDMA BTS
cdma2000 BTS (R&S FSW-K82) | BC2K | CDMA2000 BTS
1xEV-DO BTS (R&S FSW-K84) | BDO | 1xEV-DO BTS
LTE (R&S FSW-K10x) | LTE | LTE
Note: the default channel name is also listed in the table. If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel.


INSTrument:MODE

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Activating MSRA Measurements > INSTrument:MODE
INSTrument:MODE <OpMode>

The operating mode of the R&S FSW determines which applications are available and active. Whenever you change the operating mode, the currently active measurement channels are stored. The default operating mode is Signal and Spectrum Analyzer mode, however, the presetting can be changed.

Parameters:
<OpMode>
SANalyzer

Signal and Spectrum Analyzer mode

MSRanalyzer

Multi-Standard Radio Analysis (MSRA) mode

RTMStandard

Multi-Standard Realtime (MSRT) mode

Only available if the realtime option (R&S FSW-K160R) is installed.

*RST: SAN
Example: INST:MODE MSR

Switches to MSRA mode.

Example:

See "Programming Example: Analyzing MSR Signals".

Usage: SCPI confirmed


INSTrument:REName

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Activating MSRA Measurements > INSTrument:REName
INSTrument:REName <ChannelName1>, <ChannelName2>

This command renames a measurement channel.

Parameters:
<ChannelName1> | String containing the name of the channel you want to rename.
<ChannelName2> | String containing the new channel name. Note that you can not assign an existing channel name to a new channel; this will cause an error.
Example: | INST:REN 'Spectrum2','Spectrum3' Renames the channel with the name 'Spectrum2' to 'Spectrum3'.


INSTrument[:SELect]

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Activating MSRA Measurements > INSTrument[:SELect]
INSTrument[:SELect] <ChannelType> | <ChannelName>

This command activates a new measurement channel with the defined channel type, or selects an existing measurement channel with the specified name.

Also see

  • INSTrument:​CREate[:​NEW]
  • "Programming Example: Performing a Sequence of Measurements"
Parameters:
<ChannelType>

Channel type of the new channel.

For a list of available channel types see INSTrument:​LIST?.

<ChannelName>

String containing the name of the channel.

Example: INST SAN

Activates a measurement channel for the Spectrum application.

INST 'MySpectrum'

Selects the measurement channel named 'MySpectrum' (for example before executing further commands for that channel).

Example:

See "Programming Example: Performing a Sequence of Measurements" .

Example:

See "Programming Example: Analyzing MSR Signals".

Usage: SCPI confirmed
Manual operation: See "I/Q Analyzer"
See "Analog Demodulation"
See "Pulse Measurements"
See "GSM"
See "Transient Analysis"
See "Vector Signal Analysis (VSA)"
See "3G FDD BTS"
See "TD-SCDMA BTS"
See "cdma2000 BTS"
See "1xEV-DO BTS"
See "LTE DL"
See "New Channel"


SYSTem:PRESet:COMPatible

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Activating MSRA Measurements > SYSTem:PRESet:COMPatible
SYSTem:PRESet:COMPatible <OpMode>

This command defines the operating mode that is activated when you switch on the R&S FSW or press the PRESET key.

For details on operating modes see "Applications and Operating Modes".

Parameters:
<OpMode>
SANalyzer

(Default:) Defines Signal and Spectrum Analyzer operating mode as the presetting.

MSRA

Defines Multi-Standard Radio Analysis (MSRA) as the preset default operating mode.

RTSM

Defines Multi-Standard Realtime (MSRT) as the preset default operating mode.

*RST: SAN
Usage: Event


SYSTem:PRESet:CHANnel[:EXECute]

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Activating MSRA Measurements > SYSTem:PRESet:CHANnel[:EXECute]
SYSTem:PRESet:CHANnel[:EXECute]

This command restores the default instrument settings in the current channel.

Use INST:SEL to select the channel.

For details see "Factory Default Configuration" .

Example: | INST 'Spectrum2' Selects the channel for "Spectrum2". SYST:PRES:CHAN:EXEC Restores the factory default settings to the "Spectrum2" channel.
Usage: | Event
Manual operation: | See "Preset Channel"


Configuring MSRA Measurements

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements
Configuring MSRA Measurements
Contents
  • Configuring Input/Output and Frontend Settings
  • Triggering
  • Configuring Data Acquisition
  • Adjusting Settings Automatically


Configuring Input/Output and Frontend Settings

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings
Configuring Input/Output and Frontend Settings

The following commands are required to define input, output and frontend settings. Any settings related to data acquisition or data output are only available for the MSRA Master.

Contents
  • RF Input
  • Configuring Digital I/Q Input and Output
  • Configuring Input via the Analog Baseband Interface (R&S FSW-B71)
  • Setting up Probes
  • Configuring the Vertical Axis (Amplitude, Scaling)
  • Frequency
  • Configuring the Outputs


RF Input

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > RF Input
RF Input
List of Commands
INPut:ATTenuation:PROTection:RESet
INPut:CONNector
INPut:COUPling
INPut:FILTer:HPASs[:STATe]
INPut:FILTer:YIG[:STATe]
INPut:IMPedance
INPut:SELect


INPut:ATTenuation:PROTection:RESet

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > RF Input > INPut:ATTenuation:PROTection:RESet
INPut:ATTenuation:PROTection:RESet

This command resets the attenuator and reconnects the RF input with the input mixer after an overload condition occured and the protection mechanism intervened.The error status bit (bit 3 in the STAT:QUES:POW status register) and the INPUT OVLD message in the status bar are cleared.

The command works only if the overload condition has been eliminated first.

Usage: Event


INPut:CONNector

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > RF Input > INPut:CONNector
INPut:CONNector <ConnType>

Determines whether the RF input data is taken from the RF input connector or the optional Analog Baseband I connector. This command is only available if the Analog Baseband interface (R&S FSW-B71) is installed and active for input.

For more information see "Processing Data From the Analog Baseband Interface" .

Parameters:
<ConnType>
RF

RF input connector

AIQI

Analog Baseband I connector

*RST: RF
Example: INP:CONN:AIQI

Selects the analog baseband input.

Usage: SCPI confirmed
Manual operation: See "Input Connector"


INPut:COUPling

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > RF Input > INPut:COUPling
INPut:COUPling <CouplingType>

This command selects the coupling type of the RF input.

Parameters:
<CouplingType>
AC

AC coupling

DC

DC coupling

*RST: AC
Example: INP:COUP DC
Usage: SCPI confirmed
Manual operation: See "Input Coupling"


INPut:FILTer:HPASs[:STATe]

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > RF Input > INPut:FILTer:HPASs[:STATe]
INPut:FILTer:HPASs[:STATe] <State>

Activates an additional internal high-pass filter for RF input signals from 1 GHz to 3 GHz. This filter is used to remove the harmonics of the R&S FSW in order to measure the harmonics for a DUT, for example.

This function requires option R&S FSW-B13.

(Note: for RF input signals outside the specified range, the high-pass filter has no effect. For signals with a frequency of approximately 4 GHz upwards, the harmonics are suppressed sufficiently by the YIG filter.)

Parameters:
<State>
ON | OFF
*RST: OFF
Usage: SCPI confirmed
Manual operation: See "High-Pass Filter 1...3 GHz"


INPut:FILTer:YIG[:STATe]

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > RF Input > INPut:FILTer:YIG[:STATe]
INPut:FILTer:YIG[:STATe] <State>

This command turns the YIG-preselector on and off.

Note the special conditions and restrictions for the YIG filter described in "YIG-Preselector".

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1 (0 for I/Q Analyzer, GSM, VSA and MC Group Delay measurements)
Example: INP:FILT:YIG OFF

Deactivates the YIG-preselector.

Manual operation: See "YIG-Preselector"


INPut:IMPedance

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > RF Input > INPut:IMPedance
INPut:IMPedance <Impedance>

This command selects the nominal input impedance of the RF input.

75 Ω should be selected if the 50 Ω input impedance is transformed to a higher impedance using a matching pad of the RAZ type (= 25 Ω in series to the input impedance of the instrument). The power loss correction value in this case is 1.76 dB = 10 log (75Ω/50Ω).

Parameters:
<Impedance>
50 | 75
*RST: 50 Ω
Example: INP:IMP 75
Usage: SCPI confirmed
Manual operation: See "Impedance"


INPut:SELect

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > RF Input > INPut:SELect
INPut:SELect <Source>

This command selects the signal source for measurements, i.e. it defines which connector is used to input data to the R&S FSW. If no additional options are installed, only RF input is supported.

Parameters:
<Source>
RF

Radio Frequency ("RF INPUT" connector)

*RST: RF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "Digital I/Q Input State"
See "Analog Baseband Input State"


Configuring Digital I/Q Input and Output

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring Digital I/Q Input and Output
Configuring Digital I/Q Input and Output
Useful commands for digital I/Q data described elsewhere:
  • INP:SEL DIQ (see INPut:​SELect)
  • TRIGger[:​SEQuence]:​LEVel:​BBPower
Remote commands for the R&S DigIConf software

Remote commands for the R&S DigIConf software always begin with SOURce:EBOX. Such commands are passed on from the R&S FSW to the R&S DigIConf automatically which then configures the R&S EX-IQ-BOX via the USB connection.

Be sure to connect the R&S EX-IQ-BOX to the R&S FSW via USB, not via LAN!

All remote commands available for configuration via the R&S DigIConf software are described in the "R&S®EX-IQ-BOX Digital Interface Module R&S®DigIConf Software Operating Manual".

Example 1:

SOURce:EBOX:*RST

SOURce:EBOX:*IDN?

Result:

"Rohde&Schwarz,DigIConf,02.05.436 Build 47"

Example 2:

SOURce:EBOX:USER:CLOCk:REFerence:FREQuency 5MHZ

Defines the frequency value of the reference clock.

Remote commands exclusive to digital I/Q data input and output
List of Commands
INPut:DIQ:CDEVice
INPut:DIQ:RANGe[:UPPer]:AUTO
INPut:DIQ:RANGe:COUPling
INPut:DIQ:RANGe[:UPPer]
INPut:DIQ:RANGe[:UPPer]:UNIT
INPut:DIQ:SRATe
INPut:DIQ:SRATe:AUTO


INPut:DIQ:CDEVice

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring Digital I/Q Input and Output > INPut:DIQ:CDEVice
INPut:DIQ:CDEVice

This command queries the current configuration and the status of the digital I/Q input from the optional Digital Baseband Interface (R&S FSW-B17).

For details see "Interface Status Information" .

Return values:
<ConnState>

Defines whether a device is connected or not.

0

No device is connected.

1

A device is connected.

<DeviceName>

Device ID of the connected device

<SerialNumber>

Serial number of the connected device

<PortName>

Port name used by the connected device

<SampleRate>

Maximum or currently used sample rate of the connected device in Hz (depends on the used connection protocol version; indicated by <SampleRateType> parameter)

<MaxTransferRate>

Maximum data transfer rate of the connected device in Hz

<ConnProtState>

State of the connection protocol which is used to identify the connected device.

Not Started
Has to be Started
Started
Passed
Failed
Done
<PRBSTestState>

State of the PRBS test.

Not Started
Has to be Started
Started
Passed
Failed
Done
<SampleRateType>
0

Maximum sample rate is displayed

1

Current sample rate is displayed

<FullScaleLevel>

The level (in dBm) that should correspond to an I/Q sample with the magnitude "1" (if transferred from connected device);

If not available, 9.97e37 is returned

Example: INP:DIQ:CDEV?

Result:

1,SMU200A,103634,Out A,70000000,100000000,Passed,Not Started,0,0
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Connected Instrument"


INPut:DIQ:RANGe[:UPPer]:AUTO

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe[:UPPer]:AUTO
INPut:DIQ:RANGe[:UPPer]:AUTO <State>

If enabled, the digital input full scale level is automatically set to the value provided by the connected device (if available).

This command is only available if the optional Digital Baseband interface (option R&S FSW-B17) is installed.

Parameters:
<State>
ON | OFF
*RST: OFF
Manual operation: See "Full Scale Level"


INPut:DIQ:RANGe:COUPling

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe:COUPling
INPut:DIQ:RANGe:COUPling <State>

If enabled, the reference level for digital input is adjusted to the full scale level automatically if the full scale level changes.

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Adjust Reference Level to Full Scale Level"


INPut:DIQ:RANGe[:UPPer]

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe[:UPPer]
INPut:DIQ:RANGe[:UPPer] <Level>

Defines or queries the "Full Scale Level", i.e. the level that corresponds to an I/Q sample with the magnitude "1".

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<Level>
<numeric value>
Range: | 1 μV to 7.071 V
*RST: | 1 V
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Full Scale Level"


INPut:DIQ:RANGe[:UPPer]:UNIT

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe[:UPPer]:UNIT
INPut:DIQ:RANGe[:UPPer]:UNIT <Unit>

Defines the unit of the full scale level (see "Full Scale Level"). The availability of units depends on the measurement application you are using.

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<Level>
VOLT | DBM | DBPW | WATT | DBMV | DBUV | DBUA | AMPere
*RST: Volt
Manual operation: See "Full Scale Level"


INPut:DIQ:SRATe

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring Digital I/Q Input and Output > INPut:DIQ:SRATe
INPut:DIQ:SRATe <SampleRate>

This command specifies or queries the sample rate of the input signal from the Digital Baseband Interface (R&S FSW-B17, see "Input Sample Rate").

Parameters:
<SampleRate>
Range: | 1 Hz to 10 GHz
*RST: | 32 MHz
Example:

INP:DIQ:SRAT 200 MHz

Manual operation: See "Input Sample Rate"


INPut:DIQ:SRATe:AUTO

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring Digital I/Q Input and Output > INPut:DIQ:SRATe:AUTO
INPut:DIQ:SRATe:AUTO <State>

If enabled, the sample rate of the digital I/Q input signal is set automatically by the connected device.

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Input Sample Rate"


Configuring Input via the Analog Baseband Interface (R&S FSW-B71)

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71)
Configuring Input via the Analog Baseband Interface (R&S FSW-B71)

The following commands are required to control the Analog Baseband Interface (R&S FSW-B71) in a remote environment.They are only available if this option is installed.

For more information on the Analog Baseband Interface see "Processing Data From the Analog Baseband Interface" .

Useful commands for Analog Baseband data described elsewhere:
  • INP:SEL AIQ (see INPut:​SELect)
  • [SENSe:​]FREQuency:​CENTer
For calibration:
  • DIAGnostic:​SERVice:​INPut[:​SELect]
  • DIAGnostic:​SERVice:​INPut:​AIQ[:​TYPE]
Remote commands exclusive to Analog Baseband data input and output
List of Commands
INPut:IQ:BALanced[:STATe]
INPut:IQ:FULLscale:AUTO
INPut:IQ:FULLscale[:LEVel]
INPut:IQ:TYPE
CALibration:AIQ:DCOFfset:I
CALibration:AIQ:DCOFfset:Q
[SENSe:]PROBe<ch>:SETup:CMOFfset
TRACe:IQ:APCon[:STATe]
TRACe:IQ:APCon:A
TRACe:IQ:APCon:B
TRACe:IQ:APCon:RESult?


INPut:IQ:BALanced[:STATe]

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:BALanced[:STATe]
INPut:IQ:BALanced[:STATe] <State>

This command defines whether the input is provided as a differential signal via all 4 Analog Baseband connectors or as a plain I/Q signal via 2 simple-ended lines.

Parameters:
<State>
ON

Differential

OFF

Simple-ended

*RST: ON
Example: INP:IQ:BAL OFF
Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "Input configuration"


INPut:IQ:FULLscale:AUTO

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:FULLscale:AUTO
INPut:IQ:FULLscale:AUTO <State>

This command defines whether the full scale level (i.e. the maximum input power on the Baseband Input connector) is defined automatically according to the reference level, or manually.

Parameters:
<State>
ON

Automatic definition

OFF

Manual definition according to INPut:​IQ:​FULLscale[:​LEVel]

*RST: ON
Example: INP:IQ:FULL:AUTO OFF
Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "Full Scale Level Mode / Value"


INPut:IQ:FULLscale[:LEVel]

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:FULLscale[:LEVel]
INPut:IQ:FULLscale[:LEVel] <PeakVoltage>

This command defines the peak voltage at the Baseband Input connector if the full scale level is set to manual mode (see INPut:​IQ:​FULLscale:​AUTO).

Parameters:
<PeakVoltage>
0.25 V | 0.5 V | 1 V | 2 V

Peak voltage level at the connector.

For probes, the possible full scale values are adapted according to the probe's attenuation and maximum allowed power.

*RST: 1V
Example: INP:IQ:FULL 0.5V
Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "Full Scale Level Mode / Value"


INPut:IQ:TYPE

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:TYPE
INPut:IQ:TYPE <DataType>

This command defines the format of the input signal.

Parameters:
<DataType>
IQ | I | Q
IQ

The input signal is filtered and resampled to the sample rate of the application.

Two input channels are required for each input signal, one for the in-phase component, and one for the quadrature component.

I

The in-phase component of the input signal is filtered and resampled to the sample rate of the application. If the center frequency is not 0 (see [SENSe:​]FREQuency:​CENTer), the in-phase component of the input signal is down-converted first (Low IF I).

Q

The quadrature component of the input signal is filtered and resampled to the sample rate of the application. If the center frequency is not 0, the quadrature component of the input signal is down-converted first (Low IF Q).

*RST: IQ
Example:

INP:IQ:TYPE Q

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "I/Q Mode"


CALibration:AIQ:DCOFfset:I

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > CALibration:AIQ:DCOFfset:I
CALibration:AIQ:DCOFfset:I <Offset>

This command defines a DC offset of the I input from the Analog Baseband interface (R&S FSW-B71).

Parameters:
<Offset>
numeric value

DC offset

*RST: | 0
Default unit: | V
Example: CAL:AIQ:DCOF:I 0.001


CALibration:AIQ:DCOFfset:Q

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > CALibration:AIQ:DCOFfset:Q
CALibration:AIQ:DCOFfset:Q <Offset>

This command defines a DC offset of the Q input from the Analog Baseband interface (R&S FSW-B71).

Parameters:
<Offset>
numeric value

DC offset

*RST: | 0
Default unit: | V
Example: CAL:AIQ:DCOF:Q 0.001


[SENSe:]PROBe<ch>:SETup:CMOFfset

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > [SENSe:]PROBe<ch>:SETup:CMOFfset
[SENSe:]PROBe<ch>:SETup:CMOFfset <CMOffset>

Sets the common mode offset. The setting is only available if a differential probe is connected to the R&S FSW.

If the probe is disconnected, the common mode offset of the probe is reset to 0.0 V.

For details see "Common Mode Offset" .

Suffix:
<ch>
1..4

Selects the input channel.

Parameters:
<CMOffset>
Range: | -100E+24 to 100E+24
Increment: | 1E-3
*RST: | 0
Default unit: | V


TRACe:IQ:APCon[:STATe]

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon[:STATe]
TRACe:IQ:APCon[:STATe] <State>

If enabled, the average power consumption is calculated at the end of the I/Q data measurement. This command must be set before the measurement is performed!

The conversion factors A and B for the calculation are defined using TRACe:​IQ:​APCon:​A and TRACe:​IQ:​APCon:​B.

The results can be queried using TRACe:​IQ:​APCon:​RESult?.

For details see "Average Power Consumption" .

Parameters:
<State>
ON | OFF
*RST: OFF
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?


TRACe:IQ:APCon:A

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon:A
TRACe:IQ:APCon:A <ConvFact>

Defines the conversion factor A for the calculation of the average power consumption.

For details see "Average Power Consumption" .

Parameters:
<ConvFact>
numeric value
*RST: 1.0
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?


TRACe:IQ:APCon:B

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon:B
TRACe:IQ:APCon:B <ConvFact>

Defines the conversion factor B for the calculation of the average power consumption.

For details see "Average Power Consumption" .

Parameters:
<ConvFact>
numeric value
*RST: 0.0
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?


TRACe:IQ:APCon:RESult?

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon:RESult?
TRACe:IQ:APCon:RESult?

Queries the average power consumption for an analog baseband input. This value is only calculated at the end of the I/Q data measurement if the TRACe:​IQ:​APCon[:​STATe] command is set to ON before the measurement is performed!

For details see "Average Power Consumption" .

Parameters:
<Average>
numeric value
Default unit: W
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?
Usage: Query only


Setting up Probes

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Setting up Probes
Setting up Probes

Probes can be connected to the optional BASEBAND INPUT connectors, if the Analog Baseband interface ( option R&S FSW-B71) is installed.

List of Commands
[SENSe:]PROBe<p>:ID:PARTnumber?
[SENSe:]PROBe<p>:ID:SRNumber?
[SENSe:]PROBe<p>:SETup:MODE
[SENSe:]PROBe<p>:SETup:NAME?
[SENSe:]PROBe<p>:SETup:STATe?
[SENSe:]PROBe<p>:SETup:TYPE?


[SENSe:]PROBe<p>:ID:PARTnumber?

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Setting up Probes > [SENSe:]PROBe<p>:ID:PARTnumber?
[SENSe:]PROBe<p>:ID:PARTnumber?

Queries the R&S part number of the probe.

Suffix: |
<p> | 1 | 2 | 3 Selects the connector: 1 = Baseband Input I 2 = Baseband Input Q 3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")
Return values:
<PartNumber> | Part number in a string.
Usage: | Query only


[SENSe:]PROBe<p>:ID:SRNumber?

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Setting up Probes > [SENSe:]PROBe<p>:ID:SRNumber?
[SENSe:]PROBe<p>:ID:SRNumber?

Queries the serial number of the probe.

Suffix: |
<p> | 1 | 2 | 3 Selects the connector: 1 = Baseband Input I 2 = Baseband Input Q 3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")
Return values:
<SerialNo> | Serial number in a string.
Usage: | Query only


[SENSe:]PROBe<p>:SETup:MODE

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Setting up Probes > [SENSe:]PROBe<p>:SETup:MODE
[SENSe:]PROBe<p>:SETup:MODE <Mode>

Select the action that is started with the micro button on the probe head.

See also: "Microbutton Action".

Suffix:
<p>
1 | 2 | 3

Selects the connector:

1 = Baseband Input I

2 = Baseband Input Q

3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")

Parameters:
<Mode>
RSINgle

Run single: starts one data acquisition.

NOACtion

Nothing is started on pressing the micro button.

*RST: RSINgle
Manual operation: See "Microbutton Action"


[SENSe:]PROBe<p>:SETup:NAME?

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Setting up Probes > [SENSe:]PROBe<p>:SETup:NAME?
[SENSe:]PROBe<p>:SETup:NAME?

Queries the name of the probe.

Suffix: |
<p> | 1 | 2 | 3 Selects the connector: 1 = Baseband Input I 2 = Baseband Input Q 3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")
Return values:
<Name> | Name string
Usage: | Query only


[SENSe:]PROBe<p>:SETup:STATe?

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Setting up Probes > [SENSe:]PROBe<p>:SETup:STATe?
[SENSe:]PROBe<p>:SETup:STATe?

Queries if the probe at the specified connector is active (detected) or not active (not detected). To switch the probe on, i.e. activate input from the connector, use INP:SEL:AIQ (see INPut:​SELect).

Suffix:
<p>
1 | 2 | 3

Selects the connector:

1 = Baseband Input I

2 = Baseband Input Q

3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")

Return values:
<State>
DETected | NDETected
*RST: NDETected
Usage: Query only


[SENSe:]PROBe<p>:SETup:TYPE?

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Setting up Probes > [SENSe:]PROBe<p>:SETup:TYPE?
[SENSe:]PROBe<p>:SETup:TYPE?

Queries the type of the probe.

Suffix: |
<p> | 1 | 2 | 3 Selects the connector: 1 = Baseband Input I 2 = Baseband Input Q 3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")
Return values:
<Type> | String containing one of the following values: – None (no probe detected) – active differential – active single-ended
Usage: | Query only


Configuring the Vertical Axis (Amplitude, Scaling)

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring the Vertical Axis (Amplitude, Scaling)
Configuring the Vertical Axis (Amplitude, Scaling)

The following commands are required to configure the amplitude and vertical axis settings in a remote environment.

Contents
  • Amplitude Settings
  • Configuring the Attenuation
  • Configuring a Preamplifier
  • Scaling the Y-Axis


Amplitude Settings

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring the Vertical Axis (Amplitude, Scaling) > Amplitude Settings
Amplitude Settings
Useful commands for amplitude configuration described elsewhere:
  • [SENSe:​]ADJust:​LEVel
Remote commands exclusive to amplitude configuration:
List of Commands
CALCulate<n>:MARKer<m>:FUNCtion:REFerence
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet


CALCulate<n>:MARKer<m>:FUNCtion:REFerence

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring the Vertical Axis (Amplitude, Scaling) > Amplitude Settings > CALCulate<n>:MARKer<m>:FUNCtion:REFerence
CALCulate<n>:MARKer<m>:FUNCtion:REFerence

This command matches the reference level to the power level of a marker.

If you use the command in combination with a delta marker, that delta marker is turned into a normal marker.

Example: | CALC:MARK2:FUNC:REF Sets the reference level to the level of marker 2.
Usage: | Event


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring the Vertical Axis (Amplitude, Scaling) > Amplitude Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel <ReferenceLevel>

This command defines the reference level.

Example: DISP:TRAC:Y:RLEV -60dBm
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Reference Level"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring the Vertical Axis (Amplitude, Scaling) > Amplitude Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet <Offset>

This command defines a reference level offset.

Parameters:
<Offset>
Range: | -200 dB to 200 dB
*RST: | 0dB
Example: DISP:TRAC:Y:RLEV:OFFS -10dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Shifting the Display (Offset)"


Configuring the Attenuation

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring the Attenuation
Configuring the Attenuation
List of Commands
INPut:ATTenuation
INPut:ATTenuation:AUTO
INPut:EATT
INPut:EATT:AUTO
INPut:EATT:STATe


INPut:ATTenuation

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring the Attenuation > INPut:ATTenuation
INPut:ATTenuation <Attenuation>

This command defines the total attenuation for RF input.

If you set the attenuation manually, it is no longer coupled to the reference level, but the reference level is coupled to the attenuation. Thus, if the current reference level is not compatible with an attenuation that has been set manually, the command also adjusts the reference level.

Parameters:
<Attenuation>
Range: | see data sheet
Increment: | 5 dB
*RST: | 10 dB (AUTO is set to ON)
Example: INP:ATT 30dB

Defines a 30 dB attenuation and decouples the attenuation from the reference level.

Usage: SCPI confirmed
Manual operation: See "Attenuation Mode / Value"


INPut:ATTenuation:AUTO

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring the Attenuation > INPut:ATTenuation:AUTO
INPut:ATTenuation:AUTO <State>

This command couples or decouples the attenuation to the reference level. Thus, when the reference level is changed, the R&S FSW determines the signal level for optimal internal data processing and sets the required attenuation accordingly.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: INP:ATT:AUTO ON

Couples the attenuation to the reference level.

Usage: SCPI confirmed
Manual operation: See "Attenuation Mode / Value"


INPut:EATT

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring the Attenuation > INPut:EATT
INPut:EATT <Attenuation>

This command defines an electronic attenuation manually. Automatic mode must be switched off (INP:EATT:AUTO OFF, see INPut:​EATT:​AUTO).

If the current reference level is not compatible with an attenuation that has been set manually, the command also adjusts the reference level.

Parameters:
<Attenuation>
attenuation in dB
Range: | see data sheet
Increment: | 1 dB
*RST: | 0 dB (OFF)
Example: INP:EATT:AUTO OFF
INP:EATT 10 dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Using Electronic Attenuation (Option B25)"


INPut:EATT:AUTO

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring the Attenuation > INPut:EATT:AUTO
INPut:EATT:AUTO <State>

This command turns automatic selection of the electronic attenuation on and off.

If on, electronic attenuation reduces the mechanical attenuation whenever possible.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: INP:EATT:AUTO OFF
Manual operation: See "Using Electronic Attenuation (Option B25)"


INPut:EATT:STATe

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring the Attenuation > INPut:EATT:STATe
INPut:EATT:STATe <State>

This command turns the electronic attenuator on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: INP:EATT:STAT ON

Switches the electronic attenuator into the signal path.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Using Electronic Attenuation (Option B25)"


Configuring a Preamplifier

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring a Preamplifier
Configuring a Preamplifier
List of Commands
INPut:GAIN:STATe
INPut:GAIN[:VALue]


INPut:GAIN:STATe

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring a Preamplifier > INPut:GAIN:STATe
INPut:GAIN:STATe <State>

This command turns the preamplifier on and off.

The command requires option R&S FSW-B24.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: INP:GAIN:STAT ON

Switches on 30 dB preamplification.

Usage: SCPI confirmed
Manual operation: See "Preamplifier (option B24)"


INPut:GAIN[:VALue]

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring a Preamplifier > INPut:GAIN[:VALue]
INPut:GAIN[:VALue] <Gain>

This command selects the preamplification level if the preamplifier is activated (INP:GAIN:STAT ON, see INPut:​GAIN:​STATe).

The command requires option R&S FSW-B24.

Parameters:
<Gain>
15 dB | 30 dB

The availability of preamplification levels depends on the R&S FSW model.

R&S FSW8/13: 15dB and 30 dB

R&S FSW26 or higher: 30 dB

All other values are rounded to the nearest of these two.

*RST: OFF
Example: INP:GAIN:VAL 30

Switches on 30 dB preamplification.

Usage: SCPI confirmed
Manual operation: See "Preamplifier (option B24)"


Scaling the Y-Axis

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis
Scaling the Y-Axis
List of Commands
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MODE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition
DISPlay[:WINDow<n>]:TRACe:Y:SPACing


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe] <Range>

This command defines the display range of the y-axis.

Example: DISP:TRAC:Y 110dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE

Automatic scaling of the y-axis is performed once, then switched off again.

Usage: SCPI confirmed


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MODE

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MODE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MODE <Mode>

This command selects the type of scaling of the y-axis.

When the display update during remote control is off, this command has no immediate effect.

Parameters:
<Mode>
ABSolute

absolute scaling of the y-axis

RELative

relative scaling of the y-axis

*RST: ABSolute
Example: DISP:TRAC:Y:MODE REL


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition <Position>

This command defines the vertical position of the reference level on the display grid.

The R&S FSW adjusts the scaling of the y-axis accordingly.

Example:

DISP:TRAC:Y:RPOS 50PCT

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed


DISPlay[:WINDow<n>]:TRACe:Y:SPACing

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis > DISPlay[:WINDow<n>]:TRACe:Y:SPACing
DISPlay[:WINDow<n>]:TRACe:Y:SPACing <ScalingType>

This command selects the scaling of the y-axis.

Parameters:
<ScalingType>
LOGarithmic

Logarithmic scaling.

LINear

Linear scaling in %.

LDB

Linear scaling in the specified unit.

PERCent

Linear scaling in %.

*RST: LOGarithmic
Example: DISP:TRAC:Y:SPAC LIN

Selects linear scaling in %.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed


Frequency

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Frequency
Frequency
List of Commands
[SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP:AUTO
[SENSe:]FREQuency:OFFSet


[SENSe:]FREQuency:CENTer

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Frequency > [SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer <Frequency>

This command defines the center frequency.

Parameters:
<Frequency>

The allowed range and fmax is specified in the data sheet.

UP

Increases the center frequency by the step defined using the [SENSe:​]FREQuency:​CENTer:​STEP command.

DOWN

Decreases the center frequency by the step defined using the [SENSe:​]FREQuency:​CENTer:​STEP command.

*RST: | fmax/2
Default unit: | Hz
Example: FREQ:CENT 100 MHz
FREQ:CENT:STEP 10 MHz
FREQ:CENT UP

Sets the center frequency to 110 MHz.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Center Frequency"
See "Center frequency"


[SENSe:]FREQuency:CENTer:STEP

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Frequency > [SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP <StepSize>

This command defines the center frequency step size.

You can increase or decrease the center frequency quickly in fixed steps using the SENS:FREQ UP AND SENS:FREQ DOWN commands, see [SENSe:​]FREQuency:​CENTer.

Parameters:
<StepSize>

fmax is specified in the data sheet.

Range: | 1 to fMAX
*RST: | 0.1 x span
Default unit: | Hz
Example: FREQ:CENT 100 MHz
FREQ:CENT:STEP 10 MHz
FREQ:CENT UP

Sets the center frequency to 110 MHz.

Manual operation: See "Center Frequency Stepsize"


[SENSe:]FREQuency:CENTer:STEP:AUTO

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Frequency > [SENSe:]FREQuency:CENTer:STEP:AUTO
[SENSe:]FREQuency:CENTer:STEP:AUTO <State>

This command couples or decouples the center frequency step size to the span.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: FREQ:CENT:STEP:AUTO ON

Activates the coupling of the step size to the span.


[SENSe:]FREQuency:OFFSet

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Frequency > [SENSe:]FREQuency:OFFSet
[SENSe:]FREQuency:OFFSet <Offset>

This command defines a frequency offset.

If this value is not 0 Hz, the application assumes that the input signal was frequency shifted outside the application. All results of type "frequency" will be corrected for this shift numerically by the application.

See also "Frequency Offset".

Note: In MSRA mode, the setting command is only available for the MSRA Master. For MSRA applications, only the query command is available.

Parameters:
<Offset>
Range: | -100 GHz to 100 GHz
*RST: | 0 Hz
Example: FREQ:OFFS 1GHZ
Usage: SCPI confirmed
Manual operation: See "Frequency Offset"


Configuring the Outputs

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring the Outputs
Configuring the Outputs

Configuring trigger input/output is described in "Configuring the Trigger Output".

List of Commands
DIAGnostic:SERVice:NSOurce
OUTPut:IF:IFFRequency


DIAGnostic:SERVice:NSOurce

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring the Outputs > DIAGnostic:SERVice:NSOurce
DIAGnostic:SERVice:NSOurce <State>

This command turns the 28 V supply of the BNC connector labeled NOISE SOURCE CONTROL on the front panel on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: DIAG:SERV:NSO ON
Manual operation: See "Noise Source"


OUTPut:IF:IFFRequency

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Input/Output and Frontend Settings > Configuring the Outputs > OUTPut:IF:IFFRequency
OUTPut:IF:IFFRequency <Frequency>

This command defines the frequency for the IF output. The IF frequency of the signal is converted accordingly.

This command is available in the time domain and if the IF/VIDEO/DEMOD output is configured for IF.

Parameters:
<Frequency>
*RST: 50.0 MHz


Triggering

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Triggering
Triggering

The following remote commands are required to configure a triggered measurement in a remote environment. These commands are only available for the MSRA Master channel. More details are described for manual operation in "Trigger Settings".

*OPC should be used after requesting data. This will hold off any subsequent changes to the selected trigger source, until after the sweep is completed and the data is returned.

Contents
  • Configuring the Triggering Conditions
  • Configuring the Trigger Output


Configuring the Triggering Conditions

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Triggering > Configuring the Triggering Conditions
Configuring the Triggering Conditions
List of Commands
TRIGger[:SEQuence]:BBPower:HOLDoff
TRIGger[:SEQuence]:DTIMe
TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:LEVel:BBPower
TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:LEVel:IFPower
TRIGger[:SEQuence]:LEVel:IQPower
TRIGger[:SEQuence]:LEVel:RFPower
TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SOURce
TRIGger[:SEQuence]:TIME:RINTerval


TRIGger[:SEQuence]:BBPower:HOLDoff

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:BBPower:HOLDoff
TRIGger[:SEQuence]:BBPower:HOLDoff <Period>

This command defines the holding time before the baseband power trigger event.

The command requires the Digital Baseband Interface (R&S FSW-B17) or the Analog Baseband Interface (R&S FSW-B71).

Note that this command is maintained for compatibility reasons only. Use the TRIGger[:​SEQuence]:​IFPower:​HOLDoff command for new remote control programs.

Parameters:
<Period>
Range: | 150 ns to 1000 s
*RST: | 150 ns
Example: TRIG:SOUR BBP

Sets the baseband power trigger source.

TRIG:BBP:HOLD 200 ns

Sets the holding time to 200 ns.


TRIGger[:SEQuence]:DTIMe

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:DTIMe
TRIGger[:SEQuence]:DTIMe <DropoutTime>

Defines the time the input signal must stay below the trigger level before a trigger is detected again.

For input from the Analog Baseband Interface (R&S FSW-B71) using the baseband power trigger (BBP), the default drop out time is set to 100 ns to avoid unintentional trigger events (as no hysteresis can be configured in this case).

Parameters:
<DropoutTime>

Dropout time of the trigger.

Range: | 0 s to 10.0 s
*RST: | 0 s
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Drop-Out Time"


TRIGger[:SEQuence]:HOLDoff[:TIME]

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:HOLDoff[:TIME] <Offset>

Defines the time offset between the trigger event and the start of the sweep (data capturing).

Parameters:
<Offset>
*RST: 0 s
Example: TRIG:HOLD 500us
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger Offset"


TRIGger[:SEQuence]:IFPower:HOLDoff

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HOLDoff <Period>

This command defines the holding time before the next trigger event.

Note that this command can be used for any trigger source, not just IF Power (despite the legacy keyword).

Parameters:
<Period>
Range: | 0 s to 10 s
*RST: | 0 s
Example: TRIG:SOUR EXT

Sets an external trigger source.

TRIG:IFP:HOLD 200 ns

Sets the holding time to 200 ns.

Manual operation: See "Trigger Holdoff"


TRIGger[:SEQuence]:IFPower:HYSTeresis

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:IFPower:HYSTeresis <Hysteresis>

This command defines the trigger hysteresis, which is only available for "IF Power" trigger sources.

Parameters:
<Hysteresis>
Range: | 3 dB to 50 dB
*RST: | 3 dB
Example: TRIG:SOUR IFP

Sets the IF power trigger source.

TRIG:IFP:HYST 10DB

Sets the hysteresis limit value.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Hysteresis"


TRIGger[:SEQuence]:LEVel:BBPower

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:BBPower
TRIGger[:SEQuence]:LEVel:BBPower <Level>

This command sets the level of the baseband power trigger.

This command is available for the Digital Baseband Interface (R&S FSW-B17) and the Analog Baseband Interface (R&S FSW-B71).

Parameters:
<Level>
Range: | -50 dBm to +20 dBm
*RST: | -20 dBm
Example: TRIG:LEV:BB -30DBM
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .


TRIGger[:SEQuence]:LEVel[:EXTernal<port>]

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:LEVel[:EXTernal<port>] <TriggerLevel>

This command defines the level the external signal must exceed to cause a trigger event.

Suffix:
<port>

Selects the trigger port.

1 = trigger port 1 (TRIGGER INPUT connector on front panel)

2 = trigger port 2 (TRIGGER INPUT/OUTPUT connector on front panel)

3 = trigger port 3 (TRIGGER3 INPUT/OUTPUT connector on rear panel)

Parameters:
<TriggerLevel>
Range: | 0.5 V to 3.5 V
*RST: | 1.4 V
Example: TRIG:LEV 2V
Manual operation: See "Trigger Level (Repetition interval)"


TRIGger[:SEQuence]:LEVel:IFPower

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:IFPower
TRIGger[:SEQuence]:LEVel:IFPower <TriggerLevel>

This command defines the power level at the third intermediate frequency that must be exceeded to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed. If defined, a reference level offset is also considered.

Parameters:
<TriggerLevel>

For details on available trigger levels and trigger bandwidths see the data sheet.

*RST: -10 dBm
Example: TRIG:LEV:IFP -30DBM
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .


TRIGger[:SEQuence]:LEVel:IQPower

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:IQPower
TRIGger[:SEQuence]:LEVel:IQPower <TriggerLevel>

This command defines the magnitude the I/Q data must exceed to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed.

Parameters:
<TriggerLevel>
Range: | -130 dBm to 30 dBm
*RST: | -20 dBm
Example: TRIG:LEV:IQP -30DBM
Example:

See "Basic I/Q Analysis with Improved Performance" .


TRIGger[:SEQuence]:LEVel:RFPower

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:RFPower
TRIGger[:SEQuence]:LEVel:RFPower <TriggerLevel>

This command defines the power level the RF input must exceed to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed. If defined, a reference level offset is also considered.

The input signal must be between 500 MHz and 8 GHz.

Parameters:
<TriggerLevel>

For details on available trigger levels and trigger bandwidths see the data sheet.

*RST: -20 dBm
Example: TRIG:LEV:RFP -30dBm


TRIGger[:SEQuence]:SLOPe

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SLOPe <Type>

For external and time domain trigger sources you can define whether triggering occurs when the signal rises to the trigger level or falls down to it.

Parameters:
<Type>
POSitive | NEGative
POSitive

Triggers when the signal rises to the trigger level (rising edge).

NEGative

Triggers when the signal drops to the trigger level (falling edge).

*RST: POSitive
Example: TRIG:SLOP NEG
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Slope"


TRIGger[:SEQuence]:SOURce

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:SOURce
TRIGger[:SEQuence]:SOURce <Source>

This command selects the trigger source.

Note on external triggers:

If a measurement is configured to wait for an external trigger signal in a remote control program, remote control is blocked until the trigger is received and the program can continue. Make sure this situation is avoided in your remote control programs.

Parameters:
<Source>
IMMediate

Free Run

EXTernal

Trigger signal from the TRIGGER INPUT connector.

EXT2

Trigger signal from the TRIGGER INPUT/OUTPUT connector.

Note: Connector must be configured for "Input".

EXT3

Trigger signal from the TRIGGER 3 INPUT/ OUTPUT connector.

Note: Connector must be configured for "Input".

RFPower

First intermediate frequency

IFPower

Second intermediate frequency

IQPower

Magnitude of sampled I/Q data

For applications that process I/Q data, such as the I/Q Analyzer or optional applications.

BBPower

Baseband power (for digital input via the Digital Baseband Interface R&S FSW-B17)

Baseband power (for digital input via the Digital Baseband Interface R&S FSW-B17 or the Analog Baseband interface R&S FSW-B71)

PSEN

External power sensor

GP0 | GP1 | GP2 | GP3 | GP4 | GP5

For applications that process I/Q data, such as the I/Q Analyzer or optional applications, and only if the Digital Baseband Interface (R&S FSW-B17) is available.

Defines triggering of the measurement directly via the LVDS connector. The parameter specifies which general purpose bit (0 to 5) will provide the trigger data.

The assignment of the general purpose bits used by the Digital IQ trigger to the LVDS connector pins is provided in "Digital I/Q".

*RST: IMMediate
Example: TRIG:SOUR EXT

Selects the external trigger input as source of the trigger signal

Example:

See "Basic I/Q Analysis with Improved Performance" .

Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Example:

See "Programming Example" .

Manual operation: See "Trigger Source"
See "Free Run"
See "External Trigger 1/2/3"
See "Baseband Power"
See "Digital I/Q"
See "RF Power"
See "I/Q Power"
See "Power Sensor"


TRIGger[:SEQuence]:TIME:RINTerval

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:TIME:RINTerval
TRIGger[:SEQuence]:TIME:RINTerval <Interval>

This command defines the repetition interval for the time trigger.

Parameters:
<Interval>
2.0 ms to 5000
Range: | 2 ms to 5000 s
*RST: | 1.0 s
Example: TRIG:SOUR TIME

Selects the time trigger input for triggering.

TRIG:TIME:RINT 50

The sweep starts every 50 s.


Configuring the Trigger Output

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Triggering > Configuring the Trigger Output
Configuring the Trigger Output

The following commands are required to send the trigger signal to one of the variable TRIGGER INPUT/OUTPUT connectors. The tasks for manual operation are described in "Trigger 2/3".

List of Commands
OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:LENGth


OUTPut:TRIGger<port>:DIRection

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Triggering > Configuring the Trigger Output > OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:DIRection <Direction>

This command selects the trigger direction.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Direction>
INPut

Port works as an input.

OUTPut

Port works as an output.

*RST: INPut
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger 2/3"


OUTPut:TRIGger<port>:LEVel

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Triggering > Configuring the Trigger Output > OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:LEVel <Level>

This command defines the level of the signal generated at the trigger output.

This command works only if you have selected a user defined output with OUTPut:​TRIGger<port>:​OTYPe.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Level>
HIGH

TTL signal.

LOW

0 V

*RST: LOW
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger 2/3"
See "Level"


OUTPut:TRIGger<port>:OTYPe

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Triggering > Configuring the Trigger Output > OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:OTYPe <OutputType>

This command selects the type of signal generated at the trigger output.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<OutputType>
DEVice

Sends a trigger signal when the R&S FSW has triggered internally.

TARMed

Sends a trigger signal when the trigger is armed and ready for an external trigger event.

UDEFined

Sends a user defined trigger signal. For more information see OUTPut:​TRIGger<port>:​LEVel.

*RST: DEVice
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Output Type"


OUTPut:TRIGger<port>:PULSe:IMMediate

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Triggering > Configuring the Trigger Output > OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:IMMediate

This command generates a pulse at the trigger output.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: Event
Manual operation: See "Send Trigger"


OUTPut:TRIGger<port>:PULSe:LENGth

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Triggering > Configuring the Trigger Output > OUTPut:TRIGger<port>:PULSe:LENGth
OUTPut:TRIGger<port>:PULSe:LENGth <Length>

This command defines the length of the pulse generated at the trigger output.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Length>

Pulse length in seconds.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Pulse Length"


Configuring Data Acquisition

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Data Acquisition
Configuring Data Acquisition

The following commands are required to configure the actual data acquisition.

Configuring data acquisition is only possible for the MSRA Master channel. In MSRA application channels, these commands define the analysis interval (see "Commands Specific to MSRA Applications"). Be sure to select the correct measurement channel before executing these commands.

List of Commands
[SENSe:]IQ:BANDwidth|BWIDth:MODE
[SENSe:]IQ:BANDwidth|BWIDth:RESolution
[SENSe:]IQ:FFT:ALGorithm
[SENSe:]IQ:FFT:LENGth
[SENSe:]IQ:FFT:WINDow:LENGth
[SENSe:]IQ:FFT:WINDow:OVERlap
[SENSe:]IQ:FFT:WINDow:TYPE
TRACe:IQ:BWIDth
TRACe:IQ:RLENgth
TRACe:IQ:SRATe
TRACe:IQ:TPISample?
TRACe:IQ:WBANd[:STATe]
TRACe:IQ:WBANd:MBWIDTH


[SENSe:]IQ:BANDwidth|BWIDth:MODE

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Data Acquisition > [SENSe:]IQ:BANDwidth|BWIDth:MODE
[SENSe:]IQ:BANDwidth|BWIDth:MODE <Mode>

This command defines how the resolution bandwidth is determined.

Parameters:
<Mode>
AUTO | MANual | FFT
AUTO

(Default) The RBW is determined automatically depending on the sample rate and record length.

MANual

The user-defined RBW is used and the (FFT) window length (and possibly the sample rate) are adapted accordingly. The RBW is defined using the [SENSe:​]IQ:​BANDwidth|BWIDth:​RESolution command.

FFT

The RBW is determined by the FFT parameters.

*RST: AUTO
Example: IQ:BAND:MODE MAN

Switches to manual RBW mode.

IQ:BAND:RES 120000

Sets the RBW to 120 kHz.

Usage: SCPI confirmed
Manual operation: See "RBW"


[SENSe:]IQ:BANDwidth|BWIDth:RESolution

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Data Acquisition > [SENSe:]IQ:BANDwidth|BWIDth:RESolution
[SENSe:]IQ:BANDwidth|BWIDth:RESolution <Bandwidth>

This command defines the resolution bandwidth manually if [SENSe:​]IQ:​BANDwidth|BWIDth:​MODE is set to MAN.

Defines the resolution bandwidth. The available RBW values depend on the sample rate and record length.

Parameters:
<Bandwidth>
refer to data sheet
*RST: RBW: AUTO mode is used
Example: IQ:BAND:MODE MAN

Switches to manual RBW mode.

IQ:BAND:RES 120000

Sets the RBW to 120 kHz.

Usage: SCPI confirmed
Manual operation: See "RBW"


[SENSe:]IQ:FFT:ALGorithm

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Data Acquisition > [SENSe:]IQ:FFT:ALGorithm
[SENSe:]IQ:FFT:ALGorithm <Method>

Defines the FFT calculation method.

For more information see "Basics on FFT" .

Parameters:
<Method>
SINGle

One FFT is calculated for the entire record length; if the FFT length is larger than the record length (see [SENSe:​]IQ:​FFT:​LENGth and TRACe:​IQ:​RLENgth), zeros are appended to the captured data.

AVERage

Several overlapping FFTs are calculated for each record; the results are averaged to determine the final FFT result for the record.

The user-defined window length and window overlap are used (see [SENSe:​]IQ:​FFT:​WINDow:​LENGth and [SENSe:​]IQ:​FFT:​WINDow:​OVERlap).

*RST: AVER
Example: IQ:FFT:ALG SING
Usage: SCPI confirmed
Manual operation: See "Transformation Algorithm"


[SENSe:]IQ:FFT:LENGth

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Data Acquisition > [SENSe:]IQ:FFT:LENGth
[SENSe:]IQ:FFT:LENGth <NoOfBins>

Defines the number of frequency points determined by each FFT calculation. The more points are used, the higher the resolution in the spectrum becomes, but the longer the calculation takes.

Parameters:
<NoOfBins>
integer value
Range: | 3 to 524288
*RST: | 4096
Example: IQ:FFT:LENG 2048
Usage: SCPI confirmed
Manual operation: See "FFT Length"


[SENSe:]IQ:FFT:WINDow:LENGth

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Data Acquisition > [SENSe:]IQ:FFT:WINDow:LENGth
[SENSe:]IQ:FFT:WINDow:LENGth <NoOfFFT>

Defines the number of samples to be included in a single FFT window when multiple FFT windows are used.

Parameters:
<NoOfFFT>
integer value
Range: | 3 to 1001
*RST: | 1001
Example: IQ:FFT:WIND:LENG 500
Usage: SCPI confirmed
Manual operation: See "Window Length"


[SENSe:]IQ:FFT:WINDow:OVERlap

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Data Acquisition > [SENSe:]IQ:FFT:WINDow:OVERlap
[SENSe:]IQ:FFT:WINDow:OVERlap <Rate>

Defines the part of a single FFT window that is re-calculated by the next FFT calculation.

Parameters:
<Rate>
double value

Percentage rate

Range: | 0 to 1
*RST: | 0.75
Example: IQ:FFT:WIND:OVER 0.5

Half of each window overlaps the previous window in FFT calculation.

Usage: SCPI confirmed
Manual operation: See "Window Overlap"


[SENSe:]IQ:FFT:WINDow:TYPE

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Data Acquisition > [SENSe:]IQ:FFT:WINDow:TYPE
[SENSe:]IQ:FFT:WINDow:TYPE <Function>

In the I/Q Analyzer you can select one of several FFT window types.

Parameters:
<Function>
BLACkharris

Blackman-Harris

FLATtop

Flattop

GAUSsian

Gauss

RECTangular

Rectangular

P5

5-Term

*RST: FLAT
Example: IQ:FFT:WIND:TYPE GAUS
Usage: SCPI confirmed
Manual operation: See "Window Function"


TRACe:IQ:BWIDth

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Data Acquisition > TRACe:IQ:BWIDth
TRACe:IQ:BWIDth

This command defines or queries the bandwidth of the resampling filter.

The bandwidth of the resampling filter depends on the sample rate.

Parameters:
<Bandwidth>

For details on the maximum bandwidth see "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input".

Example:

See "I/Q Analysis with Graphical Evaluation" .

Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "Analysis Bandwidth"


TRACe:IQ:RLENgth

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Data Acquisition > TRACe:IQ:RLENgth
TRACe:IQ:RLENgth <NoOfSamples>

This command sets the record length for the acquired I/Q data.

Increasing the record length also increases the measurement time.

Note: Alternatively, you can define the measurement time using the SENS:SWE:TIME command.

Parameters:
<NoOfSamples>

Number of samples to record.

For digital input via the Digital Baseband Interface (R&S FSW-B17) the valid number of samples is described in "Sample Rates and Bandwidths for Digital I/Q Data".

*RST: 1001
Example: TRAC:IQ:RLEN 256
Example:

See "I/Q Analysis with Graphical Evaluation" .

Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "Record Length"


TRACe:IQ:SRATe

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Data Acquisition > TRACe:IQ:SRATe
TRACe:IQ:SRATe <SampleRate>

This command sets the final user sample rate for the acquired I/Q data. Thus, the user sample rate can be modified without affecting the actual data capturing settings on the R&S FSW.

Note: The smaller the user sample rate, the smaller the usable I/Q bandwidth, see "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input".

Parameters:
<SampleRate>

The valid sample rates are described in "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input".

Range: | 100 Hz to 10 GHz continuously adjustable;
*RST: | 32 MHz
Example:

See "I/Q Analysis with Graphical Evaluation" .

Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "Sample Rate"


TRACe:IQ:TPISample?

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Data Acquisition > TRACe:IQ:TPISample?
TRACe:IQ:TPISample?

This command queries the time offset between the sample start and the trigger event (trigger point in sample = TPIS). Since the R&S FSW usually samples with a much higher sample rate than the specific application actually requires, the trigger point determined internally is much more precise than the one determined from the (downsampled) data in the application. Thus, the TPIS indicates the offset between the sample start and the actual trigger event.

This value can only be determined in triggered measurements using external or IFPower triggers, otherwise the value is 0.

This command is not available if the Digital Baseband Interface (R&S FSW-B17) is active and not for bandwidths > 80 MHz.

Example: | TRAC:IQ:TPIS? Result for a sample rate of 1 MHz: between 0 and 1/1 MHz, i.e. between 0 and 1 μs (the duration of 1 sample).
Usage: | Query only


TRACe:IQ:WBANd[:STATe]

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Data Acquisition > TRACe:IQ:WBANd[:STATe]
TRACe:IQ:WBANd[:STATe] <State>

This command determines whether the wideband provided by bandwidth extension options is used or not (if installed).

Parameters:
<State>
ON | OFF
ON

If enabled, installed bandwidth extension options can be used. They are activated for bandwidths > 80 MHz, if the bandwidth is not restricted by the TRACe:​IQ:​WBANd:​MBWIDTH command. Otherwise, the currently available maximum bandwidth is allowed (see "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input").

This parameter corresponds to the "Auto" setting in manual operation (with TRACe:​IQ:​WBANd:​MBWIDTH 320 MHZ).

OFF

The bandwidth extension options R&S FSW-B500/-B320/-B160 are deactivated; the maximum analysis bandwidth is restricted to 80 MHz.

This parameter corresponds to the "80 MHz" setting in manual operation.

*RST: ON
Manual operation: See "Maximum Bandwidth"


TRACe:IQ:WBANd:MBWIDTH

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Configuring Data Acquisition > TRACe:IQ:WBANd:MBWIDTH
TRACe:IQ:WBANd:MBWIDTH <Limit>

Restricts the maximum analysis bandwidth.

Parameters:
<Limit>
80 MHz

Restricts the analysis bandwidth to a maximum of 80 MHz.

The bandwidth extension option R&S FSW-B160/-B320/-B500 is deactivated.

TRACe:​IQ:​WBANd[:​STATe] is set to OFF.

160 MHz

Restricts the analysis bandwidth to a maximum of 160 MHz. The bandwidth extension option R&S FSW-B320 is deactivated.

(Not available or required if bandwidth extension option R&S FSW-B500 is installed.)

TRACe:​IQ:​WBANd[:​STATe] is set to ON.

500 MHz | 320 MHz | MAX

All installed bandwidth extension options are activated. The currently available maximum bandwidth is allowed (see "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input").

TRACe:​IQ:​WBANd[:​STATe] is set to ON.

*RST: | maximum available
Default unit: | Hz
Manual operation: See "Maximum Bandwidth"


Adjusting Settings Automatically

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Adjusting Settings Automatically
Adjusting Settings Automatically

The following remote commands are required to adjust settings automatically in a remote environment. These commands are only available for the MSRA Master channel. The tasks for manual operation are described in " Automatic Settings".

Settings related to data acquisition (measurement time, hysteresis) can only be adjusted in the MSRA Master, not in the applications.

List of Commands
[SENSe:]ADJust:ALL
[SENSe:]ADJust:CONFigure:DURation
[SENSe:]ADJust:CONFigure:DURation:MODE
[SENSe:]ADJust:FREQuency
[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer
[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer
[SENSe:]ADJust:LEVel


[SENSe:]ADJust:ALL

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Adjusting Settings Automatically > [SENSe:]ADJust:ALL
[SENSe:]ADJust:ALL

This command initiates a measurement to determine and set the ideal settings for the current task automatically (only once for the current measurement).

This includes:

  • Reference level
Example: | ADJ:ALL
Usage: | Event
Manual operation: | See "Adjusting all Determinable Settings Automatically (Auto All)"


[SENSe:]ADJust:CONFigure:DURation

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Adjusting Settings Automatically > [SENSe:]ADJust:CONFigure:DURation
[SENSe:]ADJust:CONFigure:DURation <Duration>

In order to determine the ideal reference level, the R&S FSW performs a measurement on the current input data. This command defines the length of the measurement if [SENSe:​]ADJust:​CONFigure:​DURation:​MODE is set to MANual.

Parameters:
<Duration>
Numeric value in seconds
Range: | 0.001 to 16000.0
*RST: | 0.001
Default unit: | s
Example: ADJ:CONF:DUR:MODE MAN

Selects manual definition of the measurement length.

ADJ:CONF:LEV:DUR 5ms

Length of the measurement is 5 ms.

Manual operation: See "Changing the Automatic Measurement Time (Meastime Manual)"


[SENSe:]ADJust:CONFigure:DURation:MODE

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Adjusting Settings Automatically > [SENSe:]ADJust:CONFigure:DURation:MODE
[SENSe:]ADJust:CONFigure:DURation:MODE <Mode>

In order to determine the ideal reference level, the R&S FSW performs a measurement on the current input data. This command selects the way the R&S FSW determines the length of the measurement .

Parameters:
<Mode>
AUTO

The R&S FSW determines the measurement length automatically according to the current input data.

MANual

The R&S FSW uses the measurement length defined by [SENSe:​]ADJust:​CONFigure:​DURation.

*RST: AUTO
Manual operation: See "Resetting the Automatic Measurement Time (Meastime Auto)"
See "Changing the Automatic Measurement Time (Meastime Manual)"


[SENSe:]ADJust:FREQuency

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Adjusting Settings Automatically > [SENSe:]ADJust:FREQuency
[SENSe:]ADJust:FREQuency

This command sets the center frequency to the highest signal level in the current frequency range.

Example: | ADJ:FREQ
Usage: | Event
Manual operation: | See "Adjusting the Center Frequency Automatically (Auto Freq)"


[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Adjusting Settings Automatically > [SENSe:]ADJust:CONFigure:HYSTeresis:LOWer
[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer <Threshold>

When the reference level is adjusted automatically using the [SENSe:​]ADJust:​LEVel command, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines a lower threshold the signal must fall below (compared to the last measurement) before the reference level is adapted automatically.

This setting can only be adjusted in the MSRA Master, not in the applications.

Parameters:
<Threshold>
Range: | 0 dB to 200 dB
*RST: | +1 dB
Default unit: | dB
Example: SENS:ADJ:CONF:HYST:LOW 2

For an input signal level of currently 20 dBm, the reference level will only be adjusted when the signal level falls below 18 dBm.

Manual operation: See "Lower Level Hysteresis"


[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Adjusting Settings Automatically > [SENSe:]ADJust:CONFigure:HYSTeresis:UPPer
[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer <Threshold>

When the reference level is adjusted automatically using the [SENSe:​]ADJust:​LEVel command, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines an upper threshold the signal must exceed (compared to the last measurement) before the reference level is adapted automatically.

This setting can only be adjusted in the MSRA Master, not in the applications.

Parameters:
<Threshold>
Range: | 0 dB to 200 dB
*RST: | +1 dB
Default unit: | dB
Example: SENS:ADJ:CONF:HYST:UPP 2
Example:

For an input signal level of currently 20 dBm, the reference level will only be adjusted when the signal level rises above 22 dBm.

Manual operation: See "Upper Level Hysteresis"


[SENSe:]ADJust:LEVel

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Configuring MSRA Measurements > Adjusting Settings Automatically > [SENSe:]ADJust:LEVel
[SENSe:]ADJust:LEVel

This command initiates a single (internal) measurement that evaluates and sets the ideal reference level for the current input data and measurement settings. This ensures that the settings of the RF attenuation and the reference level are optimally adjusted to the signal level without overloading the R&S FSW or limiting the dynamic range by an S/N ratio that is too small.

Example: | ADJ:LEV
Usage: | Event
Manual operation: | See "Setting the Reference Level Automatically (Auto Level)"


Capturing Data and Performing Sweeps

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Capturing Data and Performing Sweeps
Capturing Data and Performing Sweeps

The only true measurement in MSRA mode in which I/Q data from the input signal is captured and stored is performed by the MSRA Master. This data acquisition is performed as in the I/Q Analyzer application, i.e. a specified frequency span of the input signal is swept for a specified measurement time.

As soon as data has been stored to the capture buffer successfully, a status bit (#9) in the STAT:OPER register is set (see "STATus:OPERation Register". Once the bit has been set, the device under test can already be reconfigured while the R&S FSW performs analysis on the captured data. For measurements that require long measurement times and comprehensive analysis tasks, using the "capture finished" information can reduce the overall measurement time significantly.

See also:
  • INITiate:​REFResh
List of Commands
ABORt
INITiate:CONMeas
INITiate:CONTinuous
INITiate[:IMMediate]
INITiate:SEQuencer:ABORt
INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:MODE
INITiate:SEQuencer:REFResh[:ALL]
[SENSe:]SWEep:POINts
[SENSe:]SWEep:TIME
SYSTem:SEQuencer


ABORt

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Capturing Data and Performing Sweeps > ABORt
ABORt

This command aborts a current measurement and resets the trigger system.

To prevent overlapping execution of the subsequent command before the measurement has been aborted successfully, use the *OPC? or *WAI command after ABOR and before the next command.

For details see "Preventing Overlapping Execution" .

To abort a sequence of measurements by the Sequencer, use the INITiate:​SEQuencer:​ABORt command.

Note on blocked remote control programs:

If a sequential command cannot be completed, for example because a triggered sweep never receives a trigger, the remote control program will never finish and the remote channel to the R&S FSW is blocked for further commands. In this case, you must interrupt processing on the remote channel first in order to abort the measurement.

To do so, send a "Device Clear" command from the control instrument to the R&S FSW on a parallel channel to clear all currently active remote channels. Depending on the used interface and protocol, send the following commands:

  • Visa: viClear()
  • GPIB: ibclr()
  • RSIB: RSDLLibclr()

Now you can send the ABORt command on the remote channel performing the measurement.

Example: | ABOR;:INIT:IMM Aborts the current measurement and immediately starts a new one.
Example: | ABOR;*WAI INIT:IMM Aborts the current measurement and starts a new one once abortion has been completed.
Usage: | SCPI confirmed


INITiate:CONMeas

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Capturing Data and Performing Sweeps > INITiate:CONMeas
INITiate:CONMeas

This command restarts a (single) measurement that has been stopped (using INIT:CONT OFF) or finished in single sweep mode.

The measurement is restarted at the beginning, not where the previous measurement was stopped.

As opposed to INITiate[:​IMMediate], this command does not reset traces in maxhold, minhold or average mode. Therefore it can be used to continue measurements using maxhold or averaging functions.

Manual operation: See "Continue Single Sweep"


INITiate:CONTinuous

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Capturing Data and Performing Sweeps > INITiate:CONTinuous
INITiate:CONTinuous <State>

This command controls the sweep mode.

Note that in single sweep mode, you can synchronize to the end of the measurement with *OPC, *OPC? or *WAI. In continuous sweep mode, synchronization to the end of the measurement is not possible. Thus, it is not recommended that you use continuous sweep mode in remote control, as results like trace data or markers are only valid after a single sweep end synchronization.

For details on synchronization see "Command Sequence and Synchronization"

If the sweep mode is changed for a measurement channel while the Sequencer is active (see INITiate:​SEQuencer:​IMMediate) the mode is only considered the next time the measurement in that channel is activated by the Sequencer.

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

Continuous sweep

OFF | 0

Single sweep

*RST: 1
Example: INIT:CONT OFF

Switches the sweep mode to single sweep.

INIT:CONT ON

Switches the sweep mode to continuous sweep.

Manual operation: See "Continuous Sweep/RUN CONT"


INITiate[:IMMediate]

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Capturing Data and Performing Sweeps > INITiate[:IMMediate]
INITiate[:IMMediate]

This command starts a (single) new measurement.

You can synchronize to the end of the measurement with *OPC, *OPC? or *WAI.

For details on synchronization see "Command Sequence and Synchronization"

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Single Sweep/ RUN SINGLE"


INITiate:SEQuencer:ABORt

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Capturing Data and Performing Sweeps > INITiate:SEQuencer:ABORt
INITiate:SEQuencer:ABORt

This command stops the currently active sequence of measurements. The Sequencer itself is not deactivated, so you can start a new sequence immediately using INITiate:​SEQuencer:​IMMediate.

To deactivate the Sequencer use SYSTem:​SEQuencer.

Usage: | Event
Manual operation: | See "Sequencer State"


INITiate:SEQuencer:IMMediate

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Capturing Data and Performing Sweeps > INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:IMMediate

This command starts a new sequence of measurements by the Sequencer. Its effect is similar to the INITiate[:​IMMediate] command used for a single measurement.

Before this command can be executed, the Sequencer must be activated (see SYSTem:​SEQuencer).

Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single sequence mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

Example:

See "Programming Example: Performing a Sequence of Measurements" .

Example:

See "Programming Example: Analyzing MSR Signals".

Usage: Event
Manual operation: See "Sequencer State"


INITiate:SEQuencer:MODE

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Capturing Data and Performing Sweeps > INITiate:SEQuencer:MODE
INITiate:SEQuencer:MODE <Mode>

This command selects the way the R&S FSW application performs measurements sequentially.

Before this command can be executed, the Sequencer must be activated (see SYSTem:​SEQuencer).

A detailed programming example is provided in "Programming Example: Performing a Sequence of Measurements" .

Note: In order to synchronize to the end of a sequential measurement using *OPC, *OPC? or *WAI you must use SINGle Sequence mode.

For details on the Sequencer see "The Sequencer Concept" .

For details on synchronization see "Command Sequence and Synchronization"

Parameters:
<Mode>
SINGle

Each measurement is performed once (regardless of the channel's sweep mode), considering each channels' sweep count, until all measurements in all active channels have been performed.

CONTinuous

The measurements in each active channel are performed one after the other, repeatedly (regardless of the channel's sweep mode), in the same order, until the Sequencer is stopped.

CDEFined

First, a single sequence is performed. Then, only those channels in continuous sweep mode (INIT:CONT ON) are repeated.

*RST: CONTinuous
Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single sequence mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

Example:

See "Programming Example: Performing a Sequence of Measurements" .

Example:

See "Programming Example: Analyzing MSR Signals".

Manual operation: See "Sequencer Mode"


INITiate:SEQuencer:REFResh[:ALL]

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Capturing Data and Performing Sweeps > INITiate:SEQuencer:REFResh[:ALL]
INITiate:SEQuencer:REFResh[:ALL]

This function is only available if the Sequencer is deactivated (SYST:SEQ:OFF) and only in MSRA or MSRT mode.

The data in the capture buffer is re-evaluated by all active MSRA/MSRT applications.

Example: | SYST:SEQ:OFF Deactivates the scheduler INIT:CONT OFF Switches to single sweep mode. INIT;*WAI Starts a new data measurement and waits for the end of the sweep. INIT:SEQ:REFR Refreshes the display for all channels.
Usage: | Event
Manual operation: | See "Refresh All"


[SENSe:]SWEep:POINts

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Capturing Data and Performing Sweeps > [SENSe:]SWEep:POINts
[SENSe:]SWEep:POINts <SweepPoints>

This command defines the number of measurement points analyzed during a sweep.

Example: SWE:POIN 251
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Sweep Points"


[SENSe:]SWEep:TIME

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Capturing Data and Performing Sweeps > [SENSe:]SWEep:TIME
[SENSe:]SWEep:TIME <Time>

This command defines the sweep (or: data capture) time.

Parameters:
<Time>
refer to data sheet
*RST: depends on current settings (determined automatically)
Example: SWE:TIME 10s
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Meas Time"


SYSTem:SEQuencer

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Capturing Data and Performing Sweeps > SYSTem:SEQuencer
SYSTem:SEQuencer <State>

This command turns the Sequencer on and off. The Sequencer must be active before any other Sequencer commands (INIT:SEQ...) are executed, otherwise an error will occur.

For details on the Sequencer see "The Sequencer Concept" .

A detailed programming example is provided in "Programming Example: Performing a Sequence of Measurements" .

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

The Sequencer is activated and a sequential measurement is started immediately.

OFF | 0

The Sequencer is deactivated. Any running sequential measurements are stopped. Further Sequencer commands (INIT:SEQ...) are not available.

*RST: 0
Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single Sequencer mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

SYST:SEQ OFF
Example:

See "Programming Example: Performing a Sequence of Measurements" .

Manual operation: See "Sequencer State"


Retrieving Results

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Retrieving Results
Retrieving Results

The measurement results are output in the form of a list, three different formats can be selected for this list (see TRACe:​IQ:​DATA:​FORMat).

For details on formats refer to "Reference: Format Description for I/Q Data Files".

The applications can only receive data that is available in the capture buffer. As soon as data has been stored to the capture buffer successfully, a status bit (#9) in the STAT:OPER register is set (see "STATus:OPERation Register").

List of Commands
FORMat[:DATA]
TRACe:IQ:DATA?
TRACe:IQ:DATA:FORMat
TRACe:IQ:DATA:MEMory?


FORMat[:DATA]

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Retrieving Results > FORMat[:DATA]
FORMat[:DATA] <Format>

This command selects the data format that is used for transmission of trace data from the R&S FSW to the controlling computer.

Note that the command has no effect for data that you send to the R&S FSW. The R&S FSW automatically recognizes the data it receives, regardless of the format.

Parameters:
<Format>
ASCii

ASCii format, separated by commas.

This format is almost always suitable, regardless of the actual data format. However, the data is not as compact as other formats may be.

REAL,32

32-bit IEEE 754 floating-point numbers in the "definite length block format".

In the Spectrum application, the format setting REAL is used for the binary transmission of trace data.

For I/Q data, 8 bytes per sample are returned for this format setting.

*RST: ASCII
Example: FORM REAL,32
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Usage: SCPI confirmed


TRACe:IQ:DATA?

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Retrieving Results > TRACe:IQ:DATA?
TRACe:IQ:DATA?

This command queries the captured data from measurements with the I/Q Analyzer.

To get the results, the command also initiates a measurement with the current settings of the R&S FSW.

Return values:
<Results>

Measured voltage for I and Q component for each sample that has been captured during the measurement.

For more information see "I/Q Processing Modes" .

The data format depends on FORMat[:​DATA].

Default unit: V
Example: TRAC:IQ:STAT ON

Enables acquisition of I/Q data

TRAC:IQ:SET NORM,10MHz,32MHz,EXT,POS,0,4096

Measurement configuration:

Sample Rate = 32 MHz

Trigger Source = External

Trigger Slope = Positive

Pretrigger Samples = 0

Number of Samples = 4096

FORMat REAL,32

Selects format of response data

TRAC:IQ:DATA?

Starts measurement and reads results

Example:

See "Basic I/Q Analysis with Improved Performance" .

Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Usage: Query only


TRACe:IQ:DATA:FORMat

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Retrieving Results > TRACe:IQ:DATA:FORMat
TRACe:IQ:DATA:FORMat <Format>

This command selects the order of the I/Q data.

For details see "Reference: Format Description for I/Q Data Files".

Parameters:
<Format>
COMPatible | IQBLock | IQPair
COMPatible

I and Q values are separated and collected in blocks: A block (512k) of I values is followed by a block (512k) of Q values, followed by a block of I values, followed by a block of Q values etc.

(I,I,I,I,Q,Q,Q,Q,I,I,I,I,Q,Q,Q,Q...)

IQBLock

First all I-values are listed, then the Q-values

(I,I,I,I,I,I,...Q,Q,Q,Q,Q,Q)

IQPair

One pair of I/Q values after the other is listed

(I,Q,I,Q,I,Q...).

*RST: IQBL
Example:

See "I/Q Analysis with Graphical Evaluation" .

Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .


TRACe:IQ:DATA:MEMory?

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Retrieving Results > TRACe:IQ:DATA:MEMory?
TRACe:IQ:DATA:MEMory? [<OffsetSamples>,<NoOfSamples>]

This command queries the I/Q data currently stored in the memory of the R&S FSW.

By default, the command returns all I/Q data in the memory. You can, however, narrow down the amount of data that the command returns using the optional parameters.

Parameters:
<OffsetSamples>

Selects an offset at which the output of data should start in relation to the first data. If omitted, all captured samples are output, starting with the first sample.

Range: | 0 to <# of samples> – 1, with <# of samples> being the maximum number of captured values
*RST: | 0
<NoOfSamples>

Number of samples you want to query, beginning at the offset you have defined. If omitted, all captured samples (starting at offset) are output.

Range: | 1 to <# of samples> - <offset samples> with <# of samples> maximum number of captured values
*RST: | <# of samples>
Return values:
<IQData>

Measured value pair (I,Q) for each sample that has been recorded.

The data format depends on FORMat[:​DATA].

Default unit: V
Example: TRAC:IQ:STAT ON

Enables acquisition of I/Q data

TRAC:IQ:SET NORM,10MHz,32MHz,EXT,POS,100,4096

Measurement configuration:

Sample Rate = 32 MHz

Trigger Source = External

Trigger Slope = Positive

Pretrigger Samples = 100

Number of Samples = 4096

INIT;*WAI

Starts measurement and wait for sync

FORMat REAL,32

Determines output format

To read the results:

TRAC:IQ:DATA:MEM?

Reads all 4096 I/Q data

TRAC:IQ:DATA:MEM? 0,2048

Reads 2048 I/Q data starting at the beginning of data acquisition

TRAC:IQ:DATA:MEM? 2048,1024

Reads 1024 I/Q data from half of the recorded data

TRAC:IQ:DATA:MEM? 100,512

Reads 512 I/Q data starting at the trigger point (<Pretrigger Samples> was 100)

Example:

See "I/Q Analysis with Graphical Evaluation" .

Example:

See "Basic I/Q Analysis with Improved Performance" .

Usage: Query only


Querying the Status Registers

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Querying the Status Registers
Querying the Status Registers

The R&S FSW-I/Q Analyzer uses the standard status registers of the R&S FSW.

The MSRA operating mode uses an additional bit in the STATus:OPERation register.

This register and the commands required to query its contents are described here.

For details and a description of the common R&S FSW status registers see "Status Reporting System" .

*RST does not influence the status registers.

Contents
  • STATus:OPERation Register
  • Commands to Query the STATus:OPERation Register


STATus:OPERation Register

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Querying the Status Registers > STATus:OPERation Register
STATus:OPERation Register

The STATus:OPERation register contains information on current activities of the R&S FSW. It also contains information on activities that have been executed since the last read out.

You can read out the register with STATus:​OPERation:​CONDition? or STATus:​OPERation[:​EVENt]?.

Meaning of the bits used in the STATus:OPERation register
Bit No. | Meaning
0 | CALibrating This bit is set as long as the instrument is performing a calibration.
1-2 | Not used
3 | SWEeping Sweep is being performed in base unit (applications are not considered); identical to bit 4 In applications, this bit is not used.
4 | MEASuring Measurement is being performed in base unit (applications are not considered); identical to bit 3 In applications, this bit is not used.
5 | Waiting for TRIgger Instrument is ready to trigger and waiting for trigger signal.
6-7 | Not used
8 | HardCOPy in progress This bit is set while the instrument is printing a hardcopy.
9 | For data acquisition in MSRA/MSRT mode only: Multi-Standard capture finish This bit is set if a data acquisition measurement was completed successfully in MSRA/MSRT operating mode and data is available for evaluation.
10 | Range completed This bit is set when a range in the sweep list has been completed if "Stop after Range" has been activated.
11-14 | Not used
15 | This bit is always 0.


Commands to Query the STATus:OPERation Register

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Querying the Status Registers > Commands to Query the STATus:OPERation Register
Commands to Query the STATus:OPERation Register

The following commands are required to query the contents of the STATus:OPERation register.

List of Commands
STATus:OPERation:CONDition?
STATus:OPERation:ENABle?
STATus:OPERation:NTRansition?
STATus:OPERation:PTRansition?
STATus:OPERation[:EVENt]?


STATus:OPERation:CONDition?

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Querying the Status Registers > Commands to Query the STATus:OPERation Register > STATus:OPERation:CONDition?
STATus:OPERation:CONDition? <ChannelName>

This comand reads out the CONDition section of the status register.

(See "STATus:OPERation Register")

The command does not delete the contents of the EVENt section.

Query parameters:
<ChannelName> | String containing the name of the channel. The parameter is optional. If you omit it, the command works for the currently active channel.
Usage: | Query only


STATus:OPERation:ENABle?

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Querying the Status Registers > Commands to Query the STATus:OPERation Register > STATus:OPERation:ENABle?
STATus:OPERation:ENABle? <SumBit>,<ChannelName>

This command controls the ENABle part of the register.

(See "STATus:OPERation Register")

The ENABle part allows true conditions in the EVENt part of the status register to bereported in the summary bit. If a bit is 1 in the enable register and its associated event bit transitions to true, a positive transition will occur in the summary bit reported to the next higher level.

Parameters:
<SumBit>
Range: 0 to 65535
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.

Usage: Query only


STATus:OPERation:NTRansition?

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Querying the Status Registers > Commands to Query the STATus:OPERation Register > STATus:OPERation:NTRansition?
STATus:OPERation:NTRansition? <SumBit>,<ChannelName>

This command controls the Negative TRansition part of a register.

(See "STATus:OPERation Register")

Setting a bit causes a 1 to 0 transition in the corresponding bit of the associated register. The transition also writes a 1 into the associated bit of the corresponding EVENt register.

Parameters:
<SumBit>
Range: 0 to 65535
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.

Usage: Query only


STATus:OPERation:PTRansition?

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Querying the Status Registers > Commands to Query the STATus:OPERation Register > STATus:OPERation:PTRansition?
STATus:OPERation:PTRansition? <SumBit>,<ChannelName>

This command controls the Positive TRansition part of the register.

(See "STATus:OPERation Register")

Setting a bit causes a 0 to 1 transition in the corresponding bit of the associated register. The transition also writes a 1 into the associated bit of the corresponding EVENt register.

Parameters:
<SumBit>
Range: 0 to 65535
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.

Usage: Query only


STATus:OPERation[:EVENt]?

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Querying the Status Registers > Commands to Query the STATus:OPERation Register > STATus:OPERation[:EVENt]?
STATus:OPERation[:EVENt]? <ChannelName>

This command queries the contents of the EVENt section of the status register.

(See "STATus:OPERation Register")

A query deletes the contents of the EVENt section.

Query parameters:
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.

Return values:
<RegisterContents>
Range: 0 to 32767
Usage: Query only


Analyzing MSRA Measurements

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Analyzing MSRA Measurements
Analyzing MSRA Measurements

The data that was captured by the MSRA Master can be analyzed in various different applications.

The analysis settings and functions available in MSRA mode are those described for the individual applications. The MSRA Master is in effect an I/Q Analyzer application and has the same analysis functions and settings.

See "I/Q Analysis" for a description of the analysis function and setting commands available for the I/Q Analyzer and thus the MSRA Master.

The commands required to configure the MSRA-specific analysis line are described in "Commands Specific to MSRA Applications".


Commands Specific to MSRA Applications

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Commands Specific to MSRA Applications
Commands Specific to MSRA Applications

Most commands for the MSRA applications are identical to those described for the individual applications. However, some specific commands are available for the MSRA applications only.

Configuring the analysis interval

The commands required to configure the application data extracts and analysis intervals vary depending on the application. See the corresponding application manuals for details.

For the I/Q Analyzer, the commands are the same as those used to define the actual data acquisition (see "Configuring Data Acquisition". In MSRA application channels, these commands define the analysis interval. Be sure to select the correct measurement channel before executing these commands.

Useful commands for configuring the analysis interval described elsewhere:
  • TRACe:​IQ:​SRATe
  • TRACe:​IQ:​BWIDth
  • TRACe:​IQ:​RLENgth
  • [SENSe:​]SWEep:​TIME
Remote commands exclusive to MSRA applications

The following commands are only available for MSRA application channels:

List of Commands
CALCulate:IQ:MODE
CALCulate:MSRA:ALINe:SHOW
CALCulate:MSRA:ALINe[:VALue]
CALCulate:MSRA:WINDow<n>:IVAL?
INITiate:REFResh
[SENSe:]MSRA:CAPTure:OFFSet


CALCulate:IQ:MODE

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Commands Specific to MSRA Applications > CALCulate:IQ:MODE
CALCulate:IQ:MODE <EvalMode>

This command defines whether the captured I/Q data is evaluated directly, or if it is converted (via FFT) to spectral or time data first.

It is currently only available for I/Q Analyzer applications in multistandrad mode (not the MSRA Master).

Parameters:
<EvalMode>
TDOMain

Evaluation in time domain (zero span).

FDOMain

Evaluation in frequency domain.

IQ

Evaluation using I/Q data.


CALCulate:MSRA:ALINe:SHOW

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Commands Specific to MSRA Applications > CALCulate:MSRA:ALINe:SHOW
CALCulate:MSRA:ALINe:SHOW

This command defines whether or not the analysis line is displayed in all time-based windows in all MSRA applications and the MSRA Master.

Note: even if the analysis line display is off, the indication whether or not the currently defined line position lies within the analysis interval of the active application remains in the window title bars.

Parameters:
<State>
ON | OFF
*RST: ON
Manual operation: See "Show Line"


CALCulate:MSRA:ALINe[:VALue]

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Commands Specific to MSRA Applications > CALCulate:MSRA:ALINe[:VALue]
CALCulate:MSRA:ALINe[:VALue] <Position>

This command defines the position of the analysis line for all time-based windows in all MSRA applications and the MSRA Master.

Parameters:
<Position>

Position of the analysis line in seconds. The position must lie within the measurement time of the MSRA measurement.

Default unit: s
Manual operation: See "Position"


CALCulate:MSRA:WINDow<n>:IVAL?

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Commands Specific to MSRA Applications > CALCulate:MSRA:WINDow<n>:IVAL?
CALCulate:MSRA:WINDow<n>:IVAL?

This command queries the analysis interval for the window specified by the index <n>. This command is only available in application measurement channels, not the MSRA View or MSRA Master.

Return values:
<IntStart>

Start value of the analysis interval in seconds

Default unit: s
<IntStop>

Stop value of the analysis interval in seconds

Usage: Query only


INITiate:REFResh

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Commands Specific to MSRA Applications > INITiate:REFResh
INITiate:REFResh

This function is only available if the Sequencer is deactivated (SYST:SEQ:OFF) and only for applications in MSRA mode, not the MSRA Master.

The data in the capture buffer is re-evaluated by the currently active application only. The results for any other applications remain unchanged.

The application channel must be selected before this command can be executed (see INSTrument[:​SELect]).

Example: | SYST:SEQ:OFF Deactivates the scheduler INIT:CONT OFF Switches to single sweep mode. INIT;*WAI Starts a new data measurement and waits for the end of the sweep. INST:SEL 'IQ ANALYZER' Selects the IQ Analyzer channel. INIT:REFR Refreshes the display for the I/Q Analyzer channel.
Usage: | Event
Manual operation: | See "Refresh"


[SENSe:]MSRA:CAPTure:OFFSet

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Commands Specific to MSRA Applications > [SENSe:]MSRA:CAPTure:OFFSet
[SENSe:]MSRA:CAPTure:OFFSet <Offset>

This setting is only available for applications in MSRA mode, not for the MSRA Master. It has a similar effect as the trigger offset in other measurements.

Parameters:
<Offset>

This parameter defines the time offset between the capture buffer start and the start of the extracted application data. The offset must be a positive value, as the application can only analyze data that is contained in the capture buffer.

Range: | 0 to <Record length>
*RST: | 0
Manual operation: See "Capture Offset"


Programming Example: Analyzing MSR Signals

MSRA Mode > Remote Commands to Perform Measurements in MSRA Mode > Programming Example: Analyzing MSR Signals
Programming Example: Analyzing MSR Signals

The following programming example demonstrates the use of the most important remote commands in MSRA mode. The example is based on the measurement example for manual operation described in "Measurement Example: Analyzing MSR Signals".

//Preset
*RST

//Select Trace data output format: ASCII
FORM ASCII

//Switch to MSRA mode
INST:MODE MSR

//Set Sequencer in single mode
INIT:SEQ:MODE SING

//Preconfigure MSRA Master for general I/Q data acquisition

//Set initial center frequency
FREQ:CENT 1000MHz

//Set Level
DISP:WIND:TRAC:Y:SCAL:RLEV 10 dBm

//Set Trigger to External 1
:TRIG:SOUR EXT

//Set Sample Rate to 15MHz
:TRACe:IQ:SRATe 15E6

//Set Record Length to 1Msample -> AQT 21 ms
:TRACe:IQ:RLENgth 315000

//Create new measurement channel for I/Q Analyzer
INST:CRE IQ, 'IQ Analyzer'

//Set initial center frequency
FREQ:CENT 994.9 MHz

//Set Sample Rate to 1MHz
:TRACe:IQ:SRATe 1E6

//Set Record Length to 1Msample -> AQT 5 ms
:TRACe:IQ:RLENgth 5000

//Create measurement channel for 3GPP FDD BTS application
INST:CRE BWCD, '3GPP FDD BTS'

//Set initial center frequency
FREQ:CENT 997.5MHz

//Select Composite EVM vs slot in Window 1, EVM vs Chip in Window 3
//Result Summary remains in Window 2 as default
LAY:REPL:WIND '1',CEVM
LAY:ADD:WIND? '2',BEL,EVMC
//Result: new window is '5'

//Meas all tabs with synchronisation in MSRA mode
INIT:SEQ:IMM;*OPC?

//Retrieve Results of IQ Analyzer
INST:SEL 'IQ Analyzer'

//Check for Rising edge
:CALCulate:MARKer:X 1.14ms
:CALCulate:MARKer:Y?
:CALCulate:MARKer:X 1.156ms
:CALCulate:MARKer:Y?

//Retrieve Results from WCMDA
INST:SEL '3GPP FDD BTS'

//Retrieve Composite EVM results
TRAC1:DATA? TRACe1

//Select Slot No 1
CDP:SLOT 1

//Search Peak value of Marker in EVM vs Chip
:CALC5:MARK1 ON
:CALC5:MARK1:MAX:PEAK

//Retrieve Chip and max EVM value
:CALC5:MARK1:X?;Y?


Annex

MSRA Mode > Annex
Annex
Contents
  • Reference: Format Description for I/Q Data Files
  • Formats for Returned Values: ASCII Format and Binary Format
  • Sample Rate and Maximum Usable I/Q Bandwidth for RF Input
  • Sample Rates and Bandwidths for Digital I/Q Data


Reference: Format Description for I/Q Data Files

MSRA Mode > Annex > Reference: Format Description for I/Q Data Files
Reference: Format Description for I/Q Data Files

This section describes how I/Q data is transferred to the memory during remote control (see TRACe:​IQ:​DATA:​FORMat command).

For details on the format of the individual values, see "Formats for Returned Values: ASCII Format and Binary Format".

For details on the format of I/Q export files (using the "IQ Export" function), see "Reference: I/Q Data File Export Format (iq.tar)" .

I/Q data formats

Note: 512k corresponds to 524288 samples

For maximum performance, the formats "Compatible" or "IQPair" should be used. Furthermore, for large amounts of data, the data should be in binary format to improve performance.

In binary format, the number of I- and Q-data can be calculated as follows:

For the format "QBLock", the offset of Q-data in the output buffer can be calculated as follows:

with "LengthIndicatorDigits" being the number of digits of the length indicator including the #. In the example above (#41024…), this results in a value of 6 for "LengthIndicatorDigits" and the offset for the Q-data results in 512 + 6 = 518.


Formats for Returned Values: ASCII Format and Binary Format

MSRA Mode > Annex > Formats for Returned Values: ASCII Format and Binary Format
Formats for Returned Values: ASCII Format and Binary Format

When trace data is retrieved using the TRAC:DATA or TRAC:IQ:DATA command, the data is returned in the format defined using the FORMat[:​DATA]. The possible formats are described here.

  • ASCII Format (FORMat ASCII):
    The data is stored as a list of comma separated values (CSV) of the measured values in floating point format.
  • Binary Format (FORMat REAL,32):
    The data is stored as binary data (Definite Length Block Data according to IEEE 488.2), each measurement value being formatted in 32 Bit IEEE 754 Floating-Point-Format.
    The schema of the result string is as follows:
    #41024<value1><value2>…<value n> with
#4 | number of digits (= 4 in the example) of the following number of data bytes
1024 | number of following data bytes (= 1024 in the example)
<Value> | 4-byte floating point value

Reading out data in binary format is quicker than in ASCII format. Thus, binary format is recommended for large amounts of data.


Sample Rate and Maximum Usable I/Q Bandwidth for RF Input

MSRA Mode > Annex > Sample Rate and Maximum Usable I/Q Bandwidth for RF Input
Sample Rate and Maximum Usable I/Q Bandwidth for RF Input
Definitions
  • Input sample rate (ISR): the sample rate of the useful data provided by the connected instrument to the R&S FSW input
  • (User, Output) Sample rate (SR): the sample rate that is defined by the user (e.g. in the "Data Aquisition" dialog box in the "I/Q Analyzer" application) and which is used as the basis for analysis or output
  • Usable I/Q (Analysis) bandwidth: the bandwidth range in which the signal remains undistorted in regard to amplitude characteristic and group delay; this range can be used for accurate analysis by the R&S FSW
  • Record length: Number of I/Q samples to capture during the specified measurement time; calculated as the measurement time multiplied by the sample rate

For the I/Q data acquisition, digital decimation filters are used internally. The passband of these digital filters determines the maximum usable I/Q bandwidth. In consequence, signals within the usable I/Q bandwidth (passband) remain unchanged, while signals outside the usable I/Q bandwidth (passband) are suppressed. Usually, the suppressed signals are noise, artifacts, and the second IF side band. If frequencies of interest to you are also suppressed, you should try to increase the output sample rate, since this increases the maximum usable I/Q bandwidth.

Bandwidth extension options

The maximum usable I/Q bandwidth provided by the R&S FSW in the basic installation can be extended by additional options. These options can either be included in the initial installation (B-options) or updated later (U-options). The maximum bandwidth provided by the individual option is indicated by its number, for example, B40 extends the bandwidth to 40 MHz.

Note that the U-options as of U40 always require all lower-bandwidth options as a prerequisite, while the B-options already include them.

Max. usable I/Q BW

Required B-option

Required U-option(s)

10 MHz

-

-

28 MHz

B28

U28

40 MHz

B40

U28+U40 or

B28+U40

80 MHz

B80

U28+U40+U80 or

B28+U40+U80 or

B40+U80

160 MHz

B160

U28+U40+U80+U160 or

B28+U40+U80+U160 or

B40+U80+U160 or

B80+U160

320 MHz

B320*)

U28+U40+U80+U160+U320 or

B28+U40+U80+U160+U320 or

B40+U80+U160+U320 or

B80+U160+U320 or

B160+U320

500 MHz

B500**)

See data sheet

*) The bandwidth extension option R&S FSW-B320/-U320 requires a reference board revision 3.14 or higher.

**) The bandwidth extension option R&S FSW-B500 requires a reference board (1312.8075.06) revision 4.06 or higher and a motherboard 1313.4180.02 or 1313.7698.02.

As a rule, the usable I/Q bandwidth is proportional to the output sample rate. Yet, when the I/Q bandwidth reaches the bandwidth of the analog IF filter (at very high output sample rates), the curve breaks.

Relationship between sample rate, record length and usable I/Q bandwidth

Up to the maximum bandwidth, the following rule applies:

Usable I/Q bandwidth = 0.8 * Output sample rate

Regarding the record length, the following rule applies:

Record length = Measurement time * sample rate

Maximum record length for RF input

The maximum record length, that is, the maximum number of samples that can be captured, depends on the sample rate.

(For activated option B320 or U320 see table "Maximum record length with activated I/Q bandwidth extension option B320 or U320".)

(For activated option B500 see table "Maximum record length with activated I/Q bandwidth extension option B500".)

Maximum record length (without I/Q bandwidth extension options B320/U320/B500)
Sample rate | Maximum record length
100 Hz to 200 MHz | 440 MSamples (precisely: 461373440 (= 440*1024*1024) samples)
200 MHz to 10 GHz (upsampling) | 220 MSamples

The figure "Relationship between maximum usable I/Q bandwidth and output sample rate with and without bandwidth extensions" shows the maximum usable I/Q bandwidths depending on the output sample rates.

R&S FSW without additional bandwidth extension options

sample rate: 100 Hz - 10 GHz

maximum I/Q bandwidth: 10 MHz

Maximum I/Q bandwidth
Sample rate | Maximum I/Q bandwidth
100 Hz to 10 MHz | proportional up to maximum 10 MHz
10 MHz to 10 GHz | 10 MHz
R&S FSW with options B28 or U28 (I/Q Bandwidth Extension):

sample rate: 100 Hz - 10 GHz

maximum bandwidth: 28 MHz

Sample rate | Maximum I/Q bandwidth
100 Hz to 35 MHz | proportional up to maximum 28 MHz
35 MHz to 10 GHz | 28 MHz
R&S FSW with option B40 or U40 (I/Q Bandwidth Extension):

sample rate: 100 Hz - 10 GHz

maximum bandwidth: 40 MHz

Sample rate | Maximum I/Q bandwidth
100 Hz to 50 MHz | proportional up to maximum 40 MHz
50 MHz to 10 GHz | 40 MHz
R&S FSW with option B80 or U80 (I/Q Bandwidth Extension):

sample rate: 100 Hz - 10 GHz

maximum bandwidth: 80 MHz

Sample rate | Maximum I/Q bandwidth
100 Hz to 100 MHz | proportional up to maximum 80 MHz
100 MHz to 10 GHz | 80 MHz
R&S FSW with activated option B160 or U160 (I/Q Bandwidth Extension):

sample rate: 100 Hz - 10 GHz

maximum bandwidth: 160 MHz

Sample rate | Maximum I/Q bandwidth
100 Hz to 200 MHz | proportional up to maximum 160 MHz
200 MHz to 10 GHz | 160 MHz
Relationship between maximum usable I/Q bandwidth and output sample rate with and without bandwidth extensions
Contents
  • Max. Sample Rate and Bandwidth with Activated I/Q Bandwidth Extension Option B320/U320
  • Max. Sample Rate and Bandwidth with Activated I/Q Bandwidth Extension Option B500


Max. Sample Rate and Bandwidth with Activated I/Q Bandwidth Extension Option B320/U320

MSRA Mode > Annex > Sample Rate and Maximum Usable I/Q Bandwidth for RF Input > Max. Sample Rate and Bandwidth with Activated I/Q Bandwidth Extension Option B320/U320
Max. Sample Rate and Bandwidth with Activated I/Q Bandwidth Extension Option B320/U320
Sample rate | Maximum I/Q bandwidth
100 Hz to 400 MHz | proportional up to maximum 320 MHz
400 MHz to 10 GHz | 320 MHz
Relationship between maximum usable I/Q bandwidth and output sample rate for active R&S FSW-B320
Maximum record length with activated I/Q bandwidth extension option B320 or U320
Sample rate | Maximum record length
100 Hz to 200 MHz*) | 440 MSamples
200 MHz to 468 MHz | 470 MSamples * sample rate / 1GHz
468 MHz to 10 GHz | 220 MSamples
*) for sample rates < 200 MHz the I/Q Bandwidth Extension B320 is not used


Max. Sample Rate and Bandwidth with Activated I/Q Bandwidth Extension Option B500

MSRA Mode > Annex > Sample Rate and Maximum Usable I/Q Bandwidth for RF Input > Max. Sample Rate and Bandwidth with Activated I/Q Bandwidth Extension Option B500
Max. Sample Rate and Bandwidth with Activated I/Q Bandwidth Extension Option B500

The bandwidth extension option R&S FSW-B500 provides measurement bandwidths up to 500 MHz.

Sample rate | Maximum I/Q bandwidth
100 Hz to 600 MHz | proportional up to maximum 500 MHz
600 MHz to 10 GHz | 500 MHz
Bandwidths between 480 MHz and 500 MHz

Note the irregular behavior of the sample rate/usable I/Q bandwidth relationship for bandwidths between 480 MHz and 500 MHz, depending on which setting you change.

For compatibility reasons, the relationship of Usable I/Q bandwidth = 0.8 * Output sample rate is maintained for bandwidths ≤480 MHz.

However, in order to make use of the maximum possible sample rate of 600 MHz at the maximum bandwidth of 500 MHz, if you change the bandwidth between 480 MHz and 500 MHz, the sample rate is adapted according to the relationship Output sample rate = Usable I/Q bandwidth/0.833.

On the other hand, if you decrease the sample rate under 600 MHz, the I/Q bandwidth is adapted according to the regular relationship of Usable I/Q bandwidth = 0.8 * Output sample rate.

Relationship between maximum usable I/Q bandwidth and output sample rate for active R&S FSW-B500
Maximum record length with activated I/Q bandwidth extension option B500
Sample rate | Maximum record length
100 Hz to 10 GHz | 440 MSamples


Sample Rates and Bandwidths for Digital I/Q Data

MSRA Mode > Annex > Sample Rates and Bandwidths for Digital I/Q Data
Sample Rates and Bandwidths for Digital I/Q Data
Definitions
  • Clock rate: the rate at which data is physically transmitted between the R&S FSW and the connected instrument; both instruments must be able to process data at this rate; the clock rate of the R&S FSW at the output connector is 142.9 MHz; using the Digital I/Q enhanced mode, a data transfer rate of up to 200 Msps is possible
  • Input sample rate (ISR): the sample rate of the useful data provided by the connected instrument to the digital input
  • (User, Output) Sample rate (SR): the sample rate that is defined by the user (e.g. in the "Data Aquisition" dialog box in the "I/Q Analyzer" application) and which is used as the basis for analysis or sent to the digital output
  • Usable I/Q (Analysis) bandwidth: the bandwidth range in which the signal remains unchanged by the digital decimation filter and thus remains undistorted; this range can be used for accurate analysis by the R&S FSW
SlowI/Q measurements

When captured data is transferred and further processed with a slower rate than the rate with which the signal was sampled, this is referred to as a Slow I/Q measurement.

For example, assume an analog signal is sampled by an oscilloscope with a sample rate of 10 GHz. This data is stored in a memory temporarily and then transferred to the R&S FSW via the Digital I/Q Interface with a sample rate of 100R&S FSWMsps. Then the input sample rate on the R&S FSW must be set to 10 GHz so the signal is displayed correctly.

Digital I/Q enhanced mode

As of firmware version 1.80, an enhanced mode for processing data from the Digital Baseband Interface is available. This enhanced mode enables data transfer via the Digital I/Q interface with a data rate of up to 200 Msps (160 MHz bandwidth, compared to the previous 100 Msps/ 80 MHz bandwidth).

The Digital I/Q enhanced mode is automatically used if the following prerequisites are fulfilled:
  • Digital Input: The connected device must support data transfer rates up to 200 Msps.
  • Digital Output:
    – The R&S FSW must supply the required bandwidth, i.e. the bandwidth extension option R&S FSW-B160 or higher must be installed and active.
    – The connected device must support data transfer rates up to 200 Msps.
Restrictions for digital in- and output

The following table describes the restrictions for digital in- and output:

Restrictions for digital in- and output
Parameter | Minimum | Maximum
Record length | 2 complex samples | 220*1024*1024 complex samples
Input sample rate (ISR) | 100 Hz | 10 GHz
Sample Rate (SR) - Digital input | Max(100 Hz; ISR/8388608) | Min(10 GHz; 2*ISR)
Sample Rate (SR) - Digital output | 100 Hz | 200 MHz
Usable I/Q bandwidth (Digital input and filter active) | Min(0.8*SR; 0.8*ISR)
Bandwidths

Depending on the sample rate, the following bandwidths are available:

Bandwidths depending on sample rate for active digital input


List of Remote Commands (MSRA)

MSRA Mode > List of Remote Commands (MSRA)
List of Remote Commands (MSRA)
[SENSe:]ADJust:ALL
[SENSe:]ADJust:CONFigure:DURation
[SENSe:]ADJust:CONFigure:DURation:MODE
[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer
[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer
[SENSe:]ADJust:FREQuency
[SENSe:]ADJust:LEVel
[SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP:AUTO
[SENSe:]FREQuency:OFFSet
[SENSe:]IQ:BANDwidth|BWIDth:MODE
[SENSe:]IQ:BANDwidth|BWIDth:RESolution
[SENSe:]IQ:FFT:ALGorithm
[SENSe:]IQ:FFT:LENGth
[SENSe:]IQ:FFT:WINDow:LENGth
[SENSe:]IQ:FFT:WINDow:OVERlap
[SENSe:]IQ:FFT:WINDow:TYPE
[SENSe:]MSRA:CAPTure:OFFSet
[SENSe:]PROBe<ch>:SETup:CMOFfset
[SENSe:]PROBe<p>:ID:PARTnumber?
[SENSe:]PROBe<p>:ID:SRNumber?
[SENSe:]PROBe<p>:SETup:MODE
[SENSe:]PROBe<p>:SETup:NAME?
[SENSe:]PROBe<p>:SETup:STATe?
[SENSe:]PROBe<p>:SETup:TYPE?
[SENSe:]SWEep:POINts
[SENSe:]SWEep:TIME
ABORt
CALCulate:IQ:MODE
CALCulate:MSRA:ALINe:SHOW
CALCulate:MSRA:ALINe[:VALue]
CALCulate:MSRA:WINDow<n>:IVAL?
CALCulate<n>:MARKer<m>:FUNCtion:REFerence
CALibration:AIQ:DCOFfset:I
CALibration:AIQ:DCOFfset:Q
DIAGnostic:SERVice:NSOurce
DISPlay[:WINDow<n>]:TRACe:Y:SPACing
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MODE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition
FORMat[:DATA]
INITiate:CONMeas
INITiate:CONTinuous
INITiate:REFResh
INITiate:SEQuencer:ABORt
INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:MODE
INITiate:SEQuencer:REFResh[:ALL]
INITiate[:IMMediate]
INPut:ATTenuation
INPut:ATTenuation:AUTO
INPut:ATTenuation:PROTection:RESet
INPut:CONNector
INPut:COUPling
INPut:DIQ:CDEVice
INPut:DIQ:RANGe:COUPling
INPut:DIQ:RANGe[:UPPer]
INPut:DIQ:RANGe[:UPPer]:AUTO
INPut:DIQ:RANGe[:UPPer]:UNIT
INPut:DIQ:SRATe
INPut:DIQ:SRATe:AUTO
INPut:EATT
INPut:EATT:AUTO
INPut:EATT:STATe
INPut:FILTer:HPASs[:STATe]
INPut:FILTer:YIG[:STATe]
INPut:GAIN:STATe
INPut:GAIN[:VALue]
INPut:IMPedance
INPut:IQ:BALanced[:STATe]
INPut:IQ:FULLscale:AUTO
INPut:IQ:FULLscale[:LEVel]
INPut:IQ:TYPE
INPut:SELect
INSTrument:CREate:DUPLicate
INSTrument:CREate:REPLace
INSTrument:CREate[:NEW]
INSTrument:DELete
INSTrument:LIST?
INSTrument:MODE
INSTrument:REName
INSTrument[:SELect]
OUTPut:IF:IFFRequency
OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:LENGth
STATus:OPERation:CONDition?
STATus:OPERation:ENABle?
STATus:OPERation:NTRansition?
STATus:OPERation:PTRansition?
STATus:OPERation[:EVENt]?
SYSTem:PRESet:CHANnel[:EXECute]
SYSTem:PRESet:COMPatible
SYSTem:SEQuencer
TRACe:IQ:APCon:A
TRACe:IQ:APCon:B
TRACe:IQ:APCon:RESult?
TRACe:IQ:APCon[:STATe]
TRACe:IQ:BWIDth
TRACe:IQ:DATA:FORMat
TRACe:IQ:DATA:MEMory?
TRACe:IQ:DATA?
TRACe:IQ:RLENgth
TRACe:IQ:SRATe
TRACe:IQ:TPISample?
TRACe:IQ:WBANd:MBWIDTH
TRACe:IQ:WBANd[:STATe]
TRIGger[:SEQuence]:BBPower:HOLDoff
TRIGger[:SEQuence]:DTIMe
TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:LEVel:BBPower
TRIGger[:SEQuence]:LEVel:IFPower
TRIGger[:SEQuence]:LEVel:IQPower
TRIGger[:SEQuence]:LEVel:RFPower
TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SOURce
TRIGger[:SEQuence]:TIME:RINTerval


Legal Notice

R&S®FSW MSRA
Multi-Standard Radio Analyzer

© 2014 Rohde & Schwarz GmbH & Co. KG

Mühldorfstr. 15, 81671 München, Germany

Phone: +49 89 41 29 - 0

Fax: +49 89 41 29 12 164

E-mail: info@rohde-schwarz.com

Internet: www.rohde-schwarz.com

Subject to change – Data without tolerance limits is not binding.

R&S® is a registered trademark of Rohde & Schwarz GmbH & Co. KG.

Trade names are trademarks of the owners.